LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   xwmconfig becomes funny! (http://www.linuxquestions.org/questions/slackware-14/xwmconfig-becomes-funny-4175431078/)

688a 10-08-2012 03:57 AM

xwmconfig becomes funny!
 
Hi there,

I've just found this funny characters on my xwmconfig. It happens on the text mode, and it is ok in the terminal. I think it's something related to the encoding, but I can't recall what I did...
Any idea how to fix it?

http://farm9.staticflickr.com/8038/8...7bc6ec88ae.jpg

Thx.

Didier Spaier 10-09-2012 01:11 PM

What says "echo $LANG"?

688a 10-09-2012 09:21 PM

I know what I've done to mess the xwmconfig. I'd edited the /etc/profile.d/lang.sh and set
from
Quote:

export LANG=en_US
to
Quote:

export LANG=en_US.UTF-8
I did it because the system didn't show the Chinese and Japanese characters!

What can I do to show the characters without setting the $LANG? :confused:

titopoquito 10-10-2012 03:06 AM

Quote:

Originally Posted by 688a (Post 4801738)
I know what I've done to mess the xwmconfig. I'd edited the /etc/profile.d/lang.sh and set
from

to


I did it because the system didn't show the Chinese and Japanese characters!

What can I do to show the characters without setting the $LANG? :confused:

Have you tried setting the locale to utf8 AND adding a line "unicode_start" to /etc/rc.d/rc.local?

kabamaru 10-10-2012 03:37 AM

I have edited lang.sh to use UTF-8 like you did and xwmconfig runs fine. Do you have this line in your /etc/lilo.conf?

Code:

append="vt.default_utf8=1"
or maybe you chose a custom font during installation?


All times are GMT -5. The time now is 05:24 AM.