LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-15-2005, 02:55 AM   #1
locke105
LQ Newbie
 
Registered: Dec 2004
Distribution: Slackware 10
Posts: 9

Rep: Reputation: 0
xserver not starting


i recently loaded slack onto a rather old pentium 166mhz box i found lying around. i got everything installed fine and it boots up but when i try to run xorg (startx) it runs and the screen blinks like it is working but then totally stops at a blank screen. i cant use ctrl alt del or switch back to any other terminals so it pretty much freezes but there appear to be no errors in the xorg.0.log file

i've been trying to go to KDE but i tried some other window managers as well and they dont seem to make a difference. same crash when running startx...
 
Old 03-15-2005, 03:16 AM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
A) How much memory does this computer have?
B) Look in /var/log. In messages or an XFree86 log may contain information you need.
C) The same thing can happen if the video isn't set up right.
Try editing the X windows configuration file ( XF86Config or XOrg.conf in the /etc/X11/ directory ). Change the video driver to 'vesa' unless you have an ancient video card that can only handle VGA.
D) Generate conservative mode-lines to use.
ex) gtf 800 600 60 -x
gtf 1024 786 60 -x

Good Luck.
 
Old 03-15-2005, 03:34 AM   #3
locke105
LQ Newbie
 
Registered: Dec 2004
Distribution: Slackware 10
Posts: 9

Original Poster
Rep: Reputation: 0


A) 16 megs... 200 meg swap if that makes a difference
B) in messages i have an error as follows

kernel: __alloc_pages: 0-order allocation failed (gfp=0xf0/0)

and some others that are similiar (__alloc_pages: 0-order allocation failed...)
not sure what that means...

also in syslog i find this

modprobe: modprobe: Can't locate module char-major-10-134
kernel: VM: killing process xkbcomp
kernel: VM: killing process X

that seems like a problem...but i'm not sure what to do about it...

C) as for video modes, i have tried just about everything. even put it in VGA mode and it still does the same thing

D) have no ideas what 'gtf' is supposed to do but i'll look into it...
 
Old 03-25-2005, 06:07 AM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
I think that you need more memory to be able to run KDE.
 
Old 03-25-2005, 06:56 AM   #5
RestInPieces
Member
 
Registered: Aug 2004
Location: In front of a CRT monitor
Distribution: Slackware-current
Posts: 108

Rep: Reputation: 15
Try installing an older version of Slackware/KDE, maybe Kde 3.2 requests too much memory...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error in starting XServer in 2.6.12.1 kernel thandermax Linux - Software 1 06-27-2005 11:59 AM
Error in starting XServer in 2.6.12.1 kernel thandermax Linux - Newbie 1 06-27-2005 06:39 AM
Xserver not starting meenalborkar Red Hat 5 03-04-2005 07:25 PM
XServer not starting. velan Red Hat 1 05-10-2004 06:05 AM
stopping xserver from starting up? Zaskar Debian 17 03-20-2004 06:59 PM


All times are GMT -5. The time now is 03:18 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration