LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-04-2006, 06:45 PM   #1
BloodiedMind
LQ Newbie
 
Registered: Mar 2006
Posts: 7

Rep: Reputation: 0
Xorgsetup with KDE running -> No display manager


I just read about xorgsetup, and when I ran it had completely forgot about kdm running in f7 (I was in console in f6 I believe). It worked fine, and I hit "yes" to "Rename old xorg.conf file to xorg.conf.backup". The next step told me it was running, and created an error-file it told me to remove when I next started it up.
Now when I attempt to log into kde (The graphical login works) it tells me it doesn't have write access to $home/flux and xserver won't start.
When I decided to run "startx" it came up with a huge list of errors. I'm not entirely sure what to do now, short of just reinstalling X and KDE from the installation cd's.

I just went in with a MEPIS livecd and there's no xorg.conf.backup like it said there would be, and the xorg.conf seems fine regardless. Now I have no clue why I can't get any kind of windows manager running, and just when I was close to actually getting my wireless working.

I can't really get logs of what happens (Not any way that I know of, if nothing else) so I can't exactly say what happens.
 
Old 03-04-2006, 06:53 PM   #2
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 66
Boot to your CLI (Ctrl-Alt-F6), login as 'root',run 'xorgsetup' again, and reboot. Should work fine then, or you can run 'xorgconfig'.
 
Old 03-04-2006, 07:27 PM   #3
BloodiedMind
LQ Newbie
 
Registered: Mar 2006
Posts: 7

Original Poster
Rep: Reputation: 0
No go.

When I boot up - It goes into KDE's graphical login. I use Ctrl+Alt+f6 and go into the console.

When I run "xorgsetup" I end up with:
"Fatal Server Error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock and try again.

Which was my initial error. I'm assuming that's because Kde's login is still open on f7. I'm not sure how to close that, and run xorgsetup properly.
Also - I'm not really sure what it means by no write access to $home/flux

Any help appreciated,
BloodiedMind
 
Old 03-04-2006, 08:01 PM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Su to root after Ctrl-Alt-F6 and enter use the init command to enter the mode for multiuser w/o X. I don't know what Slackware uses for that Run Level, but the comments in /etc/inittab will tell you. It's the equivalent of init level 3 on other distros.
 
Old 03-04-2006, 09:18 PM   #5
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Rep: Reputation: 32
hope the problem is because a x was working while u try xorgsetup

do one thing at the console, as root, type telinit 3, now u r in runlevel 3, no x aps or services are working, run xorg setup

once u r in ur console edit the /etc/inittab file and edit the "default" line ---> is from 4 to 3
so tht in next boot it wil go to console only, after correcting ur x problem u can change to 4 later.
Quote:
I just went in with a MEPIS livecd
at the lilo prompt even u can boot into ur machine by typing "linux single" at the boot: promt(if linux is the label in lilo.conf)

xwmconfig ---for choosing diff guis
 
Old 03-04-2006, 09:33 PM   #6
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Rep: Reputation: 32
hope the problem is because a x was working while u try xorgsetup(slacks default runlevel is 3 so wo cahnged tht to 4?)

do one thing at the console, as root, type telinit 3, now u r in runlevel 3, no x aps or services are working, run xorg setup

once u r in ur console edit the /etc/inittab file and edit the "default" line ---> from 4 to 3
so tht in next boot it wil go to console only, after correcting ur x problem u can change to 4 later.
Quote:
I just went in with a MEPIS livecd
at the lilo prompt even u can boot into ur machine by typing "linux single" at the boot: promt(if linux is the label in lilo.conf)

or use the slack installation disk to boot into ur slack machine at hte boot prompt(if u know hte root partition-from output of fdisk -l)
boot: bare.i root=/dev/hda1 noinitrd ro

xwmconfig ---for choosing diff guis

Last edited by rkrishna; 03-04-2006 at 10:19 PM.
 
Old 03-05-2006, 09:47 AM   #7
BloodiedMind
LQ Newbie
 
Registered: Mar 2006
Posts: 7

Original Poster
Rep: Reputation: 0
Nope...

I went in, changed the inittab to runlevel 3 and ran xorgsetup. It only gave me one option - That of color depth and then said it was finished. I'm not sure why it didn't do anything else, but whatever.
When I rebooted and tried to login via kde's login, I get the same error. The little window that shows login process will show up, but stop at interprocess communication (the first graphic) and a message about no write access to $home/flux.

I'm not entirely sure what this actually means, and I don't recall ever changing any kind of permissions. I really wish I hadn't have run xorgsetup. Ahh well, live and learn. If I could fix it, it would probably be much better than a reinstall, though if necessary I would (I have doubts it would be necessary regardless).

Any help appreciated,
BloodiedMind
 
Old 03-05-2006, 09:43 PM   #8
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
I'm wondering if there is a problem with your home partition. When linux boots up originaly the partitions are mounted read-only and are checked for errors. If there is a problem at that stage, perhaps they are still mounted read-only. Other than that, you will need to look in the Xorg.0.log and find out if there are any problems indicated there.

Also, if you log in as root, can you run startx successfully? If you changed to a non-graphical init level, you shouldn't have seen a graphical log-in screen. Please check the comments on the /etc/telinit file, because Slackware's init levels may be different. On my system, 3 would be correct for this mode. 5 is for the graphical login.
You can use the init or telinit program to change to the runlevel you want instead of editing the telinit file.

Last edited by jschiwal; 03-05-2006 at 09:49 PM.
 
Old 03-05-2006, 10:30 PM   #9
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,191

Rep: Reputation: 548Reputation: 548Reputation: 548Reputation: 548Reputation: 548Reputation: 548
Try running xorgconfig at run level three. That should allow you to over-write any mistakes in your xorgconfig file. Graphical log-in for slack is run level 4 not 5.
 
Old 03-05-2006, 11:52 PM   #10
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Rep: Reputation: 32
Quote:
I went in, changed the inittab to runlevel 3 and ran xorgsetup.
tht wil work only when u reboot after changing inittab
if u r runnning x or any x application tht means u r in run level 4, for going to run levl 3 without rebooting try "telint 3" as root
Quote:
When I rebooted and tried to login via kde's login,
how came u end up with kde login if the sytem run level is 3 ??
u wil be in a text mode only at tty1(if ur default runlevel is 3), u have to manually start the x server by giving the "startx" command, and u wont see any kde login window(kdm) or gnome (gdm)or xdm

i asked u to try "telinit 3"--> while u r in ur X
if u r getting graphical login that means u r in runlevl 4, so for best fixxing the x configuration, change the runlevel to 3 in /etc/inittab(if u r rebooting)
------
# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault: ---->change to this if it is 4
-------------
Quote:
I really wish I hadn't have run xorgsetup
dont b like this everything wil b right
what graphix card u r having (can u post the result of lspci)
 
Old 03-06-2006, 12:23 AM   #11
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 66
And run 'xorgsetup' or 'xorgconfig' as root, nat as a user
 
Old 03-08-2006, 02:29 PM   #12
BloodiedMind
LQ Newbie
 
Registered: Mar 2006
Posts: 7

Original Poster
Rep: Reputation: 0
Well then...

I went in and reformatted Slackware (I entirely forgot to check this thread beforehand) but alas, the problem rose again. This time through I did a full install, formatted -every- Linux partition with a slow format and haven't run Xorgsetup/Xorgconfig. Yesterday I rebooted-shutdown (When I run "shutdown now" it will display the message but do nothing...), and when I attempted to boot it up today, I'm getting the same error.
It's a fresh install, too.

Edit: I forgot to note that my default Runlevel is 3, and KDE is my preferred Window Manager (until I get everything running stable, then I'll probably switch to Fluxbox).
It tells me it can't create an Xauthority file (it time-outs 3 or so times) and then attempts to run KDE regardless. KDE stops at the first login step and the error message is actually behind the KDE login. I'm assuming it's the same "No write access to $Home$flux, though.

I'm running a PIII coppermine, 256 mb of ram and Nvidia TNT Riva/Pro graphics card.
I'm actually fairly close to getting my wireless to working I believe, but given that I can't even log in or anything, it's a bit of a hinderence.

Any help appreciated,
BloodiedMind

Last edited by BloodiedMind; 03-08-2006 at 02:36 PM.
 
Old 03-08-2006, 10:45 PM   #13
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Rep: Reputation: 32
Quote:
shutdown now
i dont know wether this command works or not but
this one will "shutdown -r now", "-r" is the option, for halting "-h 0"
Quote:
Nvidia TNT Riva/Pro graphics card
i think this is the problem
u could have mention it earlier, i think u download a new driver from nvidia site and run it there are many threads dealing the same issue,

dont be hurry to startx, make a compactible module and run
xwmconfig and choose fluxbox or xfce, (to check wether this is working), then go to kde.
 
Old 03-09-2006, 03:29 PM   #14
BloodiedMind
LQ Newbie
 
Registered: Mar 2006
Posts: 7

Original Poster
Rep: Reputation: 0
I don't think it's the graphics card, as I have run KDE on both installations fine for the first bit. When I reboot it seems to mess up with the
No write access to $home/flux.
I'm not sure why this is even happening, it might have been different if I had never been able to properly run KDE in the first place, but it randomly doing that is just irritating.
/$home/flux is on another partition, could that be a potential issue?
It also times out creation of a Xauthority file, which I assume is just because it has no write access.

Edit: Missed the part about using fluxbox or Xfce, I'll go try that in a minute and report back with what happens.

Last edited by BloodiedMind; 03-09-2006 at 03:30 PM.
 
Old 03-09-2006, 04:06 PM   #15
BloodiedMind
LQ Newbie
 
Registered: Mar 2006
Posts: 7

Original Poster
Rep: Reputation: 0
xwmconfig won't even work, as X cannot create a directory on /home/flux, and so it will not run.
So I can't even attempt to use Fluxbox (which more than likely would not work, I would assume).
I am using Reiserfs on both my main partition and /home partition, if that would make any difference.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
display manager crashes/wont start (KDE) Avatar Linux - General 3 11-01-2005 09:46 AM
Where is xwmconfig and xorgsetup appliction? intmail Slackware 1 07-20-2005 07:26 AM
xorgconfig and xorgsetup phantom1nc Slackware - Installation 5 01-28-2005 03:56 PM
xorgsetup WilliamS Slackware 4 09-14-2004 12:09 PM
Display Manager aikempshall Mandriva 2 02-12-2004 03:11 PM


All times are GMT -5. The time now is 05:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration