LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 02-16-2005, 09:01 AM   #1
DraaX
Member
 
Registered: Jul 2003
Location: B.C. Canada
Distribution: Slackware 14
Posts: 94

Rep: Reputation: 15
xorgconfig set up xorg.conf wrong


Good morning Slackers!!

I have just recently installed Slack 10.1 with the default kernel. I ran xorgsetup, and then ran xorgconfig. When it came to the option asking whether I wanted to have a screen larger than mine and so it pans when I move the mouse. I SAID NO. I downloaded and installed the newest Nvidia drivers and edited my xorg.conf accordingly.

Whenever I "startx" X loads but I get a large resolution but the screen pans!!! This is so frustrating. I have ran xorgconfig a couple of more time and said no to the option that I think is in quetion. So I guess that I have to edit it manually but can not find the option.

Basically my question is, what is the option in my xorg.conf that will change the panning large screen to just a non-panning screen? Also how do I choose the default resolution?

Thanks in advance for your help!
 
Old 02-16-2005, 09:15 AM   #2
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 57
can u post ur xorg.conf here

also the last question asked by xorconfig is about which xorg.conf file to write,just keep that in mind

regards
 
Old 02-16-2005, 09:23 AM   #3
DraaX
Member
 
Registered: Jul 2003
Location: B.C. Canada
Distribution: Slackware 14
Posts: 94

Original Poster
Rep: Reputation: 15
I am at work now so can not post my xorg.conf till I get home.
 
Old 02-16-2005, 09:29 AM   #4
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
XORG

You have to find the xorg.conf /etc/X11/xorg.conf and edit it accordingly. You can choose the default resolution in xorgconfig when it comes to choosing the values for colors and resolution. You have modes 1024x768 and 800x600 at 24 bit. You probably chose OK and proceeded. You can change them there, so that the biggest value is the one you want and then proceed. If you have any more questions, ask them here.
 
Old 02-16-2005, 10:29 AM   #5
DraaX
Member
 
Registered: Jul 2003
Location: B.C. Canada
Distribution: Slackware 14
Posts: 94

Original Poster
Rep: Reputation: 15
Just curious as to what determines that a specific resolution is default? Also what setting determines that I have a panning screen or not?
 
Old 02-16-2005, 10:55 AM   #6
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 57
this is from my xorg.conf

Subsection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection


the order keeps the display

th first one is default

regadrs
 
Old 02-16-2005, 12:00 PM   #7
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
I used to get this with the nvidia drivers, but the newer versions don't seem to do it as much as the older ones? anyway, the way I used to force X to stop panning the screen is by adding a virtual line like this:

Subsection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
Virtual 1024 768 ( or whatever res. you want by default)
EndSubsection
EndSection
 
Old 02-16-2005, 12:34 PM   #8
DraaX
Member
 
Registered: Jul 2003
Location: B.C. Canada
Distribution: Slackware 14
Posts: 94

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by __J
I used to force X to stop panning the screen is by adding a virtual line like this:

Subsection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
Virtual 1024 768 ( or whatever res. you want by default)
EndSubsection
EndSection
Thats ounds like what I am looking for. So by adding the Virtual line I will kill both birds with one stone. This should set up my default resolution and stop the annoying panning, right?

I will be testing this when I get home.

draAx
 
Old 02-16-2005, 12:38 PM   #9
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
yes it always worked very well for me, I'm not sure exactly why this problem occurs. It didn't seem to matter whether I told xorgconfig to enable virtual desktops or not, I always ended up with one. But now with different drivers from nvidia ( I use 6111 ) I no longer get this???
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Screen Resolution problems connected with xorg.conf and xorgconfig with Slackware 10 tvisher Linux - Newbie 17 04-03-2007 07:39 AM
xorgconfig; wrong choice won't allow me to use X simeandrews Mandriva 1 03-23-2005 02:29 PM
can't get xorg.conf set correctly lnxmacusr Slackware 3 12-29-2004 06:40 PM
A Quick Xorg.conf set up mikz Slackware 1 10-25-2004 07:40 PM
Xorg Hard Crashes and corrupts xorg.conf Advocator Linux - General 0 07-15-2004 01:41 PM


All times are GMT -5. The time now is 11:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration