LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   xorg will not start because of video driver. (http://www.linuxquestions.org/questions/slackware-14/xorg-will-not-start-because-of-video-driver-4175443406/)

FeyFre 12-29-2012 03:35 PM

xorg will not start because of video driver.
 
Hi

Suddenly it is appeared I cannot start X.
After startx I got Xorg.0.log
Code:

[  846.116]
X.Org X Server 1.12.3
Release Date: 2012-07-09
[  846.116] X Protocol Version 11, Revision 0
[  846.116] Build Operating System: Slackware 14.0 Slackware Linux Project
[  846.116] Current Operating System: Linux pywlinux 3.2.29-smp #1 SMP Mon Sep 17 13:02:10 CDT 2012 i686
[  846.116] Kernel command line: BOOT_IMAGE=Linux-G root=804 vt.default_utf8=1
[  846.116] Build Date: 23 August 2012  02:27:55PM
[  846.116] 
[  846.116] Current version of pixman: 0.26.2
[  846.116]        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[  846.116] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  846.116] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Dec 29 18:04:48 2012
[  846.116] (==) Using config file: "/etc/X11/xorg.conf"
[  846.116] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  846.116] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  846.117] (==) ServerLayout "Layout0"
[  846.117] (**) |-->Screen "Screen0" (0)
[  846.117] (**) |  |-->Monitor "Monitor0"
[  846.117] (**) |  |-->Device "Device0"
[  846.117] (**) |-->Input Device "Keyboard0"
[  846.117] (**) |-->Input Device "Mouse0"
[  846.117] (==) Automatically adding devices
[  846.117] (==) Automatically enabling devices
[  846.117] (WW) The directory "/usr/share/fonts/CID" does not exist.
[  846.117]        Entry deleted from font path.
[  846.117] (**) FontPath set to:
        /usr/lib/X11/fonts/local/,
        /usr/lib/X11/fonts/misc/:unscaled,
        /usr/lib/X11/fonts/100dpi/:unscaled,
        /usr/lib/X11/fonts/75dpi/:unscaled,
        /usr/lib/X11/fonts/misc/,
        /usr/lib/X11/fonts/Type1/,
        /usr/lib/X11/fonts/Speedo/,
        /usr/lib/X11/fonts/100dpi/,
        /usr/lib/X11/fonts/75dpi/,
        /usr/lib/X11/fonts/cyrillic/,
        /usr/lib/X11/fonts/TTF/,
        /usr/share/fonts/local,
        /usr/share/fonts/TTF,
        /usr/share/fonts/OTF,
        /usr/share/fonts/Type1,
        /usr/share/fonts/misc,
        /usr/share/fonts/75dpi/:unscaled,
        /usr/share/fonts/100dpi/:unscaled,
        /usr/share/fonts/75dpi,
        /usr/share/fonts/100dpi,
        /usr/share/fonts/cyrillic
[  846.117] (==) ModulePath set to "/usr/lib/xorg/modules"
[  846.117] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  846.117] (WW) Disabling Keyboard0
[  846.117] (WW) Disabling Mouse0
[  846.117] (II) Loader magic: 0x821ea00
[  846.117] (II) Module ABI versions:
[  846.117]        X.Org ANSI C Emulation: 0.4
[  846.117]        X.Org Video Driver: 12.0
[  846.117]        X.Org XInput driver : 16.0
[  846.117]        X.Org Server Extension : 6.0
[  846.118] (--) PCI:*(0:2:0:0) 10de:0849:1043:82f2 rev 162, Mem @ 0xfa000000/16777216, 0xd8000000/134217728, 0xd6000000/33554432, I/O @ 0x0000ec00/128, BIOS @ 0x????????/131072
[  846.118] (II) Open ACPI successful (/var/run/acpid.socket)
[  846.118] (II) LoadModule: "extmod"
[  846.118] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[  846.118] (II) Module extmod: vendor="X.Org Foundation"
[  846.118]        compiled for 1.12.3, module version = 1.0.0
[  846.118]        Module class: X.Org Server Extension
[  846.118]        ABI class: X.Org Server Extension, version 6.0
[  846.118] (II) Loading extension MIT-SCREEN-SAVER
[  846.118] (II) Loading extension XFree86-VidModeExtension
[  846.118] (II) Loading extension XFree86-DGA
[  846.118] (II) Loading extension DPMS
[  846.118] (II) Loading extension XVideo
[  846.118] (II) Loading extension XVideo-MotionCompensation
[  846.118] (II) Loading extension X-Resource
[  846.118] (II) LoadModule: "dbe"
[  846.118] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[  846.119] (II) Module dbe: vendor="X.Org Foundation"
[  846.119]        compiled for 1.12.3, module version = 1.0.0
[  846.119]        Module class: X.Org Server Extension
[  846.119]        ABI class: X.Org Server Extension, version 6.0
[  846.119] (II) Loading extension DOUBLE-BUFFER
[  846.119] (II) LoadModule: "glx"
[  846.119] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  846.145] (II) Module glx: vendor="NVIDIA Corporation"
[  846.145]        compiled for 4.0.2, module version = 1.0.0
[  846.145]        Module class: X.Org Server Extension
[  846.145] (II) NVIDIA GLX Module  275.09.07  Wed Jun  8 16:01:21 PDT 2011
[  846.145] (II) Loading extension GLX
[  846.145] (II) LoadModule: "record"
[  846.145] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[  846.145] (II) Module record: vendor="X.Org Foundation"
[  846.145]        compiled for 1.12.3, module version = 1.13.0
[  846.145]        Module class: X.Org Server Extension
[  846.145]        ABI class: X.Org Server Extension, version 6.0
[  846.145] (II) Loading extension RECORD
[  846.145] (II) LoadModule: "dri"
[  846.146] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[  846.146] (II) Module dri: vendor="X.Org Foundation"
[  846.146]        compiled for 1.12.3, module version = 1.0.0
[  846.146]        ABI class: X.Org Server Extension, version 6.0
[  846.146] (II) Loading extension XFree86-DRI
[  846.146] (II) LoadModule: "dri2"
[  846.146] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[  846.146] (II) Module dri2: vendor="X.Org Foundation"
[  846.146]        compiled for 1.12.3, module version = 1.2.0
[  846.146]        ABI class: X.Org Server Extension, version 6.0
[  846.146] (II) Loading extension DRI2
[  846.146] (II) LoadModule: "nvidia"
[  846.146] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[  846.146] (II) Module nvidia: vendor="NVIDIA Corporation"
[  846.146]        compiled for 4.0.2, module version = 1.0.0
[  846.146]        Module class: X.Org Video Driver
[  846.146] ================ WARNING WARNING WARNING WARNING ================
[  846.147] This server has a video driver ABI version of 12.0 that is not
supported by this NVIDIA driver.  Please check
http://www.nvidia.com/ for driver updates or downgrade to an X
server with a supported driver ABI.
[  846.147] =================================================================
[  846.147] (EE) NVIDIA: Use the -ignoreABI option to override this check.
[  846.147] (II) UnloadModule: "nvidia"
[  846.147] (II) Unloading nvidia
[  846.147] (EE) Failed to load module "nvidia" (module requirement mismatch, 0)
[  846.147] (EE) No drivers available.
[  846.147]
Fatal server error:
[  846.147] no screens found
[  846.147]
Please consult the The X.Org Foundation support
        at http://wiki.x.org
 for help.
[  846.147] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  846.147]

System is stock Slackware 14 (upgraded from 13.37), plus NVidia driver 275.09.07 (have GeForce 8200 integrated video)
In 13.37 it worked.
Tried to install Nvidia drivers from SBo - nothing changes.
What to do?

Alien Bob 12-29-2012 05:07 PM

Quote:

Originally Posted by FeyFre (Post 4859186)
Hi

Suddenly it is appeared I cannot start X.

System is stock Slackware 14 (upgraded from 13.37), plus NVidia driver 275.09.07 (have GeForce 8200 integrated video)

Why this old driver? It is probably too old for the X.Org server of Slackware 14. The latest Nvidia driver version 310.19 still lists the 8200 as a supported product:
Code:

GeForce 8 series:
8800 Ultra, 8800 GTX, 8800 GTS 512, 8800 GTS, 8800 GT, 8800 GS, 8600 GTS, 8600 GT, 8600 GS, 8500 GT, 8400 SE, 8400 GS, 8400, 8300 GS, 8300, 8200, 8100 / nForce 720a

Eric

FeyFre 12-30-2012 05:16 PM

Yes, I already tried that, but result was poor. nvidia-switch --remove was failing because of absence some GL libraries and whole update process stuck.
I thought problem was in that broken libraries. Now I decided to not to pay attention to those message, reinstalled glew and mesa packages(in order to be sure), removed 275.* driver and installed newer version as you suggested.
For now it works. Thanks.
(And have other problem - to wipe out from system uncontrolled by pkgtool files left after my experiments).


All times are GMT -5. The time now is 11:11 AM.