LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 09-10-2012, 12:43 AM   #16
dc_eros
Member
 
Registered: Nov 2006
Distribution: Slackware
Posts: 292

Original Poster
Rep: Reputation: 39

Not sure if this is related, but sometimes I see some graphical artifacts on the screen. Please see attached.
Attached Images
File Type: png snapshot1.png (14.6 KB, 16 views)
 
Old 09-10-2012, 05:20 AM   #17
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
I think Xorg may be the cause.

I recently found a 'Video Memory Stress Test' on the UBCD. You may want to try it in case it is a hardware issue. See the link in my sig.
 
Old 09-10-2012, 09:25 AM   #18
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Here are some more reports of EQ overflow:
https://bugs.launchpad.net/ubuntu/+s...ux/+bug/567696
https://bugzilla.redhat.com/show_bug.cgi?id=465884
https://bugs.freedesktop.org/show_bug.cgi?id=15473

EDIT:
I have an idea, try adding this to /etc/X11/xorg.conf

Code:
Section "Module"
	SubSection  "extmod"
		Option    "omit xfree86-dga"   # don't initialise the DGA extension
	EndSubSection
EndSection
I have done it and will see if it fixes it.

Last edited by H_TeXMeX_H; 09-10-2012 at 09:31 AM.
 
Old 09-10-2012, 09:36 AM   #19
gazj
Member
 
Registered: Oct 2010
Location: Cambs, England, UK
Distribution: Slackware 14
Posts: 33

Rep: Reputation: 6
Have added it to my xorg.conf. This is still doing this in 14RC4 for me. Surely this should be fixed before 14 is released? It will be a major show stopper for many!
 
Old 09-10-2012, 09:42 AM   #20
gazj
Member
 
Registered: Oct 2010
Location: Cambs, England, UK
Distribution: Slackware 14
Posts: 33

Rep: Reputation: 6
I have the xfce Compositor running, maybe thats why I am having problems with Xfce when others are not. Reading the bug reports you linked to having a compositor makes this issue more prominent. I will leave it turned on for now, with the xorg.conf fix you mentioned above and see if the situation improves.

Fingers crossed
 
Old 09-10-2012, 10:33 AM   #21
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Another thing I just did as suggested in the xorg bug report was to increase QUEUE_SIZE in mieq.c to 4096 and recompile Xorg using the slackbuild. Just a note that Xorg must be suid root. So, 'chmod u+s /usr/bin/Xorg' after installing if needed.

Hopefully one of these fixes will work.

Last edited by H_TeXMeX_H; 09-10-2012 at 10:34 AM.
 
Old 09-11-2012, 03:19 PM   #22
gazj
Member
 
Registered: Oct 2010
Location: Cambs, England, UK
Distribution: Slackware 14
Posts: 33

Rep: Reputation: 6
Although since the xorg.conf fix (touch wood) I haven't had any problems. Could this be relevent in todays changelog.

Quote:
a/udev-182-x86_64-5.txz: Rebuilt. Don't enable autosuspend for some HID devices. With a 3.5+ kernel, this might cause these input devices to become non-responsive. Thanks to Patrick Verner.
 
Old 09-11-2012, 03:25 PM   #23
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Yes, I saw it too, but I'm running 3.4.x right now, and current is running 3.2.x. I'm not sure if this is causing it. It also happened with earlier 3.x kernels.
 
Old 09-11-2012, 04:22 PM   #24
gazj
Member
 
Registered: Oct 2010
Location: Cambs, England, UK
Distribution: Slackware 14
Posts: 33

Rep: Reputation: 6
Ahh yes, didn't read it properly did I. I am running 3.2.28. Duh!
 
Old 09-15-2012, 05:21 AM   #25
gazj
Member
 
Registered: Oct 2010
Location: Cambs, England, UK
Distribution: Slackware 14
Posts: 33

Rep: Reputation: 6
Damm, it was going so well up till now. Going to turn my window manager compositer off and see how things go.
 
Old 09-16-2012, 09:35 AM   #26
dc_eros
Member
 
Registered: Nov 2006
Distribution: Slackware
Posts: 292

Original Poster
Rep: Reputation: 39
Just upgraded to latest current. Experienced frequent lockups in the middle of light web development work. Just switched to XFCE for now (from KDE).
 
Old 10-28-2012, 02:13 AM   #27
dc_eros
Member
 
Registered: Nov 2006
Distribution: Slackware
Posts: 292

Original Poster
Rep: Reputation: 39
Today, I enabled effects/animations on KDE and do some stress test on my machine. Opening several js heavy sites on firefox and google chrome while downloading the latest update/patch on 14.0, playing youtube, etc. My machine survives. Before, it couldn't survive this kind of load.

Probably a KDE problem.

I'm enjoying the animations anyway.
 
Old 12-13-2012, 08:30 AM   #28
IamaHack
LQ Newbie
 
Registered: May 2012
Distribution: Currently doing embedded linux so.... Buildroot? ;-)
Posts: 8

Rep: Reputation: Disabled
Same problem On Fedora

For what it's worth, I have experienced the same lockup with Xorg on Fedora Core 14:
[1470056.288] [mi] EQ overflowing. The server is probably stuck in an infinite loop.
etc...
However, every time I do experience it, I have been able to ssh into my FC14 machine from another machine and kill the instance of Xorg, though it seems that only SIGKILL works. I was hoping to find another way that won't kill the desktop but so far I haven't found any
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xorg: mouse and keyboard aren't responding Pluvius Linux - Newbie 0 03-11-2012 10:00 AM
[SOLVED] --current , xorg crashes and computer locks up ejecting optical drive Old_Fogie Slackware 4 12-22-2010 08:32 PM
recent dist-upgrade of xorg has killed my mouse (and thusly, xorg). Lokathor Debian 4 06-10-2006 05:52 AM
Help! slack 10 locks up when exiting xorg 6.7.0 wine Slackware 5 10-25-2004 11:15 PM
mouse not responding oDyman Linux - Hardware 1 04-25-2004 12:44 PM


All times are GMT -5. The time now is 10:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration