LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   xorg.conf screen resolution overridden by XFCE? (http://www.linuxquestions.org/questions/slackware-14/xorg-conf-screen-resolution-overridden-by-xfce-715817/)

songangel 03-31-2009 11:05 AM

xorg.conf screen resolution overridden by XFCE?
 
This might be a silly question, but I have to ask because it's driving me crazy.

I set my screen resolution to 1024x768 @ 75hz using the XFCE display manager. In addition I have all of my available screen resolutions set up in my xorg.conf file using modelines.

For some reason, when I type startx XFCE briefly starts up in 1280x860 or something before quickly changing to my chosen 1024x768 while the splash screen is displayed.

I am under the assumption that XFCE pulls the available modelines from xorg.conf but I may be wrong. I even tried making the 1024x768 the first choice under the relevant modeline in xorg.conf but that didn't help.

What am I missing?

rg3 04-01-2009 12:59 PM

I would double-check the xorg.conf file. According to the manpage:

Code:

      Modes  "mode-name" ...
              This optional entry specifies the list of video  modes  to  use.
              Each  mode-name  specified  must be in double quotes.  They must
              correspond to those specified or referenced in  the  appropriate
              Monitor  section  (including implicitly referenced built-in VESA
              standard -modes).  The server will delete modes  from  this  list
              which  don't satisfy various requirements.  The first valid mode
              in this list will be the default display mode for startup.  The
              list  of  valid  modes  is  converted internally into a circular
              list.  It  is  possible  to  switch  to  the  next  mode  with
              Ctrl+Alt+Keypad-Plus and to the previous mode with Ctrl+Alt+Key‐
              pad-Minus.  When this entry is omitted, the valid  modes  refer‐
              enced  by  the appropriate Monitor section will be used.  If the
              Monitor section contains no modes, then the  selection  will  be
              taken from the built-in VESA standard modes.

So X should start with the first valid resolution in the Modes line. Maybe you are editing the wrong line? There may be more than one.

After that, the desktop manager may change the resolution using the Randr X extension to something else. See the manpage for xrandr.

songangel 04-01-2009 06:12 PM

Thank you for responding, apparently this is a tough one. First let me say that xrandr doesn't seem to exist on my system.

Second, I have the default depth set to 16 with only one possible mode. See xorg.conf below:

Code:

Section "ServerLayout"
        Identifier    "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Mouse1" "SendCoreEvents"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        RgbPath      "/usr/share/X11/rgb"
        ModulePath  "/usr/lib/xorg/modules"
        FontPath    "/usr/share/fonts/TTF"
        FontPath    "/usr/share/fonts/OTF"
        FontPath    "/usr/share/fonts/Type1"
        FontPath    "/usr/share/fonts/misc"
        FontPath    "/usr/share/fonts/75dpi/:unscaled"
        FontPath    "/usr/share/fonts/webcore"
EndSection

Section "Module"
        Load  "xtrap"
        Load  "GLcore"
        Load  "record"
        Load  "dri"
        Load  "dbe"
        Load  "extmod"
        Load  "glx"
        Load  "freetype"
        Load  "type1"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel"  "dell101"
        Option      "XkbLayout"  "us"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option            "Protocol" "auto"
        Option            "Device" "/dev/input/mice"
        Option            "ZAxisMapping" "4 5 6 7"
EndSection

Section "InputDevice"
        Identifier "Mouse1"
        Driver "mouse"
        Option "Protocol" "PS/2"
        Option "Device" "/dev/j2m_fifo"
EndSection

Section "Monitor"
Identifier "DELL E207WFP"
Option "DPMS"
Modeline "1024x768" 147.14 1680 1972 2156 2248 1050 1051 1054 1087
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option    "ShadowFB"                  # [<bool>]
        #Option    "DefaultRefresh"            # [<bool>]
        #Option    "ModeSetClearScreen"        # [<bool>]
        Identifier  "Card0"
        Driver      "intel"
        VendorName  "Intel Corporation"
        BoardName  "82865G Integrated Graphics Controller"
        BusID      "PCI:0:2:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "DELL E207WFP"
DefaultDepth 16

SubSection "Display"
Depth 1
Modes "1680x1050" "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection

SubSection "Display"
Depth 4
Modes "1680x1050" "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection

SubSection "Display"
Depth 8
Modes "1680x1050" "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"

Depth 15
Modes "1680x1050" "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"

Depth 16
Modes "1024x768_75"
EndSubSection
SubSection "Display"

Depth 24
Modes "1680x1050" "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
EndSection


adriv 04-02-2009 04:16 AM

Quote:

Originally Posted by songangel (Post 3495464)
Thank you for responding, apparently this is a tough one. First let me say that xrandr doesn't seem to exist on my system.

Haven't you got xrandr installed?
What's the output of slocate xrandr?
Quote:

Originally Posted by songangel (Post 3495464)
Second, I have the default depth set to 16 with only one possible mode. See xorg.conf below:

Code:

Section "ServerLayout"
        Identifier    "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Mouse1" "SendCoreEvents"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        RgbPath      "/usr/share/X11/rgb"
        ModulePath  "/usr/lib/xorg/modules"
        FontPath    "/usr/share/fonts/TTF"
        FontPath    "/usr/share/fonts/OTF"
        FontPath    "/usr/share/fonts/Type1"
        FontPath    "/usr/share/fonts/misc"
        FontPath    "/usr/share/fonts/75dpi/:unscaled"
        FontPath    "/usr/share/fonts/webcore"
EndSection

Section "Module"
        Load  "xtrap"
        Load  "GLcore"
        Load  "record"
        Load  "dri"
        Load  "dbe"
        Load  "extmod"
        Load  "glx"
        Load  "freetype"
        Load  "type1"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel"  "dell101"
        Option      "XkbLayout"  "us"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option            "Protocol" "auto"
        Option            "Device" "/dev/input/mice"
        Option            "ZAxisMapping" "4 5 6 7"
EndSection

Section "InputDevice"
        Identifier "Mouse1"
        Driver "mouse"
        Option "Protocol" "PS/2"
        Option "Device" "/dev/j2m_fifo"
EndSection

Section "Monitor"
Identifier "DELL E207WFP"
Option "DPMS"
Modeline "1024x768" 147.14 1680 1972 2156 2248 1050 1051 1054 1087
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option    "ShadowFB"                  # [<bool>]
        #Option    "DefaultRefresh"            # [<bool>]
        #Option    "ModeSetClearScreen"        # [<bool>]
        Identifier  "Card0"
        Driver      "intel"
        VendorName  "Intel Corporation"
        BoardName  "82865G Integrated Graphics Controller"
        BusID      "PCI:0:2:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "DELL E207WFP"
DefaultDepth 16

SubSection "Display"
Depth 1
Modes "1680x1050" "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection

SubSection "Display"
Depth 4
Modes "1680x1050" "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection

SubSection "Display"
Depth 8
Modes "1680x1050" "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"

Depth 15
Modes "1680x1050" "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"

Depth 16
Modes "1024x768_75"
EndSubSection
SubSection "Display"

Depth 24
Modes "1680x1050" "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
EndSection


If you have xrandr installed (and working), you can put
xrandr -s 1024x768 in your .xintrc file (somewhere on the top of the file). That should do the trick.

songangel 04-02-2009 11:51 AM

Hmmm
 
I checked and libxrandr is installed but not the xrandr package. I will install it tonight and post the results here.

Still I can't help but wonder why xrandr is required, but I don't mind installing it if it cures my resolution problem.

songangel 04-03-2009 12:05 PM

Solved but still wondering
 
Ok I installed the xrandr package and added the line suggested to my .xinitrc and it worked.

This still seems like a workaround to me rather than a solution. Thanks to you adriv for solving the problem for me, but if anyone in the know can explain why this is necessary I would like to know for my own sanity.


All times are GMT -5. The time now is 03:21 AM.