LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-12-2009, 09:05 AM   #1
Gustav 4
LQ Newbie
 
Registered: Jul 2009
Location: Copenhagen, Denmark
Distribution: Fedora 15, Gnome 3
Posts: 12

Rep: Reputation: 0
xorg.conf and hal conficts: unable to set keyboard or monitor settings.


Hi forum

It pains me to ask this very ugly question: What has priority during the sequences that fire up the Xserver, all that is written in the xorg.conf file or some hal and evdev jobbers somewhere else in the system?

Here is some background as to why this question arises:

I have recently installed Slackware 12.2 on a Zepto Znote and configured with an XFCE desktop. Even more recently, I upgraded the installation to slackware-current.

Prior to the -current upgrade, all input devices worked correctly and, after some editing of the xorg.conf file, I had my monitor looking sharp and perfect. This was a matter of changing the "vesa" out with "intel" and updating the monitor sizes to suite the 15,4" screen in 16:10 aspect ratio. The keyboard was correctly set as being PC105 dk, (a danish layout making use of deadkeys). Even in the XFCE display setting you could pick from any of the resolutions I had entered in under xorg's Display headers.

Nice and easy, it was.

But now!? Yes, all is not well after the Slackware upgrade to -current.
Not that the display looks anywhere where as fuzzy as the vesa driver, but none of the display settings turn up in XFCE-> Settings->Display payne. They are set from somewhere else, that is not my xorg.conf file.

But the worst of it all is the keyboard riddle that ensued. In the default keyboard settings section of the xorg.conf file I have options set for "dk" and "pc105". But when I am in the xfce environment, its set to "us", and there are no deadkeys. Sure, from a terminal I could type setkbdmap dk every single time I open with startx, but this should be done by default.


But here is an excerpt from my x log:

...

(II) config/hal: Adding input device AT Translated Set 2 keyboard
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event1"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(**) Option "xkb_options" "terminate:ctrl_alt_bksp"

...


Whats happening here, and why?

cheers

Gustav
 
Old 08-12-2009, 09:34 AM   #2
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 32bit
Posts: 720
Blog Entries: 3

Rep: Reputation: 76
From the CHANGES_AND_HINTS.TXT file:

Quote:
Speaking of Xorg, the version of Xorg shipped with Slackware 13.0 will not
(in most cases) require an /etc/X11/xorg.conf file at all. Configuration of
input devices and such is handled by HAL, and the X server autoconfigures
everything else. You can still create an xorg.conf file if you wish, or you
can create a minimal xorg.conf with only the specific contents that you wish
to override (as an example, to use a binary-only video driver).
Due to removed drivers and other such changes, it's quite possible that your
old xorg.conf will not work correctly with this version of Xorg.

If you need to use a non-US keyboard layout, then copy the file located at
/usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi to /etc/hal/fdi/policy
and edit it to suit your needs. Have a look at the contents of that file
for an example and more information. If you prefer to do this the "old" way
using /etc/X11/xorg.conf, then you can use "X -configure" or "xorgsetup" to
generate an xorg.conf, then add the following lines to the "ServerFlags"
section to disable input device hotplugging via HAL:
Option "AllowEmptyInput" "false"
Option "AutoAddDevices" "false"
Option "AutoEnableDevices" "false"
This is also relevant if you prefer to disable HAL completely for whatever
reason.
 
Old 08-12-2009, 10:19 PM   #3
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,913

Rep: Reputation: Disabled
Thanks for posting that, gegechris.

Gustav_4, if you're going to run -current (the DEVELOPMENT tree of Slackware), you had better read the documentation that we create for it; otherwise, you're going to create a lot of noise on the forums.
 
Old 08-16-2009, 07:01 AM   #4
Gustav 4
LQ Newbie
 
Registered: Jul 2009
Location: Copenhagen, Denmark
Distribution: Fedora 15, Gnome 3
Posts: 12

Original Poster
Rep: Reputation: 0
Thumbs up

Hi Gegechris and rworkman

Thank you so kindly for bringing this documentment to my attention. As mentioned in the document, I made a copy of the original 10osvendor/10-keymap.fdi file and edited it in /etc/hal/fdi/policy. But it was really amazing when I launched the X server without the xorg.conf file. The output in the X log file was really impressive.

This was a great relief, and I apologise if my inquery was redundant: I followed some instructions from a web article, so I had not considered reading the CHANGES_AND_HINTS file.

Thanks again! You guys are doing great work.

Sincerely,
Gustav 4
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Modifying xorg.conf to set up monitor to 1280x1024 60hz refresh rate. glore2002 Slackware 10 09-11-2008 05:40 PM
Help with xorg.conf settings dwhitney67 Linux - Software 8 01-11-2008 01:57 PM
Dual Display (xorg.conf Settings) slash587 Linux - Software 3 02-20-2006 11:25 PM
Xorg.conf settings keep changing gtzpower Linux - Hardware 2 02-13-2006 11:56 PM
acer AL1714 xorg.conf settings lestoil Slackware 3 01-05-2006 02:54 PM


All times are GMT -5. The time now is 04:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration