LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-29-2005, 10:56 PM   #1
Phathead
Member
 
Registered: Sep 2003
Distribution: Slackware 10.1, Slamd64 10.1, IpCop 1.4
Posts: 125

Rep: Reputation: 15
Xorg 6.8.2 and KDE 3.4 & poor xine performance


I'm having a problem with xine since I upgraded to -current with xorg 6.8.2 and KDE 3.4. The same video I used to play with ~40% CPU usage now uses 65% CPU. That doesn't sound so horrible, but it leave less CPU for browsing and other mundane tasks, so I'm more likely to have audio or video skips.

I am using the Xv driver (just like before) with the proprietary ATI driver.

Any ideas on how to get this loss of performance back? I've used both the xine packages from -current and compiled from the latest stable source with the same problem.

This is on an Athlon XP 2000+ with 1GB RAM and an ATI Radeon 9200 AGP with 128MB. The video overlay is on and the OpenGL overlay is off in the xorg.conf file.

Thanks.

Last edited by Phathead; 03-29-2005 at 10:58 PM.
 
Old 03-30-2005, 01:26 AM   #2
Ben2210
Member
 
Registered: Feb 2004
Location: Toronto
Distribution: Arch
Posts: 146

Rep: Reputation: 16
It could be that you don't have hardware accel anymore.

That's usual after an xorg upgrade when using proprietary drivers.

the solution is probably to reinstall the ATI proprietary drivers.

By the way, considering that you have got a Radeon 9200, you might want to consider using the free "radeon" driver that is included in xorg (man radeon). It has been much improved in the 6.8.2 release of xorg. Only for Radeon 9500+ cards is the proprietary driver necessary in order to get 3D accel.

I've tried the free radeon driver on a radeon 9000 card, and it worked great. Don't have any experience with a 9200.
 
Old 03-30-2005, 01:32 AM   #3
Ben2210
Member
 
Registered: Feb 2004
Location: Toronto
Distribution: Arch
Posts: 146

Rep: Reputation: 16
and by the way, 40% cpu usage is too much for video playback on a 2000+ CPU. Clearly you had got a hardware acceleration problem even before the upgrade. It could be that the ATI proprietary drivers have poor Xv support. Either give the free driver a try, or use something else than Xv. (perhaps try OpenGL)
 
Old 03-30-2005, 08:13 AM   #4
Phathead
Member
 
Registered: Sep 2003
Distribution: Slackware 10.1, Slamd64 10.1, IpCop 1.4
Posts: 125

Original Poster
Rep: Reputation: 15
I tried the radeon driver yesterday, but when I tried to start X, it crashed and rebooted my computer. Maybe I didn't have it set up correctly in my xorg.conf. Can you post your video driver section?

I am running some postprocessing on the video stream. De-interlacing to be precise. I think that has more to do with the CPU consumption than the video playback. It's the increase of 25% that concerns me.

Thanks for your suggestions.
 
Old 03-30-2005, 02:22 PM   #5
Ben2210
Member
 
Registered: Feb 2004
Location: Toronto
Distribution: Arch
Posts: 146

Rep: Reputation: 16
OK. Have you tried reinstalling the proprietary ATI (fglrx driver) ?

If you're still interested in the "radeon" driver :
take the default xorg.conf file and just replace
Driver "vesa"
with
Driver "radeon"
and that's it.

perhaps the X crash was due to some fglrx-related change you made to the xorg.conf file...
another reason would be if you compiled your own kernel and didn't include the necessary ATI, DRM or AGP stuff.
anyway it's weird that it rebooted your computer. If you want us to look deeper into this problem, please reproduce this bug and, on next reboot, look at the file /var/log/Xorg.0.log or /var/log/Xorg.0.log.old (well, the one that talks about the crash)

it should contain lines beginning with (EE) or (WW) (respectively errors and warnings). Then post the relevant parts of this log file here.
 
Old 03-30-2005, 02:25 PM   #6
Ben2210
Member
 
Registered: Feb 2004
Location: Toronto
Distribution: Arch
Posts: 146

Rep: Reputation: 16
I'm currently using a nvidia card, so I cant post a useful xorg.conf file. Anyway you'll find the default file under /etc/X11/xorg.conf-vesa
 
Old 03-30-2005, 02:28 PM   #7
Phathead
Member
 
Registered: Sep 2003
Distribution: Slackware 10.1, Slamd64 10.1, IpCop 1.4
Posts: 125

Original Poster
Rep: Reputation: 15
Yes, I did re-install the proprietary driver. I am using a custom 2.6.10 kernel, but the configuration is very close to the stock Slackware kernel. I know I didn't remove the DRM or AGP modules.

When I get home tonight, I'll try the radeon driver again. I did look for errors in the logs and didn't find anything. I'll look again if it crashes. I'll try using the official 2.6.11 kernel if this doesn't work.

Thanks
 
Old 03-30-2005, 02:53 PM   #8
Ben2210
Member
 
Registered: Feb 2004
Location: Toronto
Distribution: Arch
Posts: 146

Rep: Reputation: 16
OK.

There's probably no reason the 2.6.11 kernel should work better...
If you don't find errors in the xorg log file, then at least you can use it to see "when did it crash"...
perhaps you would find more relevant info in /var/log/messages or /var/log/syslog.
Perhaps you're not the only person to have this problem... maybe a few google searches including "xorg 6.8.2", ati and the name of your motherboard (just an example....) would be instructive...

By the way, I read in

http://odin.prohosting.com/wedge01/g...adeon-faq.html

that fglrx would not probably work if certain kernel modules were loaded.

More specifically

Quote:
Device drivers -> Character Devices -> Direct Rendering Manager (XFree86 4.1.0 and higher DRI support): DISABLED
This option is not required, and will almost certainly prevent the driver from working if enabled.
 
Old 03-30-2005, 02:58 PM   #9
Ben2210
Member
 
Registered: Feb 2004
Location: Toronto
Distribution: Arch
Posts: 146

Rep: Reputation: 16
OK, I just checked, and actually DRI/DRM itself is not a module, its a "yes-or-no" config option.

In other words, it's impossible to have the same kernel work with "radeon" and with "fglrx"...

do you have DRI/DRM enabled in your kernel
do a

gzip -cd /proc/config.gz |grep DRM
 
Old 03-30-2005, 03:30 PM   #10
Phathead
Member
 
Registered: Sep 2003
Distribution: Slackware 10.1, Slamd64 10.1, IpCop 1.4
Posts: 125

Original Poster
Rep: Reputation: 15
Here's the check for DRM in the kernel:
Code:
jgilbert@Nimitz:/proc$ gzip -cd config.gz |grep DRM
CONFIG_DRM=y
CONFIG_DRM_TDFX=m
CONFIG_DRM_R128=m
CONFIG_DRM_RADEON=m
CONFIG_DRM_I810=m
# CONFIG_DRM_I830 is not set
# CONFIG_DRM_I915 is not set
CONFIG_DRM_MGA=m
CONFIG_DRM_SIS=m
So DRM is enabled (as a module for my VIA KT266 chipset.) According to that page, it's possible that DRM is blocking fglrx from working. glxinfo does say that the fglrx is the openGL rendering engine, but maybe that's not exactly true.

I have a lot of ideas to try tonight. Thanks again for your help. I'm going to try removing DRM support from the kernel first.
 
Old 03-30-2005, 03:41 PM   #11
Ben2210
Member
 
Registered: Feb 2004
Location: Toronto
Distribution: Arch
Posts: 146

Rep: Reputation: 16
Yes, it's a good idea to recompile a kernel following the all recommendations of the HOWTO mentionned above, in particular removing DRM, and then reinstall fglrx.

Good luck
 
Old 03-30-2005, 03:52 PM   #12
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
i have an ati radeon 9200se running with hw-acceleration with the xorg radeon driver and dri.
it should work also for the 9200.

here are the relevant parts of my xorg.conf.

--------from section module---
# This loads the GLX module
Load "glx"
# This loads the DRI module
Load "dri"
---------

-------
Section "Device"
Identifier "card"
Driver "radeon"
ChipId 0x5964
Option "Overlay"
Option "EnablePageFlip" "on"
EndSection
-------

AFAIK you don't need ChipID for 9200.
and the "overlay " option is not used ( as it sais in the log ), but without it my tv-card can not use overlay.

-------
Section "DRI"
Mode 0666
EndSection
--------

put this at the end of the file to let users use dri.


and maybe take a look at these links to the dri-wiki.
http://dri.freedesktop.org/wiki/ATIR...ac6c242de7f3c1
http://users.actrix.co.nz/michael/radeon9200.html

btw , i have all things modular :

-----
agpgart
via-agp ( i have a via chipset on the mobo )
drm
radeon ( that's the xorg driver )
-----

if this works, you don't need the fglrx driver.
and you do not need to recompile the driver everytime you update the kernel.

egag

Last edited by egag; 03-30-2005 at 03:53 PM.
 
Old 03-30-2005, 07:36 PM   #13
BenneJezzerette
Member
 
Registered: Mar 2005
Location: In a Box where Slackware Rocks
Distribution: Slackware 11 -current
Posts: 274

Rep: Reputation: 30
Quote:
Originally posted by Phathead
I tried the radeon driver yesterday, but when I tried to start X, it crashed and rebooted my computer. Maybe I didn't have it set up correctly in my xorg.conf. Can you post your video driver section?

I am running some postprocessing on the video stream. De-interlacing to be precise. I think that has more to do with the CPU consumption than the video playback. It's the increase of 25% that concerns me.

Thanks for your suggestions.
Suggestion, and this will probably help you like it did me and I use an nVidia card and using the drivers for it hosed this girls system like you would not believe.

at the command line type

xorgsetup

This will run the xorg display and mouse setup and will probe you rhardware for the best performance you can get out of it.

When I did this I had 1280x1024 and 24 bit color, now I am running at 1400x1050 24 bit color and faster than had I left it at 1280x1024.

Try it, but if you have a scroll mouse copy the way it's setup on paper and then after running the program edit the mouse area and re insert the way your mouse was setup, it messes with it and takes the scroll off and changes it from IMPS/2 to auto. Sothat should fix some of your driver and performance issues.

For the Record I have:
AMD K6-2 500
256MB System Ram
nVidia GeForce 2 MX 400 64MB AGP2X

I have some video problems but that is because of the 2X slot for a 4X card.
 
Old 03-30-2005, 07:52 PM   #14
Phathead
Member
 
Registered: Sep 2003
Distribution: Slackware 10.1, Slamd64 10.1, IpCop 1.4
Posts: 125

Original Poster
Rep: Reputation: 15
Just made it home. The kernel recompile did work. I still have the proprietary driver, but I'm not inclined to swap drivers since it already works. Maybe the next time I upgrade the kernel.

Just to be clear, if I were to use the radeon driver, I would need to add DRM support back into the kernel, correct?
 
Old 03-31-2005, 02:09 AM   #15
Ben2210
Member
 
Registered: Feb 2004
Location: Toronto
Distribution: Arch
Posts: 146

Rep: Reputation: 16
Quote:
if I were to use the radeon driver, I would need to add DRM support back into the kernel, correct?
yes!
good to hear that you made fglrx work for you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Software RAID5 - poor write performance & freezing Nitrowolf Linux - Hardware 3 09-25-2005 09:49 PM
poor performance javabb Red Hat 8 01-20-2005 05:48 AM
poor performance in x ah786 Slackware 10 11-09-2004 11:11 AM
Poor performance Shyne Red Hat 1 10-17-2004 11:50 AM
XP > SAMBA Poor Performance (again) confused_bof Linux - Networking 23 03-07-2004 04:00 PM


All times are GMT -5. The time now is 03:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration