LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-29-2011, 09:20 PM   #1
michijo
Member
 
Registered: Apr 2011
Posts: 162

Rep: Reputation: 0
Xmonad Esperanto


I have been having some trouble using the Esperanto locale in Xmonad for sometime. I used this locale mainly in the terminal, because obviously Xmonad is a tiling WM and doesnt need a specific locale itself. I found that Esperanto locale prevents Xmonad from starting, but that if the LANG locale is exported after Xmonad is already started, it will turn my xterminal into an Esperanto terminal. Thus opening mutt mail will show Esperanto-Mutt, and for instance "command not found" becomes "komando ne trovita". I enjoy seeing this.

So the trick then is running "export LANG="eo.utf8"" just after xmonad loads before any other programs are run. I tried various things, and now wonder is it possible to just have the terminal itself running it its own locale? I could run this manually in every terminal, but wonder about automating it. I use the Xfce4-Terminal.

I tried .bash_profile, .xinitrc, .bashrc, and I tried adding the export to a bash script set to run by xmonad after it starts up. None of these cause the desired effect. I also notice it is temporary. If I open a terminal and do the export, that terminal is Esperantized. If I open a new terminal it is back to english.

Another thing I noticed is that after xmonad starts, if I manually add the export to .bashrc, all the terminals are in Esperanto. So I am thinking of making a script that does a find and replace of the .bashrc to add the export. Its tricky, some kind of sed-grep action.

Another idea would be to put the .bashrc in a weird location so it isnt found on startup. Then make a command to symlink to it in the user folder after Xmonad starts. The main Slackware system would be English locale in order to prevent Xmonad from barfing on startup.

Last edited by michijo; 04-29-2011 at 09:47 PM.
 
Old 04-29-2011, 11:30 PM   #2
michijo
Member
 
Registered: Apr 2011
Posts: 162

Original Poster
Rep: Reputation: 0
solved

okay I solved this by making sure that .bashrc file is not sourced before running startx. My prompt was starting with bash sourced, so in fact when I exited it, xmonad started before .bashrc was sourced. Now with the total system set to English, and a bashrc exporting Esperanto, it starts. I dont know why Xmonad wont start with Esperanto but allows Esperanto afterward. Xfce4 allows an esperanto start. It can be Xfce4 has a more subtle xinit file. I will look into it.

Another weird thing, if a program is autostarted from a bash script, it seems not to follow the previously sourced Esperanto .bashrc. So like if I have:

Code:
#!/usr/bin/bash

terminal -T Finch -e finch &
It opens finch from the system wide settings instead of my local user, thus in English. I call the terminal -T Finch in order to auto send a terminal to a specific Xmonad workspace. Multiple terminals without the -T title cannot be sent to workspaces. I tried a workaround by symlinking /usr/bin/bash to my local user bin folder but this didnt source my .bashrc prior to starting Finch (the cli of pidgin has an Esperanto translation).

Last edited by michijo; 04-29-2011 at 11:46 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Esperanto michijo Slackware 6 04-24-2011 12:41 PM
Xmonad on Slackware vinegaroon Slackware 12 01-31-2010 02:48 PM
Where are the Esperanto dictionary on Linux? browny_amiga Linux - Software 3 04-23-2009 09:59 PM
anyone here know esperanto? microsoft/linux General 25 03-17-2006 03:39 AM
Entering esperanto mjjzf Linux - General 0 02-10-2006 01:02 PM


All times are GMT -5. The time now is 11:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration