LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 07-25-2004, 01:47 PM   #1
kostian
Member
 
Registered: Jul 2004
Location: LT
Posts: 150

Rep: Reputation: 15
xmms stops playing(alsa with dmix)


Hi, please dont kill me for asking another alsa question.
Ive searched the forum but found no answer.
I am using slackware-current with 2.6.8-rc2 and self compiled 1.0.5a
alsa drivers with dmix plugin on a nForce2 mobo.
When i do something CPU/HDD intensive(compiling,extracting) XMMS
just stops in the middle of a track(and that really drives me crazy). It
seemes to happen only when using dmix, when not using it the sound
sometimes just skips for a second but i can
live with that. The same thing happens with stock kernel/alsa.
And the sound itself has some static noises aspecially noticeable when
watching a movie. Using real time priority doesnt help. Playing
arround with bufers neither. Running XMMS with nice -15(!) seemes to
give some results
but that way i cant play any other sounds (lounching XMMS with: sudo -n
-15 xmms)
Code:
#aplay message.wav
ALSA lib pcm_direct.c:203:(make_local_socket) connect failed:
/tmp/alsa-dmix-3114-1090779987-528115: Permission denied
ALSA lib pcm_dmix.c:897:(snd_pcm_dmix_open) unable to connect client
aplay: main:507: audio open error: Permission denied
And yes DMA is enabled:
Code:
# hdparm -i /dev/hda

/dev/hda:

 Model=Maxtor 6Y080L0, FwRev=YAR41BW0, SerialNo=Y2NR8D7E
 Config={ Fixed }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=57
 BuffType=DualPortCache, BuffSize=2048kB, MaxMultSect=16, MultSect=off
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=160086528
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4 
 DMA modes:  mdma0 mdma1 mdma2 
 UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 *udma6 
 AdvancedPM=yes: disabled (255) WriteCache=enabled
 Drive conforms to: (null): 

 * signifies the current active mode
(its a maxtor ATA133 drive)

Code:
# hdparm -tT /dev/hda
/dev/hda:
 Timing buffer-cache reads:   1000 MB in  2.00 seconds = 499.33 MB/sec
 Timing buffered disk reads:  142 MB in  3.01 seconds =  47.25 MB/sec
here is my /etc/asound.conf
Code:
pcm.dmixer {
    type dmix
    ipc_key 1024
    slave {
        pcm "hw:0,0"
        period_time 0
        period_size 1024
        buffer_size 16384
   rate 44100
    }

    bindings {
        0 0
        1 1
    }
}

pcm.dsp0 {
    type plug
    slave.pcm "dmixer"
}

pcm.!default {
        type plug
        slave.pcm "dmixer"
}

pcm.default {
   type plug
   slave.pcm "dmixer"
}

ctl.mixer0 {
    type hw
    card 0
}
and my lsmod:
Code:
Module                  Size  Used by
snd_pcm_oss            50856  0 
snd_mixer_oss          17792  3 snd_pcm_oss
snd_intel8x0           31020  6 
snd_ac97_codec         66436  1 snd_intel8x0
snd_pcm                84104  3 snd_pcm_oss,snd_intel8x0
snd_timer              20868  2 snd_pcm
snd_page_alloc          9224  2 snd_intel8x0,snd_pcm
gameport                3584  1 snd_intel8x0
snd_mpu401_uart         6016  1 snd_intel8x0
snd_seq_device          6664  1 snd_rawmidi
snd                    46820  15 
snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore               7136  3 snd
Thank you for any help.
 
Old 07-28-2004, 03:17 PM   #2
leadazide
Member
 
Registered: Apr 2004
Location: Germany
Distribution: SuSE 11.0, Ubuntu 7.10
Posts: 390

Rep: Reputation: 30
On my machine dmix works pretty well (for non-midi output) with asound.conf listed below:

Code:
pcm.my_card {
  type hw
  card 0
  mmap_emulation true
}

pcm.dmixed {
  type dmix
  ipc_key 1024
  slave {
    pcm "my_card"
#   rate 48000
#   period_size 512
  }
}

ctl.asymed {
  type hw
  card 0
}

pcm.dsnooped {
  type dsnoop 
  ipc_key 2048
  slave {
    pcm "my_card"
#   rate 48000
#   period_size 128
  }
}

pcm.asymed {
  type asym
  playback.pcm "dmixed"
  capture.pcm "dsnooped"
}

pcm.pasymed {
  type plug 
  slave.pcm "asymed"
}

pcm.dsp0 {
  type plug
  slave.pcm "asymed"
}

pcm.!default {
  type plug
  slave.pcm "asymed"
}



ctl.!default {
  type hw
  card 0
}
try this one and report
 
Old 07-29-2004, 03:32 AM   #3
suslik
Member
 
Registered: Jul 2004
Distribution: OpenSuse 10.x
Posts: 262

Rep: Reputation: 30
Quote:
Originally posted by leadazide
On my machine dmix works pretty well (for non-midi output) with asound.conf listed below:

...

try this one and report
Sorry to barge in on conversation. I red on dmix site that dmix and aRts combination is yet unstable. Seeing Suse, I wander what your experience is. What is your usual sound usage. (i.e. XMMS\Zinf + all aRts notiifications come in on time, no "pixelation, degradation, Silent Noise at end of event sounds")
 
Old 07-29-2004, 01:06 PM   #4
leadazide
Member
 
Registered: Apr 2004
Location: Germany
Distribution: SuSE 11.0, Ubuntu 7.10
Posts: 390

Rep: Reputation: 30
I disabled aRts completely.
 
Old 07-29-2004, 01:55 PM   #5
trey85stang
Senior Member
 
Registered: Sep 2003
Posts: 1,091

Rep: Reputation: 41
when i use ownboard sound (Via Something) I get the same thing, I since switched to a soundblaster live and that problem stopped.
 
Old 07-29-2004, 09:52 PM   #6
suslik
Member
 
Registered: Jul 2004
Distribution: OpenSuse 10.x
Posts: 262

Rep: Reputation: 30
Quote:
Originally posted by leadazide
I disabled aRts completely.
How do you get system notifications than? Kopete, Kget, New Mail?

Or, did you just "lowered your expectations"(tm)
 
Old 07-30-2004, 04:36 AM   #7
leadazide
Member
 
Registered: Apr 2004
Location: Germany
Distribution: SuSE 11.0, Ubuntu 7.10
Posts: 390

Rep: Reputation: 30
Re: xmms stops playing(alsa with dmix)

2 suslik:

I set up aplay as an external player in KDE Control Center/Sound & Multimedia/System Messages, and everything works.


2 kostian:

Quote:
Originally posted by kostian

Code:
#aplay message.wav
ALSA lib pcm_direct.c:203:(make_local_socket) connect failed:
/tmp/alsa-dmix-3114-1090779987-528115: Permission denied
ALSA lib pcm_dmix.c:897:(snd_pcm_dmix_open) unable to connect client
aplay: main:507: audio open error: Permission denied

There's something wrong with the permissions. Maybe you'd try to copy config from /etc/asound.conf to ~/.asoundrc, so that alsa creates temporary dmix sockets as a normal user, but I'm unsure if this helps.
 
Old 07-30-2004, 06:15 AM   #8
kostian
Member
 
Registered: Jul 2004
Location: LT
Posts: 150

Original Poster
Rep: Reputation: 15
Hi ALL, thank you for your responce.
leadazide, thank you, "static" is now gone thanks to you, ive just commented the sampling frequency in my /etc/asound.conf (.asoundrc) dunno how ive hadn't noticed before that static is present only when using dmix.

moving /etc/asound.conf to .asoundrc doesnt help, anyway its almost sure screwy permissions fault coz launching xmms as root i can still play sounds as normal user and that error occurs only when using sudo.

trey85stang, probably i will upgrade to SB LIVE to, meanwhile just either have to get ussed to "stops" or use an alternative audio player like rhythmbox coz these "stops" only happen with xmms and beep media player(probably because they use the same alsa output plugin). or as an alternative use JACK
 
Old 07-30-2004, 08:53 AM   #9
trey85stang
Senior Member
 
Registered: Sep 2003
Posts: 1,091

Rep: Reputation: 41
Quote:
Originally posted by kostian
trey85stang, probably i will upgrade to SB LIVE to, meanwhile just either have to get ussed to "stops" or use an alternative audio player like rhythmbox coz these "stops" only happen with xmms and beep media player(probably because they use the same alsa output plugin). or as an alternative use JACK
Just a note, I dont like to recommend hardware upgrades to solve problems such as this... but in my case it solved the problem.. and sblive is not to terribly expesive these days so either way
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
alsa dmix in ubuntu compujas Linux - General 2 08-17-2005 09:54 AM
ALSA dmix + Skype = no go zenith_zth Linux - Hardware 0 06-12-2005 05:38 PM
CD not playing with ALSA and Xmms (digital exatraction) taker12 Linux - Software 1 04-04-2005 03:48 AM
alsa and dmix for software mixing darkleaf Linux - Software 6 04-02-2005 03:20 AM
xmms randomly stops playing kryptobs2000 Linux - Software 0 07-26-2004 08:15 PM


All times are GMT -5. The time now is 08:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration