LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-13-2007, 04:14 AM   #1
xaos5
Member
 
Registered: Dec 2004
Distribution: debian and slackware
Posts: 217

Rep: Reputation: 31
xmmintrin.h SSE not enabled slackware 12.0 and audacity


I'm trying to install audacity 1.2.6 but its complaining about a header not having SSE enabled. Does this mean I have to recompile gcc with SSE enabled or is it a ./configure parameter (which I didn't find) for audacity?

Code:
In file included from sse_optimized.cpp:70:
/usr/lib/gcc/i486-slackware-linux/4.1.2/include/xmmintrin.h:34:3: error: #error "SSE instruction set not enabled"
sse_optimized.cpp: In member function 'virtual double soundtouch::TDStretchSSE::calcCrossCorrStereo(const float*, const float*) const':
sse_optimized.cpp:76: error: '__m128' was not declared in this scope
sse_optimized.cpp:76: error: expected `;' before 'vSum'
sse_optimized.cpp:106: error: 'pVec2' was not declared in this scope
sse_optimized.cpp:106: error: expected primary-expression before ')' token
sse_optimized.cpp:106: error: expected `;' before 'pV2'
sse_optimized.cpp:107: error: 'vSum' was not declared in this scope
sse_optimized.cpp:107: error: '_mm_setzero_ps' was not declared in this scope
sse_optimized.cpp:113: error: '_mm_load_ps' was not declared in this scope
sse_optimized.cpp:113: error: '_mm_mul_ps' was not declared in this scope
sse_optimized.cpp:113: error: '_mm_add_ps' was not declared in this scope
sse_optimized.cpp: In member function 'virtual uint soundtouch::FIRFilterSSE::evaluateFilterStereo(float*, const float*, uint) const':
sse_optimized.cpp:296: error: expected initializer before '*' token
sse_optimized.cpp:297: error: '__m128' was not declared in this scope
sse_optimized.cpp:297: error: expected `;' before 'sum1'
sse_optimized.cpp:301: error: 'pFil' was not declared in this scope
sse_optimized.cpp:301: error: expected primary-expression before ')' token
sse_optimized.cpp:301: error: expected `;' before 'filterCoeffsAlign'
sse_optimized.cpp:303: error: 'sum1' was not declared in this scope
sse_optimized.cpp:303: error: 'sum2' was not declared in this scope
sse_optimized.cpp:303: error: '_mm_setzero_ps' was not declared in this scope
sse_optimized.cpp:313: error: '_mm_loadu_ps' was not declared in this scope
sse_optimized.cpp:313: error: '_mm_mul_ps' was not declared in this scope
sse_optimized.cpp:313: error: '_mm_add_ps' was not declared in this scope
sse_optimized.cpp:334: error: '_MM_SHUFFLE' was not declared in this scope
sse_optimized.cpp:334: error: '_mm_shuffle_ps' was not declared in this scope
sse_optimized.cpp:336: error: '_mm_add_ps' was not declared in this scope
sse_optimized.cpp:336: error: '_mm_storeu_ps' was not declared in this scope
Code:
cat /proc/cpuinfo 
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 35
model name      : Dual Core AMD Opteron(tm) Processor 185
stepping        : 2
cpu MHz         : 2611.892
cache size      : 1024 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt lm 3dnowext 3dnow pni lahf_lm cmp_legacy ts fid vid ttp
bogomips        : 5227.15
clflush size    : 64

processor       : 1
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 35
model name      : Dual Core AMD Opteron(tm) Processor 185
stepping        : 2
cpu MHz         : 2611.892
cache size      : 1024 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt lm 3dnowext 3dnow pni lahf_lm cmp_legacy ts fid vid ttp
bogomips        : 5224.15
clflush size    : 64
 
Old 09-13-2007, 05:28 AM   #2
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Rep: Reputation: 55
Google led me to the following - among others:

http://polywogsys.livejournal.com/2007/04/01/

Quote:
Compiling Audacity on AMD64
When compiling Audacity... i found the following useful after I would get ``
/usr/lib/gcc/i686-pc-linux-gnu/3.4.3/include/xmmintrin.h:34:3: #error "SSE instruction set not enabled"``:

Edit: audacity-src-1.2.6/lib-src/soundtouch/source/SoundTouch/Makefile.in

Change the following
From: AM_CXXFLAGS = -O3 -fcheck-new -I../../include
To: AM_CXXFLAGS = -msse -O3 -fcheck-new -I../../include
I cannot test this as I do not have an AMD64 machine.

HTH
 
Old 09-13-2007, 02:32 PM   #3
xaos5
Member
 
Registered: Dec 2004
Distribution: debian and slackware
Posts: 217

Original Poster
Rep: Reputation: 31
Thanks, I tried goggle but I didn't get any results because I was looking for a configure parameter or rebuilding gcc =\. This seems to have worked though.
 
Old 01-17-2008, 06:25 PM   #4
markmcintyre
LQ Newbie
 
Registered: Jan 2008
Posts: 1

Rep: Reputation: 0
Smile

Quote:
Originally Posted by Franklin View Post
Google led me to the following - among others:
Compiling Audacity on AMD64
When compiling Audacity... i found the following useful after I would get ``
/usr/lib/gcc/i686-pc-linux-gnu/3.4.3/include/xmmintrin.h:34:3: #error "SSE instruction set not enabled"``:

Edit: audacity-src-1.2.6/lib-src/soundtouch/source/SoundTouch/Makefile.in

Change the following
From: AM_CXXFLAGS = -O3 -fcheck-new -I../../include
To: AM_CXXFLAGS = -msse -O3 -fcheck-new -I../../include


I cannot test this as I do not have an AMD64 machine.

HTH
In fact with the latest Audacity build (1.2.6), you can define an environment variable
$ SOUNDTOUCH_CXXFLAGS =-msse -mmmx

then rerun configure and it should all work. No need to fiddle with makefiles...
 
  


Reply

Tags
amd64, audacity, enabled


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slackware Eleven install Audacity sound editor? Ed_999 Slackware 4 01-15-2007 11:06 AM
Recompile with SSE KC2LNQ Suse/Novell 2 12-12-2006 05:03 AM
Slackware 11 - Audacity 1.3.2 bgeddy Slackware 10 11-10-2006 05:45 AM
how to install audacity in slackware 10.0 alm3 Linux - Software 1 04-15-2006 07:18 AM
Slackware 10.1 -- DMA not enabled Pozican Linux - Hardware 2 06-16-2005 10:27 AM


All times are GMT -5. The time now is 09:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration