LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   .xinitrc/.xsession - Where are they? Fluxbox (http://www.linuxquestions.org/questions/slackware-14/xinitrc-xsession-where-are-they-fluxbox-154122/)

the_rydster 03-06-2004 05:22 AM

.xinitrc/.xsession - Where are they? Fluxbox
 
Just been tinkering with my fluxbox window manager and been reading the FAQ.

According to the FAQ you need to edit the .xinitrc/.xsession script (depending upon your distro I guess) to get thinks like xclock to startup automatically.

Well I can't find either of these files anywhere on my computer.

I also did:

fluxbox -i

Failed to load groupfile:
BScreen::BScreen: an error occured while querying the X server.
another window manager is already running on display :0.0.
Blackbox::Blackbox: no managable screens found, aborting
Fluxbox: Unknown error.

I did this because I was interested in the fancy transparent menus but could not find the option in the fluxbox-menu. fluxbox -i should say RENDER if the option is available. Not sure why it tells me that blackbox is running.

:confused:

thereof 03-06-2004 05:52 AM

I'm not sure about .xsession but you can make a .xinitrc in your home-directory. Below is the content of my ~/.xinitrc

Code:

# ~/.xinitrc
gkrellm -w &
exec fluxbox

You should have the "&" after all programs you start before fluxbox. This is to make sure that all applications but the window manager runs in the background. Also make sure that you have fluxbox on the last line. That way X will shutdown properly after fluxbox gets terminated.

kiedis 03-06-2004 07:02 AM

@ applications at startup
i prefer using .fluxbox/apps file for starting applications at fluxbox startup
it doesn't work in the stable version of flux, so you can try one of the latest builds

@ render,
try simple recompiling fluxbox
make sure render is enabled

gnashley 03-07-2004 01:45 PM

Are you aware that files and directories prefixed with a period are hidden? In order to see them you have to use ls-a


All times are GMT -5. The time now is 02:04 AM.