LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-16-2007, 04:00 PM   #1
fsanbr
LQ Newbie
 
Registered: Aug 2007
Posts: 1

Rep: Reputation: 0
Xinerama in Slackware 12 with i915


Hello,

I reinstalled my linux box this week but lost the old configuration.
Now I'm having trouble to get xinerama working again.

Could you please send me your xorg.conf files if you have an Intel i915 chipset?
You can send to my e-mail directly.

I'm running the new slackware 12 in a Compaq nc6220.

Thanks,
Francisco
 
Old 09-08-2007, 10:32 AM   #2
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 543Reputation: 543Reputation: 543Reputation: 543Reputation: 543Reputation: 543
Xinerama on Slack 11. Should be the same?

It shouldn't matter what the video device is really. Just change the PCI addresses appropriately, and the driver name, for your system as needed.
Don't know if you got this issue resolved yet either, but thought I'd provide the relevant parts of my Xinerama configuration here for you anyway:
Code:
Section "ServerLayout"
    Identifier  "darkstarSSI.default.dualscreens"
    Screen 0    "Screen0"   0 0
    Screen 1    "Screen1"   1600 0
    InputDevice "Mouse0"    "CorePointer"
    InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Module"
    Load  "dbe"
    Load  "extmod"
    Load  "type1"
    Load  "freetype"
    Load  "glx"
    Load  "fbdevhw"
    Load  "record"
    Load  "v4l"
EndSection

Section "ServerFlags"
    Option "Xinerama" "1"
EndSection

Section "Monitor"
#   KDS Monitor
    Identifier  "Monitor0"
    VendorName  "KDS Corp"
    ModelName   "Proview"
    HorizSync   30.0 - 86.0
    VertRefresh 50.0 - 160.0
    Option "DPMS"
EndSection

Section "Monitor"
#   Television
    Identifier  "Monitor1"
    VendorName  "General Electric"
    ModelName   "TV"
    HorizSync   30.0 - 50.0
    VertRefresh 60.0
#   Option "DPMS"
EndSection

Section "Device"
    Identifier "Videocard0"
    Driver     "nvidia"
    VendorName "nVidia Corp."
    BoardName  "NV18 GeForce4 MX 440 AGP8x"
    BusID      "PCI:01:00:0"
    Screen 0
EndSection

Section "Device"
    Identifier "Videocard1"
    Driver     "nvidia"
    VendorName "nVidia Corp."
    BoardName  "NV18 GeForce4 MX 440 AGP8x"
    BusID      "PCI:01:00:0"
    Screen 1
EndSection

Section "Screen"
#   KDS Monitor "Screen"
    Identifier "Screen0"
    Device  "Videocard0"
    Monitor "Monitor0"
    DefaultDepth 16
    Option  "XVideo"      "On"
    Option  "RenderAccel" "On"
    Option  "HWcursor"    "On"
    Option  "AddARGBGLXVisuals"     "True"
    Option  "AllowGLXWithComposite" "True"
    Option  "DamageEvents" "True"
    Option  "metamodes" "CRT: 1600x1200 +0+0"
  SubSection "Display"
    Depth 16
    Modes   "1600x1200" "1280x1024" "1024x768"
  EndSubSection
  SubSection "Display"
    Depth 24
    Modes   "1600x1200" "1280x1024" "1024x768"
  EndSubSection
EndSection

Section "Screen"
#   Television "Screen"
    Identifier "Screen1"
    Device  "Videocard1"
    Monitor "Monitor1"
    DefaultDepth 16
    Option  "XVideo"      "On"
    Option  "RenderAccel" "On"
    Option  "HWcursor"    "On"
    Option  "AddARGBGLXVisuals"     "True"
    Option  "AllowGLXWithComposite" "True"
    Option  "DamageEvents" "True"
    Option  "TVStandard"  "NTSC-M"
    Option  "TVOutFormat" "COMPOSITE"
    Option  "metamodes" "TV: 1024x768 +0+0"
  SubSection "Display"
    Depth 16
    Modes   "1600x1200" "1280x1024" "800x600"
  EndSubSection
  SubSection "Display"
    Depth 24
    Modes   "1600x1200" "1280x1024" "800x600"
  EndSubSection
EndSection
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dri, i915, FC5 kellinjar Linux - General 0 05-05-2006 02:24 PM
i915 module problems rrr-jr Linux - Hardware 2 05-05-2006 12:31 AM
xorg for i915 chipset viniosity Linux - Laptop and Netbook 42 11-29-2005 02:37 PM
i915 module matrixon Linux - Software 1 06-24-2005 10:40 PM
xinerama and non-xinerama displays edgood1 Linux - Software 0 04-02-2005 03:08 PM


All times are GMT -5. The time now is 06:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration