Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 02-13-2005, 09:11 PM   #1
Registered: Jan 2004
Location: Dhaka, Bangladesh
Distribution: Debian, Gentoo
Posts: 283

Rep: Reputation: 30
xine problem after upgrade

after upgrade xine with

slackpkg upgrade xine

then is upgrade my xine (slackware-current) i am using slack 10 (fresh install and install mplayer, fontforge, etc by compiling

salahuddin@salahuddin66:~$ xine
xine: error while loading shared libraries: cannot open shared object file: No such file or directory

? should i uprade also
Old 02-13-2005, 09:47 PM   #2
Registered: Mar 2003
Location: St. Louis, MO
Distribution: kubuntu-current
Posts: 551
Blog Entries: 4

Rep: Reputation: 31
salahuddin_66, is contained in the libidn-0.5.8 (atleast thats the version in current).
According to pkgtool, it does not contain, but it does contain . ( /usr/lib/ )

Not sure, but you may try creating a symlink from to the existing

Once or twice I've had to do similar things in the past. Maybe its not the best idea, or
the proper way, but I do remember it working for me. If theres a better way, I'de like to
hear it myself incase I run into a similar situation again.
Old 02-13-2005, 11:26 PM   #3
Registered: Jan 2004
Location: Dhaka, Bangladesh
Distribution: Debian, Gentoo
Posts: 283

Original Poster
Rep: Reputation: 30
gr8 thanx

i just have to give "slackpkg install libidn" (the upgrade and reinstall command don't work for it)

now oky

any way if i wanna upgrade lib most of the time the slackpkg don't find the pkg then if i give "install" is it will create my sys prob!!

Old 03-09-2005, 09:09 PM   #4
LQ Newbie
Registered: Sep 2004
Location: Welland, ON Canada
Distribution: Slackware 10.0
Posts: 11

Rep: Reputation: 0
for anyone else with this problem, libidn-0.5.8 does solve the problem... it creates a sym-link "" to
if you compile from source as I did since I couldn't find a slackware package, it will put the files in /usr/local/lib instead... just move everything in there to /usr/lib and you'll be fine...


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
xine won't start after upgrade Alien#007 Debian 1 05-25-2005 12:57 PM
UPgrade XINE cphase Slackware 2 02-08-2005 12:35 PM
Strange Xine problem - Xine running fine only in Xnest xgreen Slackware 3 01-24-2005 10:00 AM
Kaffeine, Xine Upgrade PlantPerson Linux - Newbie 1 07-16-2004 12:56 PM is under construction - how to install - xine-lib-1-rc3a.tar.gz sanjaya Linux - Software 1 02-13-2004 09:36 PM

All times are GMT -5. The time now is 05:52 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration