LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-27-2014, 05:28 AM   #1
rogan
Member
 
Registered: Aug 2004
Distribution: Slackware
Posts: 33

Rep: Reputation: 8
xine + nouveu on 14.1 = crash


I'm having trouble getting xine to start on Slackware 14.1 32-bit.
MPlayer works and aliens vlc build works.
If I use the corporate-hide-code nvidia driver xine also works,
but with nouveau it just won't start. Instead it crashes
with the following message:

X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 148 (XVideo)
Minor opcode of failed request: 17 ()
Serial number of failed request: 1739
Current serial number in output stream: 1739

I guess it's xv related ?
Both the version that comes with Slackware 14.1 (xine-lib 1.1.2 and
xine-ui 0.99.7) and the latest xine-lib 1.2.5 with xine-ui 0.99.8
have the same problem.

My hardware and xorg.conf are listed in the attachment.
The kernel is exactly the same as generic-smp but with jfs and
aic7xxx support compiled in (could never make it work with initrd),
but the kernel is not the issue here, since I noted the same
behavior without the aic7xxx controller.
Otherwise it is a full install with all bells and whistles.

Have anyone else had issues ?
Anyone with a clue what's going on ?
Attached Files
File Type: txt hw-list-lspci.txt (6.9 KB, 3 views)
File Type: txt xorg.conf.txt (2.4 KB, 0 views)
 
Old 04-28-2014, 03:18 AM   #2
xode
Member
 
Registered: Aug 2003
Distribution: Mandrake 9.0; FC4; FC8; SUSE 10.3; SUSE 12.1
Posts: 551
Blog Entries: 1

Rep: Reputation: 45
This is a wild guess on my part, but here goes: using the non smp 32 bit linux kernel (i.e. RAM limited to 3 GB), the wincodecs work just fine with xine and allow xine to play, for example, wmv files. However, with the smp linux kernel, using xine with any wincodec will cause xine to crash. The same kind of problem might be happening in your case.
 
Old 04-28-2014, 01:01 PM   #3
rogan
Member
 
Registered: Aug 2004
Distribution: Slackware
Posts: 33

Original Poster
Rep: Reputation: 8
Like I said, xine won't even launch so I don't get to choose what to play or how.
 
Old 04-28-2014, 02:02 PM   #4
xode
Member
 
Registered: Aug 2003
Distribution: Mandrake 9.0; FC4; FC8; SUSE 10.3; SUSE 12.1
Posts: 551
Blog Entries: 1

Rep: Reputation: 45
My wild guess would say that it could still be the same kind of problem, just at a lower level (e.g. library module that xine always uses instead of software file that you choose to have xine use). Possibly try this using the linux kernel that doesn't use the PAE memory address extensions and see if it works?

On another wild guess on my part, the following may be of assistance: https://bugs.launchpad.net/ubuntu/+s...ui/+bug/363880 I know the linux distribution there is Ubuntu and not Slackware, but it may help anyways.
 
Old 04-28-2014, 02:22 PM   #5
rogan
Member
 
Registered: Aug 2004
Distribution: Slackware
Posts: 33

Original Poster
Rep: Reputation: 8
That bug was apparently related to compositing window managers.
I can assure you I am as far from compositing as is possible (TWM).
Thanks for the tip though, nouveau obviously has problems on 64-bit as well.
I discovered other problems also, all of a sudden all my web browsers stopped
showing me fonts, not all fonts, but enough to make text unreadable.
I'm now running the proprietary nvidia driver and everything, including xine,
works perfectly.
I guess I'll have to stay away from os graphics drivers until a viable alternative
exists
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xine crash fakie_flip Linux - Software 2 11-01-2006 11:00 AM
xine crash. Just got it working, now this? SuSeGeeK Linux - Software 6 03-16-2006 02:01 PM
Xine crash in Fedora Core scmcansh Linux - Newbie 5 05-10-2004 11:12 PM
Xine Crash sellsw1711 Linux - Software 0 03-19-2004 08:57 PM
xmms crash xine crash mplayer crash paledread Linux - Software 9 03-09-2004 07:09 AM


All times are GMT -5. The time now is 07:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration