LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-26-2004, 04:21 PM   #1
Wynd
Member
 
Registered: Jul 2001
Distribution: Slackware 12
Posts: 511

Rep: Reputation: 32
Unhappy XFree86 4.4 messed up fonts


I upgraded XFree86 to 4.4 today, and it did something to my fonts. They AA works just fine, but the fonts are all "off" a little, see here for example: http://home.comcast.net/~texture/fonts.jpg

They used to look like the ones on the right, except the antialiasing was better. Now, they look like the ones on the left. I tried removing X totally and installing it from the .tgz files like was suggested in the other thread about it but it didn't work, what can I do? Please help!
 
Old 03-26-2004, 11:00 PM   #2
Wynd
Member
 
Registered: Jul 2001
Distribution: Slackware 12
Posts: 511

Original Poster
Rep: Reputation: 32
Bump

Also, I noticed I don't have any Japanese characters in fonts that normally have them (MS fonts, Bitstream Vera Sans, etc.)
 
Old 03-27-2004, 05:18 PM   #3
hkctr
Member
 
Registered: Sep 2003
Posts: 106

Rep: Reputation: 15
I did the upgrade to 4.4 using swaret and had no problems at all, including all Japanese fonts. Might try and run 'fc-cache -fv' and double check that the directories your fonts are in are correctly listed in your XF86Config file.
 
Old 03-27-2004, 08:23 PM   #4
Wynd
Member
 
Registered: Jul 2001
Distribution: Slackware 12
Posts: 511

Original Poster
Rep: Reputation: 32
Can you do me a favor, post your /etc/fonts/fonts.conf and /etc/fonts/local.conf? I've run fc-cache a bunch of times and I'm using the same XF86Config as before so I have no idea on earth what could be wrong.
 
Old 03-28-2004, 06:29 AM   #5
hkctr
Member
 
Registered: Sep 2003
Posts: 106

Rep: Reputation: 15
FWIW, here is my fonts.conf file. I have not edited anything manually.

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/fonts.conf file to configure system font access -->
<fontconfig>

<!--
DO NOT EDIT THIS FILE.
IT WILL BE REPLACED WHEN FONTCONFIG IS UPDATED.
LOCAL CHANGES BELONG IN 'local.conf'.

The intent of this standard configuration file is to be adequate for
most environments. If you have a reasonably normal environment and
have found problems with this configuration, they are probably
things that others will also want fixed. Please submit any
problems to the fontconfig bugzilla system located at fontconfig.org

Note that the normal 'make install' procedure for fontconfig is to
replace any existing fonts.conf file with the new version. Place
any local customizations in local.conf which this file references.

Keith Packard
-->

<!-- Font directory list configured on Sun Mar 21 21:50:27 PST 2004 -->

<dir>/usr/share/fonts</dir>
<dir>/usr/X11R6/lib/X11/fonts/TTF</dir> <dir>/usr/X11R6/lib/X11/fonts/Type1</dir>
<dir>~/.fonts</dir>

<!--
Accept deprecated 'mono' alias, replacing it with 'monospace'
-->
<match target="pattern">
<test qual="any" name="family">
<string>mono</string>
</test>
<edit name="family" mode="assign">
<string>monospace</string>
</edit>
</match>

<!--
Accept alternate 'sans serif' spelling, replacing it with 'sans-serif'
-->
<match target="pattern">
<test qual="any" name="family">
<string>sans serif</string>
</test>
<edit name="family" mode="assign">
<string>sans-serif</string>
</edit>
</match>

<!--
Accept deprecated 'sans' alias, replacing it with 'sans-serif'
-->
<match target="pattern">
<test qual="any" name="family">
<string>sans</string>
</test>
<edit name="family" mode="assign">
<string>sans-serif</string>
</edit>
</match>

<!--
Mark common families with their generics so we'll get
something reasonable
-->

<!--
Serif faces
-->
<alias>
<family>Bitstream Vera Serif</family>
<family>Times</family>
<family>Times New Roman</family>
<family>Nimbus Roman No9 L</family>
<family>Luxi Serif</family>
<family>Kochi Mincho</family>
<family>AR PL SungtiL GB</family>
<family>AR PL Mingti2L Big5</family>
<family>Baekmuk Batang</family>
<family>FreeSerif</family>
<default><family>serif</family></default>
</alias>
<!--
Sans-serif faces
-->
<alias>
<family>Bitstream Vera Sans</family>
<family>Helvetica</family>
<family>Arial</family>
<family>Verdana</family>
<family>Nimbus Sans L</family>
<family>Luxi Sans</family>
<family>Kochi Gothic</family>
<family>AR PL KaitiM GB</family>
<family>AR PL KaitiM Big5</family>
<family>Baekmuk Dotum</family>
<family>SimSun</family>
<family>FreeSans</family>
<default><family>sans-serif</family></default>
</alias>
<!--
Monospace faces
-->
<alias>
<family>Bitstream Vera Sans Mono</family>
<family>Courier</family>
<family>Courier New</family>
<family>Andale Mono</family>
<family>Luxi Mono</family>
<family>Nimbus Mono L</family>
<family>NSimSun</family>
<family>FreeMono</family>
<default><family>monospace</family></default>
</alias>
<!--
If the font still has no generic name, add sans-serif
-->
<match target="pattern">
<test qual="all" name="family" compare="not_eq">
<string>sans-serif</string>
</test>
<test qual="all" name="family" compare="not_eq">
<string>serif</string>
</test>
<test qual="all" name="family" compare="not_eq">
<string>monospace</string>
</test>
<edit name="family" mode="append_last">
<string>sans-serif</string>
</edit>
</match>

<!--
Some Asian fonts misadvertise themselves as monospaced when
in fact they are dual-spaced (half and full). This makes
FreeType very confused as it forces all widths to match.
Undo this magic by disabling the width forcing code -->
<match target="font">
<test name="family"><string>GulimChe</string></test>
<edit name="globaladvance"><bool>false</bool></edit>
</match>

<match target="font">
<test name="family"><string>DotumChe</string></test>
<edit name="globaladvance"><bool>false</bool></edit>
</match>

<match target="font">
<test name="family"><string>BatangChe</string></test>
<edit name="globaladvance"><bool>false</bool></edit>
</match>

<match target="font">
<test name="family"><string>GungsuhChe</string></test>
<edit name="globaladvance"><bool>false</bool></edit>
</match>

<!--
The Bitstream Vera fonts have GASP entries suggesting that hinting be
disabled below 8 ppem, but FreeType ignores those, preferring to use
the data found in the instructed hints. The initial Vera release
didn't include the right instructions in the 'prep' table. Fix this
by disabling hinting manually at smaller sizes (< 8ppem)
-->

<match target="font">
<test name="family">
<string>Bitstream Vera Sans</string>
</test>
<test name="pixelsize" compare="less">
<double>7.5</double>
</test>
<edit name="hinting">
<bool>false</bool>
</edit>
</match>

<match target="font">
<test name="family">
<string>Bitstream Vera Serif</string>
</test>
<test name="pixelsize" compare="less">
<double>7.5</double>
</test>
<edit name="hinting">
<bool>false</bool>
</edit>
</match>

<match target="font">
<test name="family">
<string>Bitstream Vera Sans Mono</string>
</test>
<test name="pixelsize" compare="less">
<double>7.5</double>
</test>
<edit name="hinting">
<bool>false</bool>
</edit>
</match>

<!--
Load per-user customization file
-->
<include ignore_missing="yes">~/.fonts.conf</include>

<!--
Load local system customization file
-->
<include ignore_missing="yes">local.conf</include>

<!--
Alias well known Type1 font names to metric equivalent TrueType fonts
-->
<alias>
<family>Times</family>
<accept><family>Times New Roman</family></accept>
</alias>
<alias>
<family>Helvetica</family>
<accept><family>Arial</family></accept>
</alias>
<alias>
<family>Courier</family>
<accept><family>Courier New</family></accept>
</alias>

<!--
Provide required aliases for standard names
-->
<alias>
<family>serif</family>
<prefer>
<family>Bitstream Vera Serif</family>
<family>Times New Roman</family>
<family>Nimbus Roman No9 L</family>
<family>Luxi Serif</family>
<family>Times</family>
<family>Frank Ruehl</family>
<family>Kochi Mincho</family>
<family>AR PL SungtiL GB</family>
<family>AR PL Mingti2L Big5</family>
<family>Baekmuk Batang</family>
<family>FreeSerif</family>
</prefer>
</alias>
<alias>
<family>sans-serif</family>
<prefer>
<family>Bitstream Vera Sans</family>
<family>Verdana</family>
<family>Nimbus Sans L</family>
<family>Luxi Sans</family>
<family>Arial</family>
<family>Helvetica</family>
<family>Nachlieli</family>
<family>Kochi Gothic</family>
<family>AR PL KaitiM GB</family>
<family>AR PL KaitiM Big5</family>
<family>Baekmuk Dotum</family>
<family>SimSun</family>
<family>FreeSans</family>
</prefer>
</alias>
<alias>
<family>monospace</family>
<prefer>
<family>Bitstream Vera Sans Mono</family>
<family>Andale Mono</family>
<family>Courier New</family>
<family>Luxi Mono</family>
<family>Nimbus Mono L</family>
<family>Miriam Mono</family>
<family>Kochi Gothic</family>
<family>AR PL KaitiM GB</family>
<family>Baekmuk Dotum</family>
<family>FreeMono</family>
</prefer>
</alias>

<!--
Artificial oblique for fonts without an italic or oblique version
-->

<match target="font">
<!-- check to see if the font is roman -->
<test name="slant">
<const>roman</const>
</test>
<!-- check to see if the pattern requested non-roman -->
<test target="pattern" name="slant" compare="not_eq">
<const>roman</const>
</test>
<!-- multiply the matrix to slant the font -->
<edit name="matrix" mode="assign">
<times>
<name>matrix</name>
<matrix><double>1</double><double>0.2</double>
<double>0</double><double>1</double>
</matrix>
</times>
</edit>
<!-- pretend the font is oblique now -->
<edit name="slant" mode="assign">
<const>oblique</const>
</edit>
</match>

<config>
<!--
These are the default Unicode chars that are expected to be blank
in fonts. All other blank chars are assumed to be broken and
won't appear in the resulting charsets
-->
<blank>
<int>0x0020</int> <!-- SPACE -->
<int>0x00a0</int> <!-- NO-BREAK SPACE -->
<int>0x00ad</int> <!-- SOFT HYPHEN -->
<int>0x115f</int> <!-- HANGUL CHOSEONG FILLER -->
<int>0x1160</int> <!-- HANGUL JUNGSEONG FILLER -->
<int>0x1680</int> <!-- OGHAM SPACE MARK -->
<int>0x2000</int> <!-- EN QUAD -->
<int>0x2001</int> <!-- EM QUAD -->
<int>0x2002</int> <!-- EN SPACE -->
<int>0x2003</int> <!-- EM SPACE -->
<int>0x2004</int> <!-- THREE-PER-EM SPACE -->
<int>0x2005</int> <!-- FOUR-PER-EM SPACE -->
<int>0x2006</int> <!-- SIX-PER-EM SPACE -->
<int>0x2007</int> <!-- FIGURE SPACE -->
<int>0x2008</int> <!-- PUNCTUATION SPACE -->
<int>0x2009</int> <!-- THIN SPACE -->
<int>0x200a</int> <!-- HAIR SPACE -->
<int>0x200b</int> <!-- ZERO WIDTH SPACE -->
<int>0x200c</int> <!-- ZERO WIDTH NON-JOINER -->
<int>0x200d</int> <!-- ZERO WIDTH JOINER -->
<int>0x200e</int> <!-- LEFT-TO-RIGHT MARK -->
<int>0x200f</int> <!-- RIGHT-TO-LEFT MARK -->
<int>0x2028</int> <!-- LINE SEPARATOR -->
<int>0x2029</int> <!-- PARAGRAPH SEPARATOR -->
<int>0x202a</int> <!-- LEFT-TO-RIGHT EMBEDDING -->
<int>0x202b</int> <!-- RIGHT-TO-LEFT EMBEDDING -->
<int>0x202c</int> <!-- POP DIRECTIONAL FORMATTING -->
<int>0x202d</int> <!-- LEFT-TO-RIGHT OVERRIDE -->
<int>0x202e</int> <!-- RIGHT-TO-LEFT OVERRIDE -->
<int>0x202f</int> <!-- NARROW NO-BREAK SPACE -->
<int>0x205f</int> <!-- MEDIUM MATHEMATICAL SPACE -->
<int>0x2060</int> <!-- WORD JOINER -->
<int>0x2061</int> <!-- FUNCTION APPLICATION -->
<int>0x2062</int> <!-- INVISIBLE TIMES -->
<int>0x2063</int> <!-- INVISIBLE SEPARATOR -->
<int>0x206A</int> <!-- INHIBIT SYMMETRIC SWAPPING -->
<int>0x206B</int> <!-- ACTIVATE SYMMETRIC SWAPPING -->
<int>0x206C</int> <!-- INHIBIT ARABIC FORM SHAPING -->
<int>0x206D</int> <!-- ACTIVATE ARABIC FORM SHAPING -->
<int>0x206E</int> <!-- NATIONAL DIGIT SHAPES -->
<int>0x206F</int> <!-- NOMINAL DIGIT SHAPES -->
<int>0x3000</int> <!-- IDEOGRAPHIC SPACE -->
<int>0x3164</int> <!-- HANGUL FILLER -->
<int>0xfeff</int> <!-- ZERO WIDTH NO-BREAK SPACE -->
<int>0xffa0</int> <!-- HALFWIDTH HANGUL FILLER -->
<int>0xfff9</int> <!-- INTERLINEAR ANNOTATION ANCHOR -->
<int>0xfffa</int> <!-- INTERLINEAR ANNOTATION SEPARATOR -->
<int>0xfffb</int> <!-- INTERLINEAR ANNOTATION TERMINATOR -->
</blank>
<!--
Rescan configuration every 30 seconds when FcFontSetList is called
-->
<rescan>
<int>30</int>
</rescan>
</config>

</fontconfig>
 
Old 03-28-2004, 08:56 PM   #6
Wynd
Member
 
Registered: Jul 2001
Distribution: Slackware 12
Posts: 511

Original Poster
Rep: Reputation: 32


Got it working!

I recompiled Freetype, but I edited the file include/freetype/config/ftoption.h and uncommented the "TT_CONFIG_OPTION_BYTECODE_INTERPRETER" macro.
 
Old 03-30-2004, 02:21 AM   #7
mangus
LQ Newbie
 
Registered: Mar 2004
Distribution: slackware current
Posts: 7

Rep: Reputation: 0
Unhappy

Hi wynd, I have the same problem and I'm going crazy with it.....
I reinstalled X many times but nothing, it seems X messed up the font rendering of my browsers ( opera and konq) and the php pages look very weird...
Can u post a more complete description of your solution, please?
Did U edit the ftoption.h files , before or after the freetype compilation?
which version of freetype U compiled?
U can also send info to fedemang@libero.it
thank U for your collaboration
Mangus
 
Old 03-30-2004, 07:37 AM   #8
jeffmccoy
LQ Newbie
 
Registered: Aug 2003
Location: Washington, D.C., US
Distribution: Slackware
Posts: 11

Rep: Reputation: 0
Hi,

I'm still having problems with messed up fonts as well. This is what I've tried:

1. removepkg all the xfree packages, and reinstall (this is Xfree4.4 from current)

2. start kde, see the wide spaced helvetica fonts. also tried removing and installing again the kde packages. this is kde 3.2.1 from current.

3. then compile freetype2 with the hinting enabled.

4. start x and kde again, still see the wide spaced helvetica fonts. Run fc-cache etc. Also tried deleting a lot of temp kde files in case a kde config file wasn't being written properly. Confirmed that antialiasing is enabled in the KDE control center.

5. I've confirmed that the /etc/fonts/fonts.conf & local.conf config files are ok and the font paths are correct in /etc/X11/XF86Config.

6. I've checked the X log (/var/log/Xfreesomething). When I first upgraded to Xfree86 4.4, there were errors that my fonts.dir files couldn't be read. I used mkdontscale and mkfontdir to recreate those files, and those errors went away. However, I still have errors that "font renderer already registered" for various fonts.

7. I thought it might be something to do with the font server so I tried using the core fonts system and then using xfs (using "FontPath "unix/:7100" in /etc/X11/Xf86Config). I got the same errors in the log and it didn't seem to change how the fonts were rendered.

Fyi I'm using the nvidia driver. I also recompiled that but it didn't seem to affect things. The strange thing, from the X log it looks like it's a generic font problem, but it's really only severely affecting kde, with the wide spaced fonts. other window managers look ok and truetype fonts look like they're being rendered ok in Mozilla.

Any help/advice would be appreciated.

Last edited by jeffmccoy; 03-30-2004 at 07:39 AM.
 
Old 03-30-2004, 02:50 PM   #9
Wynd
Member
 
Registered: Jul 2001
Distribution: Slackware 12
Posts: 511

Original Poster
Rep: Reputation: 32
Ok, this is what I did. I downloaded the latest version of Freetype (2.1.7 I think) and untarred it into mmy home dir. The file I edited was ~/freetype-2.1.7/include/freetype/config/ftoption.h. There is a big section that looks like this:
Code:
  /*************************************************************************/
  /*                                                                       */
  /* Define TT_CONFIG_OPTION_BYTECODE_INTERPRETER if you want to compile   */
  /* a bytecode interpreter in the TrueType driver.  Note that there are   */
  /* important patent issues related to the use of the interpreter.        */
  /*                                                                       */
  /* By undefining this, you will only compile the code necessary to load  */
  /* TrueType glyphs without hinting.                                      */
  /*                                                                       */
  /*   Do not #undef this macro here, since the build system might         */
  /*   define it for certain configurations only.                          */
  /*                                                                       */
/* #define  TT_CONFIG_OPTION_BYTECODE_INTERPRETER */
Remove the /* and */ from around the #define part to uncomment it, and save and exit. Then go back to ~/freetype-2.1.7 and compile/install it, and restart X and it should work. Things I also did were I deleted all libfreetype.so files before I installed it so it would only use mine, and I did everything without X running just in case. Hope this helps
 
Old 03-31-2004, 12:08 AM   #10
mangus
LQ Newbie
 
Registered: Mar 2004
Distribution: slackware current
Posts: 7

Rep: Reputation: 0
hi evrybody, I've done also the things described by jeffmccoy and I also dont solved anything. Also recompiled freetype 2.1.7 as Wynd sais but didn't help , Helvetica fonts still rules on my webpages.
This affects seems only php pages opened with konq and opera.
Gnome and firefox seems work well.
May be something with css and qt? or some weird font aliases?
I don't know what to do now, I noticed that downgrading to 4.3.0 solve the problem.. but I would like to give 4.4 a chance and stay tuned with the slack current tree... sob!!!
Mangus
 
Old 03-31-2004, 02:23 AM   #11
shepper
Member
 
Registered: Mar 2003
Location: Dry, Dusty and Conservative
Distribution: OpenBSD, Debian Wheezy/Jessie
Posts: 449

Rep: Reputation: 32
From the Slackware Changelog March 30, 2004

provide better wireless support).
x/xfree86-fonts-scale-4.4.0-noarch-2.tgz: Fixed missing VeraIt.ttf.
(Thanks to Stepan Roh for the bug report).
extra/checkinstall/checkinstall-1.5.3-i486-2.tgz: Recompiled
 
Old 03-31-2004, 03:25 AM   #12
mangus
LQ Newbie
 
Registered: Mar 2004
Distribution: slackware current
Posts: 7

Rep: Reputation: 0
this could be a good answer... now go on downloading
but my question is: why only few guys have this problem if the package is corrupted? let's give a try
cheers
mangus
 
Old 03-31-2004, 06:04 PM   #13
naradla
LQ Newbie
 
Registered: Mar 2004
Posts: 1

Rep: Reputation: 0
Also here all the fonts got messed up seriously after upgrading to XFree86 4.4.0. Tried everything, including the updated slackware font packages, and also compiling/installing the latest freetype package.

The thing that really helped though, was installing the XFree86 freetype module from the 4.3.0 package. Now almost everything is back to normal again (window manager fonts, opera, etc.).
Seem to have some problems with gtk2 applications (e.g. gkrellm) but not sure if that's an application configuration problem or a system font problem.

The freetype module is: /usr/X11R6/lib/modules/fonts/libfreetype.a .
 
Old 03-31-2004, 06:05 PM   #14
jeffmccoy
LQ Newbie
 
Registered: Aug 2003
Location: Washington, D.C., US
Distribution: Slackware
Posts: 11

Rep: Reputation: 0
well, I've upgraded to the new current packages as of March 30:

kdelibs-3.2.1-i486-2.tgz
kdenetwork-3.2.1-i486-2.tgz
xfree86-fonts-scale-4.4.0-noarch-2.tgz
as well as the others

and it still doesn't work - I'm still getting the widely spaced fonts in kde.

also, regarding freetype, I've tried compiling with "configure && make" and
"configure --prefix=/usr && make" to see if that would make a difference. But it doesn't seem to - still have the widely spaced fonts.

Have the recent updates from current helped out anyone? If so, could you post your experience?
 
Old 04-01-2004, 12:37 AM   #15
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Rep: Reputation: 45
xfree86-fonts-scale-4.4.0-noarch-2.tgz post-installation script takes VERY VERY long time with CPU load at 99.1% for fc-cache. And I had to kill it. But it works fine till now.

xfree86-cursors is still at 4.3, anybody have an update for that?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fonts messed up in Steam GT_Onizuka Linux - Games 3 09-03-2004 07:55 PM
Fonts messed up with upgrade to XFree86 4.4 xflow7 Slackware 2 05-11-2004 01:10 PM
upgraded to Xfree86 v 4.4 -> fonts messed up EyesOnly Slackware 20 04-11-2004 09:50 AM
konqueror fonts messed up mi6alec Mandriva 2 03-06-2004 08:05 AM
Messed up fonts.. creepynut Linux - General 0 08-25-2003 01:52 AM


All times are GMT -5. The time now is 05:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration