LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Xfree 4.4 and Radeon fglrx drivers (http://www.linuxquestions.org/questions/slackware-14/xfree-4-4-and-radeon-fglrx-drivers-164648/)

Menestrel 03-31-2004 02:45 PM

Xfree 4.4 and Radeon fglrx drivers
 
Does anyone know if I can use the drivers from www.ati.com with Xfree 4.4 ? Because I recetly installed Xfree 4.4 and can't seem to make those drivers work

mipia 03-31-2004 05:32 PM

I am still at 2.4.25 (havent touched on kernel compile yet). But I have heard from/read many people using 4.4 that have it running. For other readers it may be helpful to post your error messages and/or describe the problem.

fcaraballo 03-31-2004 06:39 PM

Unfortunately, the ATI 3.7.6 driver for XFree86 4.3.0 is not compatible with XFree86 4.4.0. We will all have to wait until ATI gets a new driver out that supports XFree86 4.4.0. In the meantime though, you can use the generic radeon driver that comes with XFree86 4.4.0. It is not quite up to hard core gaming standards, but will give you <cough> decent enough 3D/OpenGL support while you wait.

Just edit your XF86Config file and add/change the following:

Driver "radeon"
Option "AGPMode" "(1, 2, or 4)" ;(8x is not yet supported :( )

Don't forget to uninstall/delete your XF86Config-4 file, ATI 3.x.x driver, and rem-out your modprobe fglrx first.

Hope this helps someone :D

Menestrel 04-15-2004 04:36 AM

Well... it works with the radeon driver and the Xfree 4.4, but I also needed dga mode for Full-screen mode in a VmWare machine and Xfree 4.4 doesn't support dga mode (or so I think :scratch: ), so I switched back to the old Xfree 4.3 with radeon fglrx drivers


All times are GMT -5. The time now is 01:56 AM.