LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 02-02-2012, 01:54 PM   #1
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 5,953

Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
XFIG unable to load font set


This is in slackware64-current. It throws up a list of fonts it didn't find and barfs when I load a library. I did find this
http://www.linuxquestions.org/questi...ontset-883553/

and tried the solution but no joy. Anyone got the syntax for the /etc/X11/app-defaults/Fig file to tell it there are 1000s of %$£@! fonts on the system?
 
Old 02-03-2012, 07:09 AM   #2
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 145Reputation: 145
I got the same. Wanted to spend no time in finding out the cause, I simply duplicated the "gb18030" lines in
"/usr/share/fonts/TTF/fonts.{dir,scale}" and changed "gb18030.2000" to "gbk" in the new lines.

Then xfig worked.
Of course it depends on your locale.

Last edited by guanx; 02-03-2012 at 07:11 AM.
 
Old 02-03-2012, 08:30 AM   #3
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 5,953

Original Poster
Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
Sounds devious and excellent! I'll go off and hack appropriately.
I'm in Ireland.

For the record, any idea _why_ it worked? I can't find where they set the font.
 
Old 02-03-2012, 11:32 AM   #4
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 5,953

Original Poster
Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
Not sorted yet. I have no lines about font gb18030 or gb<anything> for that matter. Here's the error I see. It finds fonts, but I still get the middle finger
http://pastebin.com/qN19YSiK
 
Old 02-03-2012, 12:06 PM   #5
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 145Reputation: 145
Most probably you don't have it, when you don't use zh locales.
What does the locale command say?

In the mean time you can run "LC_ALL=C xfig".
 
1 members found this post helpful.
Old 02-03-2012, 02:19 PM   #6
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 5,953

Original Poster
Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
LANG=C xfig

It's barfing on utf-8. This is half of a workaround, and it works for me. What's depressing is that different things work for different folks and it's locale dependent.
 
Old 02-03-2012, 04:09 PM   #7
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 145Reputation: 145
Why "LANG=C"? The key is "LC_CTYPE".

If you need UTF-8, set locale to something like this:
Code:
LANG=zh_CN.UTF-8
LC_CTYPE=en_US.UTF-8
LC_NUMERIC=zh_CN.UTF-8
LC_TIME=zh_CN.UTF-8
LC_COLLATE=zh_CN.UTF-8
LC_MONETARY=zh_CN.UTF-8
LC_MESSAGES=zh_CN.UTF-8
LC_PAPER=zh_CN.UTF-8
LC_NAME=zh_CN.UTF-8
LC_ADDRESS=zh_CN.UTF-8
LC_TELEPHONE=zh_CN.UTF-8
LC_MEASUREMENT=zh_CN.UTF-8
LC_IDENTIFICATION=zh_CN.UTF-8
LC_ALL=
Note that "LC_ALL" must be empty.
 
Old 02-04-2012, 03:01 AM   #8
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 5,953

Original Poster
Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
Quote:
Originally Posted by guanx View Post
Why "LANG=C"? The key is "LC_CTYPE".

If you need UTF-8, set locale to something like this:
[SNIP]
Note that "LC_ALL" must be empty.
I am working by getting away from UTF-8 xfig-3.2.4 may not be under active development. it's veen at 3.2.4 for a looong time·
 
Old 02-04-2012, 04:23 AM   #9
joghi
LQ Newbie
 
Registered: Jun 2011
Distribution: Slackware 14.0 Slackware64 14.0
Posts: 19

Rep: Reputation: Disabled
You can download version 3.2.5 from www.xfig.org. However, some patches from the slackbuild script in src doesn't work any more, so you have to compile and install it on your own. BTW, does printing directly from xfig work for you with version 3.2.4?
 
Old 02-04-2012, 07:37 AM   #10
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 5,953

Original Poster
Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
I saw that myself, thanks, joghi.
Don't worry about the patches, I can shoehorn most of that stuff in if it belongs - I'm an ex-LFSer. HLFS is/was a master class in applying patches.
3.2.4 to 3.2.5 doesn't sound amazing. It's more like a (long overdue) bug fix package. If they had Unicode, I would expect 3.3.0 at least.
 
Old 02-04-2012, 12:03 PM   #11
joghi
LQ Newbie
 
Registered: Jun 2011
Distribution: Slackware 14.0 Slackware64 14.0
Posts: 19

Rep: Reputation: Disabled
Yes, it's mostly bugfixes. I switched to version 3.2.5 sometime because printing xfig postscript directly suddenly only produced white pages for me. It seemed to me that this was due to transfig producing slightly incorrect postscript code, that was not accepted by CUPS any longer. What interests me is, if this problem still occurs with version 3.2.4 of xfig / transfig in Slackware-current. If not, maybe I have to look somewhere else in my system configuration.
 
Old 02-05-2012, 09:41 AM   #12
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 5,953

Original Poster
Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
Quote:
Originally Posted by joghi View Post
Yes, it's mostly bugfixes. I switched to version 3.2.5 sometime because printing xfig postscript directly suddenly only produced white pages for me. It seemed to me that this was due to transfig producing slightly incorrect postscript code, that was not accepted by CUPS any longer. What interests me is, if this problem still occurs with version 3.2.4 of xfig / transfig in Slackware-current. If not, maybe I have to look somewhere else in my system configuration.
It seems Xfig/transfig is locale sensitive, and particularly about utf-8. Send me a file if you like, and I'll run it through here. I have to sort printing myself.
 
Old 02-05-2012, 09:44 AM   #13
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 5,953

Original Poster
Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
Quote:
Originally Posted by guanx View Post
Most probably you don't have it, when you don't use zh locales.
What does the locale command say?

In the mean time you can run "LC_ALL=C xfig".
Thanks, guanx I spotted this late.

Due to the vagaries of the internet, This post wasn't in the thread for me whan I was replying as I did. It is indeed the solution.
 
Old 02-05-2012, 01:02 PM   #14
joghi
LQ Newbie
 
Registered: Jun 2011
Distribution: Slackware 14.0 Slackware64 14.0
Posts: 19

Rep: Reputation: Disabled
I'm still not using utf-8, so this maybe wasn't the problem. With transfig 3.2.5d printing works for me.
Just in case you should experience problems to.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xfig aborts because "no fontset found"Unable to load any usable fontset tfonz Slackware 1 05-31-2011 05:39 PM
Unable to set remote font server with xset pensrock68 Fedora 4 12-22-2009 11:41 AM
Unable to load screen15 font, trying fixed anacharya Linux - General 1 04-02-2005 01:05 PM
Unable to load screen15 font, trying fixed anacharya Linux - Newbie 0 04-02-2005 12:09 PM
Unable to load any usable ISO8859 font TheCyberDude Linux - Software 0 08-17-2003 03:28 PM


All times are GMT -5. The time now is 06:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration