LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 01-06-2008, 09:04 PM   #1
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
XFE and Tooltips


I would like to grow warmer toward XFE (X File Explorer), but the tooltips drive me nuts. I'm hoping there is an easy RTFM way to disable tooltips that I overlooked. Any help is appreciated.

Thanks.
 
Old 01-07-2008, 05:02 AM   #2
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,525

Rep: Reputation: 94
No, I think there is no good way at the moment. In the configuration file (~/.xfe/xferc) there are two options for tooltips, but it seems they don't get read or applied.

You can get rid of the tooltips though if you change one line in the source code before compiling. Edit src/xfedefs.h and change lines 67-69 (version 1.04) to look like this:
Code:
#ifndef TOOLTIP_TIME
#define TOOLTIP_TIME 0
#endif
This removed the tooltips for me.
 
Old 01-12-2008, 02:47 PM   #3
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Quote:
No, I think there is no good way at the moment. In the configuration file (~/.xfe/xferc) there are two options for tooltips, but it seems they don't get read or applied.
Yes, I did not mention that in my original post, but I noticed the options too. I tried various numbers hoping to at least delay the tooltips from appearing, but to no avail.

Quote:
You can get rid of the tooltips though if you change one line in the source code before compiling. Edit src/xfedefs.h and change lines 67-69 (version 1.04) to look like this:
I added a "sed" line to the SlackBuild script to edit xfedefs.h on-the-fly and I just finished recompiling. Seems to work just great. Thank you!
 
Old 01-12-2008, 06:15 PM   #4
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,525

Rep: Reputation: 94
You're welcome, glad it works
 
Old 06-16-2008, 04:39 PM   #5
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
FYI:

Version 1.19 of Xfe is now available. No more on-the-fly modifications to the configuration build files are needed to disable directory and file tooltips. Tooltips remain available but easily disabled through the Preferences. Tooltips for the toolbar buttons remain active with that same change. A welcomed usability improvement.
 
Old 06-16-2008, 05:42 PM   #6
adriv
Member
 
Registered: Nov 2005
Location: Diessen, The Netherlands
Distribution: Slackware 14.1
Posts: 661

Rep: Reputation: 38
Thanks for the tip.
Gonna try 1.19 right now.
 
Old 06-17-2008, 08:14 AM   #7
silverbird
LQ Newbie
 
Registered: Jun 2008
Location: Philippines
Distribution: Slackware
Posts: 24

Rep: Reputation: 0
After reading this thread I decided to try xfe - have just installed it.

I thought it said it could be run from the command line, but when I try I get unable to open display 0,0

I was so pleased as a new Slackware user to successfully build my first package - xfe works if I use a terminal after I have typed startx (xfce wm) but I thought it could be used without startx.
 
Old 06-17-2008, 11:23 AM   #8
adriv
Member
 
Registered: Nov 2005
Location: Diessen, The Netherlands
Distribution: Slackware 14.1
Posts: 661

Rep: Reputation: 38
If you want a filemanager that runs without X, try Midnight Commander (just type mc).
 
Old 06-17-2008, 12:50 PM   #9
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 14.1
Posts: 1,141

Rep: Reputation: 55
Quote:
Originally Posted by Woodsman View Post
I would like to grow warmer toward XFE (X File Explorer), but the tooltips drive me nuts. I'm hoping there is an easy RTFM way to disable tooltips that I overlooked. Any help is appreciated.

Thanks.
Thanks for introducing me to XFE...seems like just what I was looking for.
 
Old 06-20-2008, 09:02 PM   #10
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Quote:
I thought it said it could be run from the command line, but when I try I get unable to open display 0,0
From an xterm console, yes. Not from outside of X.

Three things I have not yet figured out with xfe:

1. How to provide some indication I am running xfe as root. I like the way konqueror supports this by simply modifying the background color. Thunar does something similar with a red bar.

2. How to convert the bookmarks into human readable descriptions. Piece of cake with konqueror.

3. How to make xfe blend into the overall KDE look-and-feel. I've tried all the themes but none make me smile.
 
Old 08-20-2008, 07:11 PM   #11
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Quote:
1. How to provide some indication I am running xfe as root. I like the way konqueror supports this by simply modifying the background color. Thunar does something similar with a red bar.
There is a way to do this. I'm using version 1.19.2. Head into Preferences, select the Themes tab, then play with the colors. I set my background to pinkish (#FDD9E6/253-217-230), just like I have had in Konqueror for many years. This background color helps remind me I'm using xfe as root.

My root xfe colors (from my /root/.xfe/xferc config file):

[SETTINGS]
listforecolor=Black
forecolor=Black
basecolor=#dcdad5
selforecolor=Gray100
selbackcolor=#4b6983
highlightcolor=#eeeeee
bordercolor=Black
listbackcolor=Gray100
backcolor=Gray100


Quote:
How to convert the bookmarks into human readable descriptions. Piece of cake with konqueror.
No solution yet found.

Quote:
How to make xfe blend into the overall KDE look-and-feel. I've tried all the themes but none make me smile.
Select this through Preferences or edit the $HOME/.xfe/xferc config file:

[SETTINGS]
iconpath=/usr/share/xfe/icons/kde-theme


I hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
libpng problem with xfe file manage davimint Slackware 4 09-05-2007 03:26 AM
mass renaming icons for use with XFE? Mr_Shameless Linux - Software 2 06-02-2007 06:55 AM
Installing libFOX for XFE chaz_bro1972 Linux - Desktop 6 04-11-2007 05:41 PM
XFE + Error loading shared libraries Br0eTcHeN Linux - Newbie 1 12-08-2005 11:01 AM
XFE + libFOX + fox/fx.h RaVilj Linux - Software 0 06-13-2004 06:28 PM


All times are GMT -5. The time now is 10:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration