LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   xfce terminal colors (http://www.linuxquestions.org/questions/slackware-14/xfce-terminal-colors-4175485674/)

l0rddarkf0rce 11-23-2013 06:57 PM

xfce terminal colors
 
New to xfce and have a quick question... When I open a Terminal window the terminal is in black and white, but if I su to root all of the files and directories display in the proper colors. Which file controls which colors are used in the xfce terminal? TIA

maciuszek 11-23-2013 07:30 PM

Have your desired shells init script run the profile.d/* scripts. look how /etc/profile does it

perbh 11-23-2013 11:55 PM

.config/xfce4/terminal/terminalrc

alternatively, just open a terminal and do: edit->preferences

GazL 11-24-2013 06:12 AM

Add an alias to your ~/.bashrc
I use this:
alias ls='ls --color=auto --group-directories-first'

The ansi colour codes used for each type of file are set by the LS_COLORS environment variable (read up on 'dircolors' for details).

What those colours actually look like on screen will be down to whatever palette is set in the settings of your terminal program.

l0rddarkf0rce 11-24-2013 02:00 PM

Quote:

Originally Posted by GazL (Post 5069748)
Add an alias to your ~/.bashrc
I use this:
alias ls='ls --color=auto --group-directories-first'

The ansi colour codes used for each type of file are set by the LS_COLORS environment variable (read up on 'dircolors' for details).

What those colours actually look like on screen will be down to whatever palette is set in the settings of your terminal program.

Thanks GazL this is what I actually did. What is strange is that ls works just fine if I am not running X or if I am using KDE, this only happens when I run xfce, also if I su to root after I start terminal ls works just fine as root. In any case this seems to had work so I will be happy.

GazL 11-24-2013 03:44 PM

Yes, that's normal. Depending on what starts it bash will start as either a normal shell or a "login shell". Only the login shell runs /etc/profile. There have been a number of threads about this in the past so I won't go over old ground again here, but if you want to search the forum for them you'll find several discussions about it.

chemfire 11-24-2013 05:50 PM

Go to preferences in XFCE Terminal; Check "Run Command as Login Shell"

GazL 11-25-2013 06:07 AM

... which is the quick and dirty, but wrong way to fix it.


All times are GMT -5. The time now is 11:01 AM.