LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 07-24-2012, 12:04 PM   #1
slackuser600
LQ Newbie
 
Registered: Jun 2012
Posts: 7

Rep: Reputation: Disabled
XFCE sensor plugin


I'm unable to compile xfce4-sensors-plugin-1.0.0. I'm using the package from slackbuilds for 13.37 and I am running Slackware 13.37, 64-bit. The same package compiles fine on my 32-bit systems, but fails on a 64-bit system. So it has something to do with 64-bit, I assume.

The configure script checks out, however the compilation itself fails:

Code:
mv -f .deps/xfce4_sensors_plugin-sensors-plugin.Tpo .deps/xfce4_sensors_plugin-sensors-plugin.Po
/bin/sh ../libtool --tag=CC   --mode=link gcc -pthread -I/usr/include/xfce4/ -I/usr/include/xfce4 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng14 -I/usr/include/atk-1.0 -DPACKAGE_LOCALE_DIR=\"/usr/local/share/locale\" -I/usr/include -g -O2 ../lib/libxfce4sensors.la  -o xfce4-sensors-plugin xfce4_sensors_plugin-sensors-plugin.o  
libtool: link: gcc -pthread -I/usr/include/xfce4/ -I/usr/include/xfce4 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng14 -I/usr/include/atk-1.0 -DPACKAGE_LOCALE_DIR=\"/usr/local/share/locale\" -I/usr/include -g -O2 -o .libs/xfce4-sensors-plugin xfce4_sensors_plugin-sensors-plugin.o  ../lib/.libs/libxfce4sensors.so -pthread -Wl,-rpath -Wl,/usr/local/lib/xfce4/modules
/usr/local/lib/gcc/x86_64-unknown-linux-gnu/4.7.1/../../../../x86_64-unknown-linux-gnu/bin/ld: xfce4_sensors_plugin-sensors-plugin.o: undefined reference to symbol 'xfce_panel_plugin_get_size'
/usr/local/lib/gcc/x86_64-unknown-linux-gnu/4.7.1/../../../../x86_64-unknown-linux-gnu/bin/ld: note: 'xfce_panel_plugin_get_size' is defined in DSO /usr/lib64/libxfce4panel.so.1 so try adding it to the linker command line
/usr/lib64/libxfce4panel.so.1: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status
make[2]: *** [xfce4-sensors-plugin] Error 1
It suggests 'xfce_panel_plugin_get_size' is defined in DSO /usr/lib64/libxfce4panel.so.1 so try adding it to the linker command line, how do I do that?
 
Old 07-24-2012, 01:29 PM   #2
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,276

Rep: Reputation: 187Reputation: 187
Or... you could download the package from here:

http://download.tuxfamily.org/salixb...alixbang/xfce/

 
Old 07-24-2012, 01:39 PM   #3
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,504

Rep: Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912
maybe you are running slackware64-13.37, but you have installed gcc-4.7.1 in /usr/local and you are using that to build your packages, not the standar compiler: you can try adding to the slackbuild in a line before the CFLAGS one
Code:
LDFLAGS="-lxfce4panel" \
 
Old 07-27-2012, 05:57 PM   #4
slackuser600
LQ Newbie
 
Registered: Jun 2012
Posts: 7

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ponce View Post
maybe you are running slackware64-13.37, but you have installed gcc-4.7.1 in /usr/local and you are using that to build your packages, not the standar compiler: you can try adding to the slackbuild in a line before the CFLAGS one
Code:
LDFLAGS="-lxfce4panel" \
Thanks for the suggestion.

You are completely right. I have installed GCC 4.7.1 in /usr/local/bin. How can I specify which version of GCC to use? Can I specify this as an argument to the configure script in some way?

Edit: I forgot to mention that I tried adding LDFLAGS, but the result was exactly the same as before.
 
Old 07-28-2012, 10:11 AM   #5
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,504

Rep: Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912
try to export the CC variable in the shell you use to build the slackware package
Code:
export CC=/usr/bin/gcc
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SlackWare 13.37 xfce + xkb-plugin == ctrl+alt+backspace not working FeyFre Slackware 8 01-25-2012 10:18 AM
[SOLVED] TOSHIBA Hard Drive Impact Sensor (3D sensor) and Linux josephj Linux - Laptop and Netbook 4 11-06-2010 07:39 PM
A feature of the Open tray XFCE plugin in currrent AGer Slackware 0 03-07-2010 08:32 AM
xfce: LCD Brightness plugin?? andrew.46 Slackware 2 10-08-2009 02:36 AM
Help on XFCE thunar-archive-plugin igorthinks Linux - Desktop 1 08-21-2008 10:58 AM


All times are GMT -5. The time now is 06:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration