LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   xfce problems dbus segfault with nm-applet (http://www.linuxquestions.org/questions/slackware-14/xfce-problems-dbus-segfault-with-nm-applet-4175460264/)

BadAvocado 05-01-2013 05:22 AM

xfce problems dbus segfault with nm-applet
 
I've been having these errors show up recently. I first noticed them after xfce4 took a long time to log out, then at the next startx, it took a long time to paint the screen, and had a Xorg cursor set and window styles instead of the typical xfce styles. I got things back to "normal" by deleting ~/.cache/sessions/* (all but the 'thumbs' subdirectory).

However, these errors below still show up, and my google searches aren't helping me to diagnose them. Any clues / help are appreciated.

Startup Errors:
Code:

** (nm-applet:4583): CRITICAL **: dbus_set_g_error: assertion 'gerror == NULL || *gerror == NULL' failed

xfdesktop:4566): GLib-GIO-CRITICAL **: g_file_get_path: assertion 'G_IS_FILE (file)' failed

xfdesktop:4566): GLib-GIO-CRITICAL **: g_file_get_path: assertion 'G_IS_FILE (file)' failed

xfdesktop:4566): GLib-GIO-CRITICAL **: g_file_get_path: assertion 'G_IS_FILE (file)' failed

xfdesktop:4566): GLib-GIO-CRITICAL **: g_file_get_path: assertion 'G_IS_FILE (file)' failed

/usr/lib/python2.7/site-packages/gtk-2.0/gtk/__init__.py:127: RuntimeWarning: PyOS_InputHook in not available for interactive use of PyGTK
  set_interactive(1)
QGtkStyle was unable to detect the current GTK+ theme

I think the python2.7 error is related to hplip, if I remove it from the session, that error doesn't appear, but the GLib-GIO-CRITICAL messages still show up.

When I run nm-applet from a terminal, I get a similar dbus error:
Code:

$ nm-applet

** (nm-applet:5809): CRITICAL **: dbus_set_g_error: assertion `gerror == NULL || *gerror == NULL' failed
Segmentation fault

/var/log/messages
Code:

May  1 06:48:32 slackmachine kernel: [75972.503334] nm-applet[5809]: segfault at ffff3ff0 ip b64096ae sp bf969b40 error 4 in libc-2.15.so[b63c3000+17e000]
~/.xinitrc
Code:

#!/bin/sh
#  xinitrc.xfce - modified to work around xfce4session bug
#                https://bugzilla.xfce.org/show_bug.cgi?id=8841


########################################################################
##  Merge in defaults and keymaps                                    ##
########################################################################

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

if [ -f $sysresources ]; then
    /usr/bin/xrdb -merge $sysresources
fi

if [ -f $sysmodmap ]; then
    /usr/bin/xmodmap $sysmodmap
fi

if [ -f $userresources ]; then
    /usr/bin/xrdb -merge $userresources
fi

if [ -f $usermodmap ]; then
    /usr/bin/xmodmap $usermodmap
fi

########################################################################
##  Start xfce Desktop Environment                                    ##
########################################################################

if [ -z "$DESKTOP_SESSION" -a -x /usr/bin/ck-launch-session ]; then
  exec ck-launch-session dbus-launch --exit-with-session /usr/bin/startxfce4
else
  exec dbus-launch --exit-with-session /usr/bin/startxfce4
fi


cynwulf 05-01-2013 06:30 AM

Ensure the networkmanager daemon is not set as executable and that you don't have nm-applet set to run at startup and it won't trouble you. You do not need to go into "network connections" in the Xfce menu if you configured your connection using slack's networking daemon.

You're actually trying to execute those .pdf files. Try to execute an actual pdf viewer (e.g. xpdf) or just put them on the desktop.

BadAvocado 05-01-2013 06:45 AM

Quote:

Originally Posted by caravel (Post 4942515)
Ensure the networkmanager daemon is not set as executable and that you don't have nm-applet set to run at startup and it won't trouble you. You do not need to go into "network connections" in the Xfce menu if you configured your connection using slack's networking daemon.

Thanks for the reply. networkmanager is not set as executable.

Code:

# ls -al /etc/rc.d/rc.networkmanager
-rw-r--r-- 1 root root 1669 Aug 14  2012 /etc/rc.d/rc.networkmanager

I'm aware that I don't 'need' to use Network Connections, I just assumed this is an entry for nm-applet, so I tried to run it to see what happens. In any case, starting nm-applet from terminal produces a dbus error, and since these segfault errors are littered throughout /var/log/messages, I'd like to diagnose/fix the problem.

Quote:

You're actually trying to execute those .pdf files. Try to execute an actual pdf viewer (e.g. xpdf) or just put them on the desktop.
Thanks, I figured that out after my original post, and then I edited the post to remove that question.

cynwulf 05-01-2013 07:28 AM

nm-applet relates to network manager - you don't need to run it and yes it will produce a dbus error if the networkmanager daemon is not running.

You should be able to disable it from running on startup in the xfce settings.

BadAvocado 05-01-2013 02:01 PM

Quote:

Originally Posted by caravel (Post 4942551)
nm-applet relates to network manager - you don't need to run it and yes it will produce a dbus error if the networkmanager daemon is not running.

You should be able to disable it from running on startup in the xfce settings.

Settings / Session and Startup / Session tab shows:
xwfm4
Thunar
Xfsettingsd
xfce4-panel
xfdesktop
/usr/bin/hp-systray
Power Manager

Of all those, both hp-systray and Thunar show no PID and the restart style is "if running" for both. So I'm not sure what's causing the error to pop up in /var/log/messages.

cynwulf 05-01-2013 04:50 PM

Settings / Session and Startup / Application Autostart / "Network (Manage your network connections)"

Uncheck - done.

(I also get the same segfault when trying to run nm-applet, when the networkmanager daemon is not running.)

BadAvocado 05-02-2013 12:52 AM

Quote:

Originally Posted by caravel (Post 4942951)
Settings / Session and Startup / Application Autostart / "Network (Manage your network connections)"

Uncheck - done.

(I also get the same segfault when trying to run nm-applet, when the networkmanager daemon is not running.)

Thanks - I guess I was being 'dense' yesterday. :)


All times are GMT -5. The time now is 08:43 AM.