LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-24-2013, 06:36 PM   #1
max_arbit
Member
 
Registered: Aug 2010
Posts: 40

Rep: Reputation: 2
XFCE problems after update


I am running Slackware 14.0 32bit on my desktop (it's a pretty old machine). Yesterday, I updated the system using slackpkg upgrade-all. While doing this, I noticed there were a few xorg updates too, however since virtually everytime, everything just works with these updates, I just went through it.

However, after rebooting, my XFCE is behaving weirdly. The mouse pointer shows up as a cross, any window I open only opens in the left half of the screen, I don't see the top bar (I don't know what it is called, but the one which has buttons for maximizing, minimizing, closing :-)) and so on. I suspect it is a configuration (or driver) issue which may have gotten overwritten by the update. However, right now I am clueless and don't know where to start the debug process. Any help is greatly appreciated!

Also, I tried switching back to KDE and this is what I noticed: when I run xwmconfig (from terminal), I see weird fonts showing up on the screen. I could still select xinitrc.kde and then startx seems work ok (though I still thought there were minor issues with KDE too). So, mostly pointing towards overwritten configuration files or drivers. Can somebody help me please? Thanks!
 
Old 04-24-2013, 08:24 PM   #2
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,217

Rep: Reputation: 176Reputation: 176
I use to have the same problems with Xfce, and on a fairly regular basis. I tried several
ways to "fix it" and strumbled across the solution one day when I was just about stop using Xfce and go back to, ugh, KDE.

Here is the fix, log out of Xfce, delete your ~/.cache/sessions directory and then log back in. That should do it.
Good luck.

BTW, this hasn't been a problem since the 23 March 2013 -current upgrades for Xfce.

Last edited by cwizardone; 04-25-2013 at 10:53 AM.
 
2 members found this post helpful.
Old 04-24-2013, 08:26 PM   #3
mlslk31
Member
 
Registered: Mar 2013
Location: Florida, USA
Distribution: Slackware, FreeBSD
Posts: 107

Rep: Reputation: 30
It looks like things went badly. Try the update again.

Before you do anything, though, make a new user and use that new user to start Xfce. If things look much better, it means something in the update did not like your old configuration.

X11 fonts need an insane amount of love and care for what they are. There's a font cache update section in /etc/rc.d/rc.M, so make sure that that's been run. You could try to reinstall the fonts so that it's font updaters run. [Forum: Does it still help to learn to run mkfontdir and mkfontscale by hand? Age is showing here.] Plus there seem to be new XDG/FreeDesktop-based toys to do this that I know nothing about.

If KDE is looking way better than Xfce, consider the need to update one of Xfce's prerequisites, whether it be something directly Xfce like exo or garcon or something deeper like GTK+ or glade. KDE is based in Qt, so things in the GTK+ world might not affect it too much.

You seem to be seeing enough to make me think that X11 is still doing well, but please cite your video hardware, anyway, just in case.
 
2 members found this post helpful.
Old 04-25-2013, 04:46 AM   #4
STDOUBT
Member
 
Registered: May 2010
Location: Stumptown
Distribution: Slackware 14.0/32bit + a T60p (2007-YS3) = YES
Posts: 260

Rep: Reputation: 60
Quote:
The mouse pointer shows up as a cross, any window I open only opens in the left half of the screen, I don't see the top bar (I don't know what it is called, but the one which has buttons for maximizing, minimizing, closing :-))
I used to use XFCE. The only time I've seen the "window decoration" disappear is when I've mis-configured compiz. Are you running compiz or some crazy Theme you downloaded from xfce-look? It also seems your mouse "theme" has been replaced by the default X11 mouse cursor. That's not a bad thing in my opinion ;-)
 
Old 04-25-2013, 10:40 PM   #5
max_arbit
Member
 
Registered: Aug 2010
Posts: 40

Original Poster
Rep: Reputation: 2
Success!

Thanks a lot everybody for your replies.

I tried the following:
Quote:
Before you do anything, though, make a new user and use that new user to start Xfce. If things look much better, it means something in the update did not like your old configuration.
1. Created a new user and in that, XFCE worked just perfectly fine!
Quote:
Here is the fix, log out of Xfce, delete your ~/.cache/sessions directory and then log back in. That should do it.
Good luck.
2. Then I went back and followed cwizardone's suggestion of removing ~/.cache/session and then it worked like a charm for the original user too :-)
3. The main reason I use KDE is that this desktop I am talking about is quite a old one and if I am running KDE, it is just slower. Everything works, but just a bit slow. Probably, I could do things to make it faster (I just tried switching off compiz, which improved things, but still not as fast as XFCE), but so far I had never faced any issue with XFCE and I even love it's real plain look :-)

Once I get a better desktop, I will definitely give KDE a shot. Thanks a million for all your replies guys.

Before I mark this as solved though, one last thing unresolved is that when I am on terminal (the default boot mode for me) and I run xwmconfig, I still get these weird non-english fonts (instead of the nice rectangular box that is supposed to come). Now that my XFCE is working, I did within a terminal inside XFCE and everything there looks nice and clean. I don't know why is that. That might be the font problem that mlslk31 referred to. How can I fix this?

Quote:
BTW, this hasn't been a problem since the 23 March 2013 -current upgrades for Xfce.
I am running 14.0 and not -current. So maybe there was some issue when I upgrading? In fact, now with all these things happening, I do remember that when I was running slackpkg upgrade-all, in the middle of the upgrade, the whole thing froze. I don't know why. I just canceled it and reran the upgrade-all. So maybe that screwed up somethings? Is there a way to check what were the updates I did last time and just rerun those upgrades?

Again that's a ton for all your helps guys! :-)
 
Old 04-26-2013, 05:58 PM   #6
mlslk31
Member
 
Registered: Mar 2013
Location: Florida, USA
Distribution: Slackware, FreeBSD
Posts: 107

Rep: Reputation: 30
Quote:
Originally Posted by max_arbit View Post
Thanks a lot everybody for your replies.
Before I mark this as solved though, one last thing unresolved is that when I am on terminal (the default boot mode for me) and I run xwmconfig, I still get these weird non-english fonts (instead of the nice rectangular box that is supposed to come). Now that my XFCE is working, I did within a terminal inside XFCE and everything there looks nice and clean. I don't know why is that. That might be the font problem that mlslk31 referred to. How can I fix this?

I am running 14.0 and not -current. So maybe there was some issue when I upgrading? In fact, now with all these things happening, I do remember that when I was running slackpkg upgrade-all, in the middle of the upgrade, the whole thing froze. I don't know why. I just canceled it and reran the upgrade-all. So maybe that screwed up somethings? Is there a way to check what were the updates I did last time and just rerun those upgrades?

Again that's a ton for all your helps guys! :-)
The upgrade issue is more for the better-connected experts to solve. I use slackware-current, so I upgrade by rsync'ing slackware-current (less KDE) to a USB key, and I take the key to my private-data and backup-verification PCs that by design have no Internet connection. This means I use the standard installpkg/removepkg/upgradepkg scripts. For these "classic" tools, sometimes you can do `upgradepkg pkg.txz`, and it will work. Sometimes it takes `upgradepkg --install-new pkg.txz`. Sometimes it takes `upgradepkg --reinstall --install-new pkg.txz`. In extreme cases--like using rpm2tgz to convert the OpenOffice.org RPMs to tgz format, only `installpkg pkg.txz` seems to work. `removepkg pkg` might be needed before `installpkg pkg.txz` in some cases, just to be sure. Now it's up to somebody else to convert that syntax for modern tools.

As for the fonts, unless somebody got really fancy, X11 fonts and console fonts are separate. On installation, if you chose a custom screen font, the /etc/rc.d/rc.font script should fire and load your custom screen font. For testing purposes, mine looked like this:

Code:
#!/bin/sh
#
# This selects your default screen font from among the ones in
# /usr/share/kbd/consolefonts.
#
setfont -v s.fnt.gz
Before I used the `setconsolefont` program, that last line was just `setfont -v`. These fonts come from the kbd and terminus-font packages.

It gets crazy from there. Language settings can change how fonts render, and the kernel itself can have its font changed out. However, if your console font looks like regular VGA until halfway through the boot process, start by looking at /etc/rc.d/rc.font and `setconsolefont`. If your X11 fonts are now working well, there will hopefully be no need to touch them.

I thank cwizardone for the real answer here. My solution is usually to do `rm -r .cache`, `rm -r .config`, `rm -r .anything-that-does-not-look-important` until something works or I regret it not working after all that deleting.
 
Old 04-26-2013, 10:58 PM   #7
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,229

Rep: Reputation: 286Reputation: 286Reputation: 286
Quote:
Originally Posted by max_arbit View Post
...I noticed there were a few xorg updates too, however since virtually everytime, everything just works with these updates, I just went through it.

However, after rebooting, my XFCE is behaving weirdly. The mouse pointer shows up as a cross, ...
I had exactly the same problem. I "solved" it by creating a new user profile, and reinstalling the binary blob nvidia driver.

I will keep cwizardone's fix noted for future reference.

I just love that there is always a way to fix the few and far between problems that may develop with using Slackware!
 
Old 04-27-2013, 08:00 AM   #8
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,217

Rep: Reputation: 176Reputation: 176
Quote:
Originally Posted by max_arbit View Post
...Before I mark this as solved though, one last thing unresolved is that when I am on terminal (the default boot mode for me) and I run xwmconfig, I still get these weird non-english fonts (instead of the nice rectangular box that is supposed to come). Now that my XFCE is working, I did within a terminal inside XFCE and everything there looks nice and clean. I don't know why is that. That might be the font problem that mlslk31 referred to. How can I fix this?...
I am not sure this will help, but have you tried running, as root, pkgtool > setup > 04.mkfontdir
and then 05.fontconfig ?
Just a thought.
 
Old 04-28-2013, 03:31 AM   #9
STDOUBT
Member
 
Registered: May 2010
Location: Stumptown
Distribution: Slackware 14.0/32bit + a T60p (2007-YS3) = YES
Posts: 260

Rep: Reputation: 60
tommcd,
I had that problem with "weird non-english fonts" in the terminal after I changed my /etc/profile.d/lang.sh to use UTF-8 per DuganChen's instructions here:
http://duganchen.ca/writings/slackware/fonts/
I was able to solve the problem by adding this "append=" line to my /etc/lilo.conf

Code:
# Append any additional kernel parameters:
append=" vt.default_utf8=1"
I haven't delved into "pkgtool > setup" etcetera like cwizardone suggests you do, but it might be worth your while to check that out first ;-) My way is probably a kludge...
 
2 members found this post helpful.
Old 04-29-2013, 10:18 PM   #10
max_arbit
Member
 
Registered: Aug 2010
Posts: 40

Original Poster
Rep: Reputation: 2
Solved

Quote:
tommcd,
I had that problem with "weird non-english fonts" in the terminal after I changed my /etc/profile.d/lang.sh to use UTF-8 per DuganChen's instructions here:
http://duganchen.ca/writings/slackware/fonts/
I was able to solve the problem by adding this "append=" line to my /etc/lilo.conf

Code:
# Append any additional kernel parameters:
append=" vt.default_utf8=1"
This was it! Thanks a lot guys for quick replies and I apologize for the late reply (got caught up in some other work) :-)

Marking as solved..
 
Old 04-30-2013, 06:39 AM   #11
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,006

Rep: Reputation: 742Reputation: 742Reputation: 742Reputation: 742Reputation: 742Reputation: 742Reputation: 742
Coming in a little late (had cataract surgery yesterday and couldn't read too well with wide-open irises).

The problems I've had with Xfce (Slackware 14.0 stable) have, typically, been the goofy cursor and the magic window resize "feature."

Usually, the cursor thing happens when I shut down Xfce (I use startx) and it takes up to, oh, three minutes to quit -- a restart winds up all screwed up. The trick I learned was to simply
Code:
cd
rm -r .cache
The annoying feature (when you slide a window to the top of the screen and automatically tiles it) can be cured in the Settings, Window Manage Tweaks, Accessibility, un-check the Automatically tile windows when moving toward the edge.

Fonts. The distribution fonts (in /usr/share/fonts, TTF and Type1) come with the fonts.scale and fonts.dir files. You can, if you want, get in there and rebuild them:
Code:
su -
cd /usr/share/fonts/TTF
mkfontscale
mkfontdir
cd ../Types
mkfontscale
mkfontdir
Probably not necessary, but what the heck; I don't remember ever having to redo those files.

If you have other TTF or Type1 fonts installed in, say /usr/local/share/fonts and did not build the fonts.scale and fonts.dir files as above, be a good idea to do so.

For example, my /usr/local/share/fonts directory has these fonts directoryies:
Code:
ls /usr/local/share/fonts
Adobe/  Interstate/  MSfonts/  myfonts/\
(all have manually-generated fonts.scale and fonts.dir files)

And, to use those there is this:
Code:
cat /etc/fonts/local.conf
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/local.conf file to configure system font access -->
<fontconfig>
	<dir>/usr/local/share/fonts/Adobe</dir>
	<dir>/usr/local/share/fonts/MSfonts</dir>
	<dir>/usr/local/share/fonts/myfonts</dir>
	<dir>/usr/local/share/fonts/Interstate</dir>
</fontconfig>
Works fine; in the above, the Adobe directory contains the Adobe Type Library, had it for 20-some years, never had a lick of problem with it (or the others).

I had a problem with ghostview using UTF-8 (kicked out a lot of error messages about fonts). The solutions was reset to EN_US. Not the best solution, but the one that worked.

You know that message in /etc/profile.d/lang.sh?
Code:
# There is also support for UTF-8 locales, but be aware that
# some programs are not yet able to handle UTF-8 and will fail to
# run properly.  In those cases, you can set LANG=C before
# starting them.  Still, I'd avoid UTF unless you actually need it.
#export LANG=en_US.UTF-8
Well, it's true.

One other thing you may wan to consider is blowing away the KDE stuff in your home directory (like ~/.kde and where those symbolic links point). If you've started KDE once, you've got a whole lot of stuff running that you don't actually want running and it's a PITA to get rid of it.

Hope this helps some.
 
1 members found this post helpful.
Old 05-01-2013, 09:31 PM   #12
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,229

Rep: Reputation: 286Reputation: 286Reputation: 286
Well, for whatever reason, when I booted up Slack 14 64 bit today, I had only one desktop available on my XFCE, and my mouse pointer was nowhere to be found!
Not to worry though,
I simply hit CTRL + ALT + backspace keys to log out of X and used cwizardone's fix that he listed in post #2 in this thread:
Quote:
Here is the fix, log out of Xfce, delete your ~/.cache/sessions directory and then log back in. That should do it.
And when I ran startx again everything was back to normal!
Thanks again to everyone for all that I have learned here in this thread!

Last edited by tommcd; 05-01-2013 at 09:32 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Fedora 13 Xfce update LXer Syndicated Linux News 0 08-22-2010 11:40 AM
[SOLVED] How to update xfce? codeman1234 Linux - Desktop 6 04-09-2010 05:04 AM
Cannot login into XFCE after update DodoTux Zenwalk 4 12-29-2006 04:27 PM
Xfce problems with task bar and xfce-panel aeruzcar Linux - Software 4 06-26-2006 05:29 AM
FC3: how to update Xfce from 4.06 to 4.2 ghee22 Fedora 5 03-08-2005 01:20 PM


All times are GMT -5. The time now is 11:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration