LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-29-2013, 01:17 PM   #1
Bertman123
Member
 
Registered: Jun 2010
Distribution: Slackware 14.1 64 bit MLED with KDE
Posts: 243

Rep: Reputation: 32
xfce on 14.1 screen keeps on shutting off


I'm using the xfce desktop on 14.1 32 bit and have it set in the power settings to not shut the screen off. However the screen keeps shutting off after about 15 minutes. I have disabled the screensaver from starting when my laptop boots and have tried typing "xset -dpms" in the terminal, which has not helped either. Am I missing a setting somewhere?
 
Old 12-29-2013, 01:40 PM   #2
metaschima
Senior Member
 
Registered: Dec 2013
Distribution: Slackware
Posts: 1,493

Rep: Reputation: Disabled
Check '/etc/rc.d/rc.M', near the top you will see:
Code:
# Screen blanks after 15 minutes idle time, and powers down in one hour
# if the kernel supports APM or ACPI power management:
/bin/setterm -blank 15 -powersave powerdown -powerdown 60
You can change these numbers as needed. I usually change blank to 30, which is more reasonable.
 
Old 12-29-2013, 01:44 PM   #3
Bertman123
Member
 
Registered: Jun 2010
Distribution: Slackware 14.1 64 bit MLED with KDE
Posts: 243

Original Poster
Rep: Reputation: 32
Quote:
Originally Posted by metaschima View Post
Check '/etc/rc.d/rc.M', near the top you will see:
Code:
# Screen blanks after 15 minutes idle time, and powers down in one hour
# if the kernel supports APM or ACPI power management:
/bin/setterm -blank 15 -powersave powerdown -powerdown 60
You can change these numbers as needed. I usually change blank to 30, which is more reasonable.
Is it safe to comment that line out?
 
Old 12-29-2013, 02:02 PM   #4
metaschima
Senior Member
 
Registered: Dec 2013
Distribution: Slackware
Posts: 1,493

Rep: Reputation: Disabled
Set them both to 0 if you want to turn the feature off. I find it useful, so I don't have to keep pressing the monitor button myself when I walk away.
 
1 members found this post helpful.
Old 12-29-2013, 02:15 PM   #5
Bertman123
Member
 
Registered: Jun 2010
Distribution: Slackware 14.1 64 bit MLED with KDE
Posts: 243

Original Poster
Rep: Reputation: 32
Quote:
Originally Posted by metaschima View Post
Set them both to 0 if you want to turn the feature off. I find it useful, so I don't have to keep pressing the monitor button myself when I walk away.
Thanks for your help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shutting Down XFCE in Debian debianboy Linux - Desktop 5 05-04-2009 08:30 PM
black screen and freeze when shutting down eNtoS Ubuntu 3 12-10-2006 06:37 AM
Blank screen while shutting down tcamp Fedora 4 10-17-2005 06:36 PM
Screen Goes Crazy When Shutting Down 9.3 RAMMS+EIN Suse/Novell 1 08-18-2005 09:38 PM
screen does not power off after shutting the lid roaher Linux - Laptop and Netbook 4 09-19-2003 05:54 PM


All times are GMT -5. The time now is 08:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration