LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Xfce No Cursor for All Non-root Users Slackware 14.0 32-bit (http://www.linuxquestions.org/questions/slackware-14/xfce-no-cursor-for-all-non-root-users-slackware-14-0-32-bit-4175450558/)

tronayne 02-17-2013 12:17 PM

Xfce No Cursor for All Non-root Users Slackware 14.0 32-bit
 
All of a sudden when Xfce starts, all non-root users have no cursor. The mouse does work after I drag it around all over the place to highlight that Applications Menu then slide up a little to highlight Logout.

What in blue blazes is causing this!

I created a new account, log in to it , startx, got a cursor. Log out, log back in, no cursor. Too, it took quite a while (like a couple of minutes) to log out.

One other thing -- I removed every "dot" file in an existing account (except .profile, .exrc and .kshrc), logged out, logged back in, no cursor but all the previously added Launchers were still there (with no .config, .caches or any other files). I don't know where to look for what's going on.

Any ideas?

Additional Stuff (18 Feb):

This machine is configured identically to three others (two 64-bit, one 32-bit), none of which exhibit this problem.

I have been removing the .cache directory from the user account before logging off (and logging back in I do get a cursor) but it takes, like a minute for the logout! Seems kind of silly to do rm -r .cache every time you log out, eh?

I can find nothing in this box that differs from others, it's a clean install, no fiddling with the kernel, every stable patch installed, no fine-tuning of anything.

The one addition is in /etc/profile.d/ksh.sh -- all users on all machines use KornShell, and this is used to set the environment (/etc/profile is untouched):
Code:

#!/bin/sh
#ident        "$Id$"
#
#        Name:                $Source$
#        Version:        $Revision$
#        Modified:        $Date$
#        Purpose:        set local environment variables for Korn Shell
#        Author:                T. N. Ronayne
#        Date:                1 Oct 2009
#        $Log$
# Set the HOST environment variable
export HOST="`uname -n`"
# Set ksh93 visual editing mode:
if [ "$SHELL" = "/bin/ksh" ]; then
#  VISUAL=emacs                # ugh
#  VISUAL=gmacs                # double ugh
  VISUAL=vi                # ah, elegence
fi
# Set a default shell prompt:
#PS1='`hostname`:`pwd`# '
# Do these anyway in case sombody uses a different shell
if [ "$SHELL" = "/bin/pdksh" ]; then
 PS1='! $ '
elif [ "$SHELL" = "/bin/ksh" ]; then
 PS1='${HOST}-${USER}-${PWD}: '
elif [ "$SHELL" = "/bin/zsh" ]; then
 PS1='%n@%m:%~%# '
elif [ "$SHELL" = "/bin/ash" ]; then
 PS1='$ '
else
 PS1='\u@\h:\w\$ '
fi
PS2='> '
export PS1 PS2

Don't think that has anything to do with, but...

All users also have a .kshrc for their environment (and it's the same everywhere, just sets aliases):
Code:

cat .kshrc
alias lc='/usr/bin/clear; /bin/ls ${LS_OPTIONS} -aCF'
alias ll='/bin/ls ${LS_OPTIONS} -al'
alias cls='clear'
alias hi='history -${LINES}'
alias rs='eval `resize`'

And the PATH environment is also set in their .profile for some local stuff:
Code:

cat .profile
#        set up default columns and lines
COLUMNS=80
LINES=40
export COLUMNS LINES
#        set up default group
GRPNAME=`groups | cut -d' ' -f1`
export GRPNAME
#        set up a good-size history
HISTSIZE=1000
export HISTSIZE
#        set up the ksh environment
ENV=${HOME}/.kshrc
export ENV
#        set up CVSROOT
CVSROOT=:pserver:root@fubar.com:/usr/local/cvsroot
export CVSROOT
#        change the PATH a little
export PATH=.:${HOME}/bin:${PATH}
export INSTALL_BASE=${HOME}
export LLDATABASES=${HOME}/LifeLines:.
export LLPROGRAMS=.:/usr/local/share/lifelines
#        make COLUMNS and LINES the screen size
eval `resize`

I cannot imagine what would be causing this stuff -- I'm a little leery of trying KDE (what the heck, Xfce works just fine everywhere else, eh?).

Appreciate any insight.

cynwulf 02-18-2013 09:02 AM

I can't be sure, but this seems like more of a video problem...

Do you have xfwm4's compositor enabled? If so then disable it.

Also post the contents of your xorg.conf

You might want to try the software cursor also, e.g.

Code:

Section "Device"
        Identifier  "Card0"
        Driver      "radeon"
        Option      "HWCursor" "false"
        Option      "SWCursor" "true"

EndSection

("radeon" is just an example, substitute with the driver for your GPU)

It can be helpful to look at the xorg log files for errors, e.g.

Code:

$ grep 'WW\|EE' /var/log/Xorg.0.log

tronayne 02-18-2013 11:48 AM

Ah-Ha!

This box has a long history of Radeon problems -- old hardware.

That took care of it.

Thank you.


All times are GMT -5. The time now is 07:42 AM.