LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   xfce does not save my keyboard layouts across suspend-resume (http://www.linuxquestions.org/questions/slackware-14/xfce-does-not-save-my-keyboard-layouts-across-suspend-resume-4175437400/)

bogzab 11-16-2012 03:18 AM

xfce does not save my keyboard layouts across suspend-resume
 
Slackware 14 and whatever xfce comes with it. Thinkpad Edge hardware. I added xfce-kb-plugin from slackbuiulds.org, installed it and added it to the panel.

I can add the keyboard layouts I need and remove the default US layout. I can switch between layouts - all works fine. However when I suspend the laptop and resume I find I have only the default US keyboard back again. I have tried Saving the Session but that does not seem to help.

Does anybody know if there is a config file somewhere that I should make sure contains the right settings before suspending?

Thanks

ppencho 11-16-2012 12:05 PM

http://www.linuxquestions.org/questi...ap-4175433278/

http://docs.slackware.com/howtos:win...eyboard_layout

I also lost my layout settings after restart. So I added the layout in 90-keyboard-layout.conf, this works for me.

solarfields 11-16-2012 12:12 PM

in my case XFCE tends to "forget" the keyboard layout, occasionally...

so, i just copied the config file:

/usr/share/X11/xorg.conf.d/90-keyboard-layout.conf

to

/etc/X11/xorg.conf.d

Opened and edited the layouts to my needs. I also added the option to use ALT+SHIFT for layout switch:

Option "XkbOptions" "terminate:ctrl_alt_bksp,grp:alt_shift_toggle"

bogzab 11-17-2012 11:37 AM

Thanks to both replies which pointed to sorting this out at the level of the X config (/etc/X11/xorg.conf/d/90-keyboard-layout.conf) - this solves the problem so I am marking this as SOLVED. Some indication in the replies that it will work through the xfce plugin so long as you can identify your keyboard model correctly and precisely. Looks like if this is not correct in your config then xfce returns to a default keyboard layout.

Look like I should have looked first at docs.slackware.com which of course out of habit I failed to do trying general google searches and searches of the Slackware forum on LQ...

Thanks again for the help.


All times are GMT -5. The time now is 05:03 PM.