LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   xfce desktop suddenly changed (http://www.linuxquestions.org/questions/slackware-14/xfce-desktop-suddenly-changed-903628/)

wufo 09-18-2011 12:53 AM

xfce desktop suddenly changed
 
I am running Slackware 13.0and all of a sudden my desktop (xfce) changed.
Now when I log on the background stays the same as the login background, the shaded "bubble" type and I do not get my icons in the upper left corner, "Home", "Trash", etc.

What could have changed to cause these to go away and the desktop background change?

tj

wufo 09-18-2011 01:14 AM

A followup on this. Using Settings->Desktop and selecting backgroud image does not work and the "Home", "Trash" desktop icons are checked.

Making any changes in Deskop Settings causes no chnages to desktop appearance.

tj

Ilgar 09-18-2011 04:13 AM

I think the window manager doesn't start properly. What about the panels and menus, do they work?

I am not sure but maybe some config files got corrupted and that prevents some components from starting up correctly. The Xfce settings are under ~/.config, in the worst case you can try renaming the Xfce directories and start with a fresh config. Do this when your user is logged out. But before that you may also try clearing (again when logged out) the ~/.dbus directory. Some leftover old session file could also be causing these kinds of errors.

enorbet 09-18-2011 09:20 AM

Just Asking..
 
Greetz
I wonder do you have some version of Gnome installed? It is my understanding that Gnome often "bleeds" into other DEs. I don't know the solution but the first step is identifying the problem. So, if you have Gnome, I'd start looking there.

Eternal_Newbie 09-19-2011 08:20 AM

XFCE settings occasionally seem to get corrupted. The best thing to do is rename ALL the XFCE settings directories and start fresh. As well as the ones mentioned above under ~/.config , XFCE also stores settings in ~/.cache/sessions/ , ~/.cache/xfce4/ and ~/.cache/Thunar/ .

Obviously you want to do this from runlevel 3, or under another window manager.

slac-in-the-box 09-19-2011 11:23 AM

Eternal Newbie is correct: sometimes xfce gets corrupted cache files:

get to a console prompt and do the following

Code:

rm ~/.cache/sessions/xf*
this removes xfce4-session cache files as well as xfwm4 cache files... then log out and log back in and your settings should be restored... shouldn't have to change run levels or back up your life's work... your only deleting "cache" and not the actual settings...

i find that situation happens most frequently to my laptop if I let it run out of power... I don't think it gets the session saved properly before it dies, and then when I give it power again, my icons are gone, but only until I delete the session cache...

This is an issue when installing linux/xfce for people who don'tcare to tinker with it... it makes them hate it when their icons disappear, therefore, I was wondering, if adding the code to remove the cache to some startup script would be a viable workaround, and if so, I'm not sure which one to add it to: the user's shell startup (like ~/.zshrc) or maybe add it to /usr/bin/startx, or perhaps /etc/rc.d/local; does anyone have any suggestions about whether removing these cache files when user is logging in is a good idea?


All times are GMT -5. The time now is 09:20 PM.