LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Xfce 4.6.1 and Slack stable (http://www.linuxquestions.org/questions/slackware-14/xfce-4-6-1-and-slack-stable-723013/)

joutlancpa 05-01-2009 04:23 PM

Xfce 4.6.1 and Slack stable
 
My power manager icon is in the sys tray....but I can't access the power manager preference....it will give me a brief start up indication, then die off....anyone have a clue? Everything else seems fine. thanks

metrofox 05-01-2009 04:42 PM

Post the complete error ;) It may help us to solve the problem.

joutlancpa 05-01-2009 05:41 PM

Quote:

Originally Posted by metrofox (Post 3527141)
Post the complete error ;) It may help us to solve the problem.

There's no error message....when I try to launch settings, I get an 'hourglass' like the dialogue is going to appear, then it quits. I installed 4.6.1 from RW's site, PLUS the power manager package he says should be installed....is something going on here give the .1 update of Xfce?

niels.horn 05-01-2009 05:46 PM

It's not the 4.6.1 update I think, all works fine here...

Just a guess: are you a member of the 'power' group?
Not sure if it has anything to do with it, but it might be worth a try.

joutlancpa 05-01-2009 06:00 PM

Quote:

Originally Posted by niels.horn (Post 3527200)
It's not the 4.6.1 update I think, all works fine here...

Just a guess: are you a member of the 'power' group?
Not sure if it has anything to do with it, but it might be worth a try.

Here's my groups....I'm going to log in as root and try it also: EDIT: as root won't come either...it almost feels like a dependency is missing. I get an 'hourglass for about 20 seconds, then it dies)

Code:

root:x:0:root
bin:x:1:root,bin
daemon:x:2:root,bin,daemon
sys:x:3:root,bin,adm
adm:x:4:root,adm,daemon
tty:x:5:
disk:x:6:root,adm
lp:x:7:lp
mem:x:8:
kmem:x:9:
wheel:x:10:root,john
floppy:x:11:root,john
mail:x:12:mail
news:x:13:news
uucp:x:14:uucp
man:x:15:
audio:x:17:root,john
video:x:18:root,john
cdrom:x:19:root,john
games:x:20:
slocate:x:21:
utmp:x:22:
smmsp:x:25:smmsp
tape:x:26:root
mysql:x:27:
rpc:x:32:
sshd:x:33:sshd
gdm:x:42:
shadow:x:43:
ftp:x:50:
apache:x:80:
messagebus:x:81:
haldaemon:x:82:
plugdev:x:83:root,john
power:x:84:root,john
pop:x:90:pop
scanner:x:93:
nobody:x:98:nobody
nogroup:x:99:
users:x:100:
console:x:101:


joutlancpa 05-01-2009 06:31 PM

to follow up, I've removed and reinstalled the power manager...it works, and reacts to unplugging the power cord....dims the screen too dark, which won't work....just can't bring up preferences....is there an error log somewhere I can check, or a settings file somewhere?

EDIT: Also, my dedicated sound level buttons on the keyboard quit working, xorg.conf didn't change....how can I do a clean rollback? i.e. the best way?

niels.horn 05-01-2009 06:38 PM

On my Dell Latitude I set the screen with the Fn+Up/Down keys.
The setting somehow is saved for the plugged & battery states.

So just turn the brightness up a bit while on battery, then plug in the power cord.
When unplugging, it should come back to the brightness setting you had before.

joutlancpa 05-01-2009 06:56 PM

Quote:

Originally Posted by niels.horn (Post 3527249)
On my Dell Latitude I set the screen with the Fn+Up/Down keys.
The setting somehow is saved for the plugged & battery states.

So just turn the brightness up a bit while on battery, then plug in the power cord.
When unplugging, it should come back to the brightness setting you had before.

I went to the console and rolled it back to 4.4.3 reluctantly for right now till I do some research...thanks for the info on the brightness, but I hated not having my sound keys which are working again...don't get it...something hiding, somewhere...this precision is really funky with distros...I had to give up MEPIS 8 because of it (that's good because I saw the light of Slackware :). Only Slack and the 'buntu's work on it with my limited skills :) with 4.4.3 it idles at around 0-1% cpu load and stays cool...I don't hibernate with linux, and I compiled the kernel to a preferred 'on demand' power setting....do I know what I'm talking about here? :) :)

niels.horn 05-01-2009 07:11 PM

Do you mean the buttons for volume up/down/mute?
I remember vaguely changing something when I switched from Xfce 4.4 to 4.6.0 but I don't have my notes with me here (not at home right now...)
On my Dell Latitude the three sound buttons (volume up / down + mute) are working fine in Xfce 4.6.1

joutlancpa 05-01-2009 09:50 PM

Quote:

Originally Posted by niels.horn (Post 3527278)
Do you mean the buttons for volume up/down/mute?
I remember vaguely changing something when I switched from Xfce 4.4 to 4.6.0 but I don't have my notes with me here (not at home right now...)
On my Dell Latitude the three sound buttons (volume up / down + mute) are working fine in Xfce 4.6.1

Yes, those buttons....I think we have the same keyboard layout....on this precision m4400, those buttons stop working everytime I go to 4.6.0 or .1 But, with 4.6.0, not .1, the power manager settings worked, but I had the icon problem (know about workaround). Wonder what's up? Where are power manager preferences hidden? If anyone knows offhand it would help (me) thanks

niels.horn 05-01-2009 10:46 PM

Did you check if the keycodes are the same with 'xev'?

In my case they return XF86AudioRaiseVolume / XF86AudioLowerVolume / XF86AudioMute, but only after setting them in /etc/X11/xinit/.Xmodmap

Then in Xfce, in the 'menu - settings - keyboard' click on the "Application Shortcuts" tab and use:
Code:

Command                  | Shortcut
------------------------- | ---------------------
amixer set Master 10%+    | XF86AudioRaiseVolume
amixer set Master 10%-    | XF86AudioLowerVolume
amixer set Master toggle  | XF86AudioMute

Well, if you need some more help, just ask here!

joutlancpa 05-02-2009 01:24 AM

Quote:

Originally Posted by niels.horn (Post 3527386)
Did you check if the keycodes are the same with 'xev'?

In my case they return XF86AudioRaiseVolume / XF86AudioLowerVolume / XF86AudioMute, but only after setting them in /etc/X11/xinit/.Xmodmap

Then in Xfce, in the 'menu - settings - keyboard' click on the "Application Shortcuts" tab and use:
Code:

Command                  | Shortcut
------------------------- | ---------------------
amixer set Master 10%+    | XF86AudioRaiseVolume
amixer set Master 10%-    | XF86AudioLowerVolume
amixer set Master toggle  | XF86AudioMute

Well, if you need some more help, just ask here!

Thanks, I'll check that tomorrow....it's late, can't see very well...:D


All times are GMT -5. The time now is 05:06 PM.