LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Xfce 4.10 Menu bar's icons not display properly (http://www.linuxquestions.org/questions/slackware-14/xfce-4-10-menu-bars-icons-not-display-properly-948930/)

gabytf 06-06-2012 10:12 PM

Xfce 4.10 Menu bar's icons not display properly
 
I am with Slackware13.37, i upgraded to xfce 4.10 by using pkgtool using pkg contributed by http://people.salixos.org/ralvex/pkg/i486/Xfce-4.10/,
i removepkg the original version xfce, then install xfce 4.10 from pkgtool.

Problem: Some of my icons at the menu bar not display properly as before after i upgrade to xfce 4.10

Samething happened even i download from the official site http://archive.xfce.org/xfce/4.10/src

Why it is like that and How can i fix this?
Thank you.

NyteOwl 06-07-2012 12:25 PM

In all likelihood you neglected to update one or more dependancies for XFCE 4.10.

gabytf 06-08-2012 03:59 AM

Working on it...first of all i think i need to meet this requirement:

Quote:

Xfce 4.10 requires Gtk+ 2.20 and Glib 2.24
Xfce 4.8 requires Gtk+ 2.14 and Glib 2.20
Xfce 4.6 requires Gtk+ 2.10 and Glib 2.12
http://docs.xfce.org/xfce/building

because that i am on 13.37 which come with xfce 4.6, my Gtk+ and Glib not upgrade yet.
Looking for Gtk+ 2.20 and Glib 2.24 which packed for 13.37...can you advise where can i refer to? Thanks!

Edit: Is gtk-engine-2.20.2 is the same with gtk+ 2.20?
[url]http://pkgs.org/slackware-13.37/slacky-i486/gtk-engines-2.20.2-i486-1sl.txz.html

My laptop previously having installed:
gtk+ -1.2.10-i486-5
gtk+2 -2.24.4-i486-1
glib -1.2.10-i486-3
glib2 -2.28.6-i486-1


All times are GMT -5. The time now is 05:00 AM.