LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-20-2012, 12:27 PM   #1
dunric
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 446

Rep: Reputation: 51
Xfce's Thunar automount issue


Hi,

in /etc/fstab I have the following entry:
Code:
/dev/sdb1       /mnt/memory auto noauto,rw,user,comment=x-gvfs-show  0 0
The x-gvfs-show option recommends Pat in his Changes & Hints document.

Volume gets automounted in Xfce but unexpectedly with root:root ownership. If there is no entry for the device in /etc/fstab it is properly automounted with current user ownership. How can I achieve user automount for devices listed in fstab ?

Btw. mount /mnt/memory from shell does mount with current user privileges. It just does not work for Gvfs-based Thunar's Volman.
 
Old 11-20-2012, 05:01 PM   #2
ljb643
Member
 
Registered: Nov 2003
Posts: 264

Rep: Reputation: Disabled
Interesting find - confirmed. I assume this has a VFAT-type filesystem on the volume (e.g. one with no inherent file ownership concept).

The default for vfat filesystems (uid,gid options) is the IDs of the current process. When you issue the mount command line, that's you, so you own the files on the volume.

But when Xfce/Thunar mounts the volume (whether because you enabled auto-mount, or because you right-clicked it on the desktop and picked Mount), then the udisks2 process does the mount. If there is no entry for the volume in /etc/fstab, then udisks makes you the owner of files on the volume. It also mounts it at the location we all complain about /run/media/USER/volume.

However, if there is an entry in /etc/fstab, then udisks seems to use exactly the options there, and does not arrange to "fix" the ownership. udisks runs as root, hence root owns files on the volume.

Options?
  1. Remove the entry from /etc/fstab, and live with the default options and awkward mount point that udisks likes.
  2. If this is a single user situation, you could probably add the uid=... option to the /etc/fstab line for the volume.
  3. Use only command-line mounts.
(I didn't say they were good options)
 
1 members found this post helpful.
  


Reply

Tags
automount, slackware, thunar, xfce


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
thunar service not started -- cygwin and xfce mtdew3q Linux - Desktop 2 02-25-2013 01:35 PM
[SOLVED] Thunar 1.4.0 and Fluxbox on -current: no trash or automount usb devices andrew.46 Slackware 29 09-05-2012 02:59 AM
XFCE double click in thunar after last nov upgrading anti_user Slackware 6 11-23-2010 10:52 AM
How to automount usb flash drives in Thunar (openbox) iamthat Linux - Newbie 1 05-12-2010 12:56 AM
Help on XFCE thunar-archive-plugin igorthinks Linux - Desktop 1 08-21-2008 09:58 AM


All times are GMT -5. The time now is 11:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration