LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-26-2013, 06:48 PM   #1
jon lee
Member
 
Registered: Jul 2013
Posts: 81

Rep: Reputation: Disabled
XBMC on Slackware?


Has anyone been successful on this? I'm finding it to be a tough nut to crack. I made it through the whole patching tinyxml for stl support thing (or at least I thought I did...).

make[1]: Leaving directory `/home/slackjack/xbmc/lib/addons/library.xbmc.codec'
make -C lib/addons/library.xbmc.gui
make[1]: Entering directory `/home/slackjack/xbmc/lib/addons/library.xbmc.gui'
CPP lib/addons/library.xbmc.gui/libXBMC_gui.o
/usr/bin/ccache g++ -O2 -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -g -D_DEBUG -Wall -shared -g -o
../../../addons/library.xbmc.gui/libXBMC_gui-i486-linux.so libXBMC_gui.o
make[1]: Leaving directory `/home/slackjack/xbmc/lib/addons/library.xbmc.gui'
make -C lib/addons/library.xbmc.pvr
make[1]: Entering directory `/home/slackjack/xbmc/lib/addons/library.xbmc.pvr'
CPP lib/addons/library.xbmc.pvr/libXBMC_pvr.o
/usr/bin/ccache g++ -O2 -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -g -D_DEBUG -Wall -shared -g -o
../../../addons/library.xbmc.pvr/libXBMC_pvr-i486-linux.so libXBMC_pvr.o
make[1]: Leaving directory `/home/slackjack/xbmc/lib/addons/library.xbmc.pvr'
-----------------------
XBMC built successfully
-----------------------
root@bigbro:/home/slackjack/xbmc#


But when I try and start it, it hangs.
This is the resulting xbmc.log

18:34:55 T:3043702592 NOTICE: special://profile/ is mapped to: special://masterprofile/
18:34:55 T:3043702592 NOTICE: -----------------------------------------------------------------------
18:34:55 T:3043702592 NOTICE: Starting XBMC (13.0-ALPHA6 Git:20130725-91134c5), Built on Jul 26 2013 (GCC version 4.7.1). Platform: Linux (Slackware 14.0, 3.10.2-smp i686)
18:34:55 T:3043702592 INFO: Using Debug XBMC build
18:34:55 T:3043702592 NOTICE: special://xbmc/ is mapped to: /usr/share/xbmc
18:34:55 T:3043702592 NOTICE: special://xbmcbin/ is mapped to: /usr/lib/xbmc
18:34:55 T:3043702592 NOTICE: special://masterprofile/ is mapped to: /home/slackjack/.xbmc/userdata
18:34:55 T:3043702592 NOTICE: special://home/ is mapped to: /home/slackjack/.xbmc
18:34:55 T:3043702592 NOTICE: special://temp/ is mapped to: /home/slackjack/.xbmc/temp
18:34:55 T:3043702592 NOTICE: The executable running is: /usr/lib/xbmc/xbmc.bin
18:34:55 T:3043702592 NOTICE: Local hostname: bigbro
18:34:55 T:3043702592 NOTICE: Log File is located: /home/slackjack/.xbmc/temp/xbmc.log
18:34:55 T:3043702592 NOTICE: -----------------------------------------------------------------------
18:34:55 T:3043702592 INFO: Selected UPower as PowerSyscall
18:34:55 T:3043702592 INFO: CAESinkALSA - ALSA: pcm_hw.c:1293snd_pcm_hw_open) open '/dev/snd/pcmC1D0p' failed (-16): Device or resource busy
18:34:55 T:3043702592 INFO: CAESinkALSA - ALSA: pcm_dmix.c:1018snd_pcm_dmix_open) unable to open slave
18:34:55 T:3043702592 INFO: CAESinkALSA - Unable to open device "sysdefault:CARD=Device" for playback
18:34:55 T:3043702592 INFO: CAESinkALSA - ALSA: pcm_hw.c:1293snd_pcm_hw_open) open '/dev/snd/pcmC1D0p' failed (-16): Device or resource busy
18:34:55 T:3043702592 INFO: CAESinkALSA - ALSA: pcm_dmix.c:1018snd_pcm_dmix_open) unable to open slave
18:34:55 T:3043702592 INFO: CAESinkALSA - Unable to open device "default:CARD=Device" for playback
18:34:55 T:3043702592 INFO: CAESinkALSA - ALSA: pcm_hw.c:1293snd_pcm_hw_open) open '/dev/snd/pcmC1D0p' failed (-16): Device or resource busy
18:34:55 T:3043702592 INFO: CAESinkALSA - Unable to open device "front:CARD=Device,DEV=0" for playback
18:34:55 T:3043702592 INFO: CAESinkALSA - ALSA: pcm_hw.c:1293snd_pcm_hw_open) open '/dev/snd/pcmC1D0p' failed (-16): Device or resource busy
18:34:55 T:3043702592 INFO: CAESinkALSA - Unable to open device "iec958:CARD=Device,DEV=0" for playback
18:34:55 T:3043702592 NOTICE: Found 1 Lists of Devices
18:34:55 T:3043702592 NOTICE: Enumerated ALSA devices:
18:34:55 T:3043702592 NOTICE: Device 1
18:34:55 T:3043702592 NOTICE: m_deviceName : @
18:34:55 T:3043702592 NOTICE: m_displayName : Default (HDA Intel ALC272 Analog)
18:34:55 T:3043702592 NOTICE: m_displayNameExtra:
18:34:55 T:3043702592 NOTICE: m_deviceType : AE_DEVTYPE_PCM
18:34:55 T:3043702592 NOTICE: m_channels : FL,FR
18:34:55 T:3043702592 NOTICE: m_sampleRates : 48000
18:34:55 T:3043702592 NOTICE: m_dataFormats : AE_FMT_S32NE
18:34:55 T:3043702592 NOTICE: Device 2
18:34:55 T:3043702592 NOTICE: m_deviceName : @:CARD=Intel,DEV=0
18:34:55 T:3043702592 NOTICE: m_displayName : HDA Intel
18:34:55 T:3043702592 NOTICE: m_displayNameExtra: ALC272 Analog
18:34:55 T:3043702592 NOTICE: m_deviceType : AE_DEVTYPE_PCM
18:34:55 T:3043702592 NOTICE: m_channels : FL,FR
18:34:55 T:3043702592 NOTICE: m_sampleRates : 48000
18:34:55 T:3043702592 NOTICE: m_dataFormats : AE_FMT_S32NE
18:34:55 T:3043702592 NOTICE: load settings...
18:34:55 T:3043702592 DEBUG: CSettings: loaded settings definition from special://xbmc/system/settings/settings.xml
18:34:55 T:3043702592 DEBUG: CSettings: loaded settings definition from special://xbmc/system/settings/linux.xml
18:34:55 T:3043702592 ERROR: CSettingsManager: unable to load settings from special://masterprofile/guisettings.xml, creating new default settings


Anyone have any ideas on what I'm doing wrong or how to fix this?
 
Old 07-26-2013, 06:50 PM   #2
jon lee
Member
 
Registered: Jul 2013
Posts: 81

Original Poster
Rep: Reputation: Disabled
It's my version isn't it? I bet I'm going to have to find v12 source.
 
Old 07-26-2013, 07:03 PM   #3
bosth
Member
 
Registered: Apr 2011
Posts: 234

Rep: Reputation: 68
I run XBMC on Slackware using the SlackBuild: http://slackbuilds.org/repository/14.0/multimedia/xbmc/
 
Old 08-06-2013, 03:48 PM   #4
jon lee
Member
 
Registered: Jul 2013
Posts: 81

Original Poster
Rep: Reputation: Disabled
It was because my libtinyxml had been compiled with STL support for an audio app.
http://www.grinninglizard.com/tinyxmldocs/
I had to do a core dump by:
pkill -SIGSEGV xbmc.bin
to find out the prob was in libtinyxml...

Anyway, all works (sorta, two libraries...).
Running XBMC13-Gotham!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
XBMC 12.0 (Frodo) and Slackware 14 croxen Slackware 15 02-08-2013 02:21 PM
Building xbmc on Slackware 14 Woodsman Slackware 1 09-10-2012 11:10 PM
Using XBMC 10.0 slackbuild to compile XBMC 11.0 almost works farmerdave Slackware 20 06-11-2012 02:05 PM
PS3 Media Server on Slackware (and advice on XBMC) spudgunner Slackware 6 01-31-2012 08:32 AM
need xbmc svn slackware packages kite Slackware 3 10-06-2009 09:54 PM


All times are GMT -5. The time now is 01:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration