LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 12-14-2005, 02:49 AM   #1
v@ny@
Member
 
Registered: Dec 2005
Location: Moscow
Distribution: Ubuntu 8.1
Posts: 104

Rep: Reputation: 15
Xauth: timeout in locking authority file //.Xauthority


I created a new user, so I don't use the computer as root all the time. But I am facing a few problems...:
1- I can login as this user, but when I type 'startx' it takes a long time to load the Xwindow and I get this message:

Xauth: timeout in locking authority file //.Xauthority.

The same message and strange delay appear when shutting down the Xwindow.

2- Even though I used pkgtool and configured KDE as my default Xwindow system, when I am logged in as 'user' and type startx it starts the 'blackbox' and not 'KDE'. If I am logged in as root and type startx it starts 'KDE', no problems...

3- When I am logged in as 'user' I cannot start firefox or any other program! How do I change the authorizaion so I can actually do stuff as user and not 'su' all the time I want to open a program?!

4- When logged in as 'user' I cannot shutdown the computer 'halt' or even 'reboot' the computer. How do I give the 'user' the ability to reboot and shutdown the computer?!



Thanks
 
Old 12-14-2005, 03:59 AM   #2
Toods
Member
 
Registered: Dec 2005
Location: UK
Distribution: Slackware 12.1
Posts: 249

Rep: Reputation: 32
I have exactly the same problem.

At the console terminal, if logged in as the new user, I cannot chdir to the /home/"new usr" directory. I have tried chmod to give all permissions to everyone but still no success.

I think I hasve a 'beginners problem' here with creating a new user. I tried both 'useradd' and 'addusr'.

It would be really helpful here if an experienced user would give us a simple step-by-step guide to creating this 'new user'.
 
Old 12-14-2005, 05:04 AM   #3
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
To add correctly a user, just use (and try to use defaults settings by just pressing enter): adduser

v@ny@: Probably your /home directory is not setted correctly, paste /etc/passwd here. useradd is a tricky command and has to be called carefully, try using adduser (create another user just to test).
2) You can configure each user's default window manager by running xwmconfig as the user.
3) Are you running X as the user?
4) Learn how to configure sudo (man sudo && man sudoers)
 
Old 12-15-2005, 02:30 AM   #4
v@ny@
Member
 
Registered: Dec 2005
Location: Moscow
Distribution: Ubuntu 8.1
Posts: 104

Original Poster
Rep: Reputation: 15
2- When I type 'wxmconfig' as the 'user' I get an error saying this command does not exist.
3- I am trying to run as the user but it doesn't work... So rigth now I am using as root.
4- I'll check this out! Thanks!

Here is passwd:

root:x:0:0::/root:/bin/bash
bin:x:1:1:bin:/bin:
daemon:x:2:2:daemon:/sbin:
adm:x:3:4:adm:/var/log:
lp:x:4:7:lp:/var/spool/lpd:
sync:x:5:0:sync:/sbin:/bin/sync
shutdown:x:6:0:shutdown:/sbin:/sbin/shutdown
halt:x:7:0:halt:/sbin:/sbin/halt
mail:x:8:12:mail:/:
news:x:9:13:news:/usr/lib/news:
uucp:x:10:14:uucp:/var/spool/uucppublic:
operator:x:11:0:operator:/root:/bin/bash
games:x:12:100:games:/usr/games:
ftp:x:14:50::/home/ftp:
smmsp:x:25:25:smmsp:/var/spool/clientmqueue:
mysql:x:27:27:MySQL:/var/lib/mysql:/bin/bash
rpc:x:32:32:RPC portmap user:/:/bin/false
sshd:x:33:33:sshd:/:
gdm:x:42:42:GDM:/var/state/gdm:/bin/bash
pop:x:90:90:POP:/:
nobody:x:99:99:nobody:/:
vanya:x:1000:100::/home/vanya:
 
Old 12-15-2005, 03:04 AM   #5
v@ny@
Member
 
Registered: Dec 2005
Location: Moscow
Distribution: Ubuntu 8.1
Posts: 104

Original Poster
Rep: Reputation: 15
I have deleted this user and created a new user following this commands you gave. Now it all works, thanks! When I created the previous user I used the command useradd (as it is shown in the Slackware Handbook). Now I used adduser as you said. I thought they did the same thing but now I see...
 
Old 12-15-2005, 05:01 AM   #6
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Glad to hear that.
Regarding the other stuff...
2) It's xwmconfig not wmxconfig.
3) Mmm, that should work, is it working now with the "new" user?
 
Old 12-15-2005, 12:16 PM   #7
v@ny@
Member
 
Registered: Dec 2005
Location: Moscow
Distribution: Ubuntu 8.1
Posts: 104

Original Poster
Rep: Reputation: 15
Yes! It is all working with the new user...
Thanks! And thankyou also for the packages you wrote the links to, to get Cyrilic working (http://www.linuxquestions.org/questions/showthread.php?t=152048)! The other links were down, but those ones you wrote worked and now it is all good! Thank you very much! How did you find those links? I was looking for it but could not find!

Gracias!

Last edited by v@ny@; 12-15-2005 at 12:23 PM.
 
Old 12-17-2005, 01:38 PM   #8
Toods
Member
 
Registered: Dec 2005
Location: UK
Distribution: Slackware 12.1
Posts: 249

Rep: Reputation: 32
Stillnot Working

I had originally the same problem creating a new account as V@NY@.

I have followed the recommended procedure in the thread but still I cannot use my new USER account properly:

1. My /home partition is FAT32.
2. I created new USER, 'bill'( using 'adduser')
3. Logged in as 'bill'.
4. From console, able to change directory to /home/bill.
5. Try to StartX (KDE) and get errors about not being able to write to files in /home/bill
6. Go back to console prompt, logged in as 'bill'. Now very strange - can no longer change directory to /home/bill.

Tried to run 'xwmconfig' but again cannot do as cannot access /home/bill

I am really puzzled by all this and would really appreciate some help.

Many thanks.
 
Old 12-17-2005, 02:07 PM   #9
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Fat32 filesystem doesn't support linux permissions. You could set the correct permissions during mount using the correct parameters, but they will be lost when umount/mount again.

Last edited by gbonvehi; 12-17-2005 at 02:09 PM.
 
Old 11-25-2006, 03:18 AM   #10
acelere
LQ Newbie
 
Registered: May 2006
Location: Brazil
Distribution: Overclkd Fedora 9 + Gnome
Posts: 4

Rep: Reputation: 0
I had the same problem and in my case, what was wrong was permitioning:

My original .Xauthority file was owned by root.
For some reason, I had chown it to another user.
That is when X forwarding stopped working.
All I had to do was chown it back to root and it worked.

acelere
 
Old 03-27-2007, 10:25 AM   #11
cstan
LQ Newbie
 
Registered: Mar 2007
Posts: 2

Rep: Reputation: 0
I also faced the same problem but i am using red hat 6.0

the following was my situation, hope expert can help me.

I had server in my working company, i tend to remote desktop to that server from my hostel.
I had install SSH client and "Xming" in my laptop (XP platform).

this error msg i get when i connect with SSH client:
/usr/X11R6/bin/xauth: timeout in locking authority file /.Xauthority

I had chmod the permission of the "usr" folder to all (include sub folder)

what should i do for next for me to remote desktop?

thank a lot.
 
Old 09-26-2007, 03:57 PM   #12
trebek
Member
 
Registered: Feb 2005
Location: Costa Rica
Distribution: Ubuntu, gOS, Debian & Slack 12
Posts: 426

Rep: Reputation: 30
I had this same problem and applied the solution you suggested. That worked because i got X loaded again with the new user. Problem is that i cannot sudo to anything, it doesn't ask me for the root password. At this point, it doesn't even tell me that the new user isn't in the sudoers file, which i get very often.

I got out of X so that i could login as root, but i can't. So there is no way for me to perform changes cause i can't get root privileges.

What to do?

Last edited by trebek; 09-26-2007 at 04:01 PM.
 
Old 09-26-2007, 04:04 PM   #13
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,381

Rep: Reputation: Disabled
What to do????
Open a new thread and describe your problem clearly, as well as the things you tried to solve it, and how these failed. That will attract people who can help you. With the information you supply here, no one will be able to assist unless they are in possession of a crystal ball.
Please do not ressurrect long-dead threads, they stink.

Eric
 
Old 09-26-2007, 05:52 PM   #14
trebek
Member
 
Registered: Feb 2005
Location: Costa Rica
Distribution: Ubuntu, gOS, Debian & Slack 12
Posts: 426

Rep: Reputation: 30
Well, no need to do that. Some extensive googling and search over at lq did the job.

Thanks anyways.
 
Old 11-20-2013, 06:52 AM   #15
nehaljwani
LQ Newbie
 
Registered: Jan 2013
Posts: 8

Rep: Reputation: Disabled
For those who are still not able to resolve the error after changing permissions, you need to change the mode of selinux from enforcing to permissive. Become root and either edit the file /etc/sysconfig/selinux or just type setenforce 0 for one session.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xauth: timeout in locking authority file ~/.Xauthority? otbibb Linux - Software 6 08-28-2013 02:42 PM
xauth: timeout in locking authority file //.Xauthority karlrb Linux - Software 2 10-26-2006 07:53 AM
xauth.... time out locking file .Xauthority DraaX Slackware 17 12-01-2004 01:19 AM
xauth: timeout in locking .Xauthority mcd Slackware 1 11-03-2004 02:42 AM
error in locking authority file Spyder23 Linux - Newbie 1 06-22-2002 12:34 AM


All times are GMT -5. The time now is 06:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration