LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-03-2011, 02:03 PM   #1
gtludwig
Member
 
Registered: Oct 2005
Location: Brazil
Distribution: Slackware64-current
Posts: 221

Rep: Reputation: 16
x64 -current sometimes hangs and other times "feels" slow


Hi all,

I know this is a rather too generic thread, but bear with me so I can try to explain it... I use Slackware64-current almost exclusively both at work (95%+ of the time) and at home (all the time! Even the wife has growing tender feelings for Slackware! ).

At work, my box is a HP dc5850 microtower (CPU AMD Athlon Dual Core 5200B with 4GiB RAM DDR2). It's a pretty decent work machine. At home, I built from parts an AMD Phenon II X4 965 with 8 GiB RAM DDR3 - it's an awesome machine!

In both computers I have recently installed Slackwarew64-current and have applied the multilib packages from AlienBob (great work, btw!).

I'm a Java developer and have created a directoy under /opt for all the software I need for work (JDK, Apache Ant, Apache Tomcat, Apache Maven, etc). All settings are exported in /etc/profile, which is posted here.

But, occasionally, I feel the whole system (on either machine) to respond very slowly, like there's some sort of process eating up all resources. Considering what I have "under the hood", that's quite annoying.

I use stock KDE and kernel, plus a here-and-there tweak I got from this Dugan Chen's excelent post, mostly font-related.

How can I help you helping me?

Thanks in advance,
gtludwig
 
Old 06-04-2011, 08:07 AM   #2
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,617
Blog Entries: 3

Rep: Reputation: 219Reputation: 219Reputation: 219
the dbus freeze up sure and this will be a problem as the new programs are built for current. Since Alien Bob is the developer for KDE and you run Current it would be good to go read his kde change log at ktown. the known issues with current. the reason is the config and strgi data base etc. how I test it is I rename my dot .kde file to .kde1 and let kde regenerate plus if you have been running current for a long time did you go in and make sure your aaa_elflibs can be updated. per /etc/slackpkg/blacklist read Pat's notes on running current.
hope this helps. Oh another big deal is to uninstall old programs read upgrade text those old programs can cause problems. please read Changes Tips and hints text This has helped me through the years.
 
  


Reply

Tags
current, hang, java, multilib, slow


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CrunchBang 10 "Statler" r20110207 Install Hangs "Detecting Network Devices" jv2112 Linux - Newbie 2 05-04-2011 05:48 PM
".config" and ".kde" folders are being created under root directory (Slack Current) piratesmack Slackware 8 03-12-2011 11:06 PM
mysql "flush logs" or "flush tables with read lock", ... hangs deadeyes Linux - Server 4 01-19-2010 03:24 AM
Data transfer online is slow "at times" or "stops at times" Balarabay1 Suse/Novell 14 04-30-2006 10:00 AM
[B]"wireless network" config from "system" hangs[/B] dauphinfay Ubuntu 0 03-04-2006 03:16 PM


All times are GMT -5. The time now is 10:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration