LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-15-2004, 05:55 AM   #1
hnad
LQ Newbie
 
Registered: Mar 2004
Location: Australia
Distribution: Schlack!
Posts: 26

Rep: Reputation: 15
X11 - failed to load module keyboard


ugh no idea what happened. Updated some packages, a few X11 ones using swaret. Everything went ok. Typed in startx and I get the following

Failed to load module 'keyboard' module does not exist.

In the log file

II) LoadModule: "Keyboard"
(WW) Warning, couldn't open module Keyboard
(II) UnloadModule: "Keyboard"
(EE) Failed to load module "Keyboard" (module does not exist, 0)


Did I break something??? Was all working fine before. :/

How can I fix this?

Thanks
 
Old 09-15-2004, 06:10 AM   #2
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Go to your /etc/X11/xorg.conf file and try changing a line that says Driver "keyboard" to Driver "kbd" maybe you got the new X11 release.
 
Old 09-15-2004, 06:12 AM   #3
hnad
LQ Newbie
 
Registered: Mar 2004
Location: Australia
Distribution: Schlack!
Posts: 26

Original Poster
Rep: Reputation: 15
Yep just saw that. I generated a new xorg.conf using xorgconfig and noticed the driver was called kdb. So I changed keyboard to kdb in my original xorg.conf and now it all works.

Ta

Always the little things.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xorg -- (EE) Failed to load module "glx" (loader failed, 7) windowsrefugeeX Linux - Software 10 09-23-2009 06:51 PM
xorg: Failed to load module... NullDevice23 Linux - Hardware 4 08-05-2006 10:01 AM
ver:10.2, after startx, (EE)Failed to load module ...\..\libglx.a catfox Mandriva 5 07-07-2005 11:40 AM
Failed to load the NVIDA kernal module magisbladius Slackware 9 04-14-2005 05:27 PM
(EE) Failed to load module error Seventh Linux - Newbie 8 02-23-2004 03:16 PM


All times are GMT -5. The time now is 11:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration