LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-13-2007, 04:31 PM   #1
oneagainstall
LQ Newbie
 
Registered: Feb 2006
Location: Bulgaria, the small and peaceful town of Razlog
Distribution: slackware-11.0
Posts: 9

Rep: Reputation: 0
x.org 6.9 to 6.8, because of fglrx?


hi there i've been using slackware since 10.1. i moved to dropline gnome when 10.2 came out. i recently upgraded my system to slack 11
i have a radeon 9200se/128mb graphic adapter. we all know that ati dropped support for the 9200 series since the 8.28.8 version of their drivers for linux. while using kernel 2.6.18 i was unable to compile my ati drivers. i downgraded to linux-2.6.17.13 and everything went well untill i ran aticonfig and restarted X. then i got the following err:
Quote:
[r200setup]X version mismatch - detected X.org 7.0.0, required 6.8.0
failed to load module "fglrx"(module requirement mismatch,0)
slackware 11 uses x.org 6.9
anyway i downgraded again to x.org 6.8.1. and x started normaly. 1024x768@85Hz fits perfectly on my 19" crt monitor then an error message about the system monitor poped up.. dropline gnome 2.16 was build on slackware's x11-6.9 packages i ran fgl_glxgears:
Quote:
Using GLX_SGIX_pbuffer
X Error of failed request: BadLength (poly request too large or internal Xlib length error)
Major opcode of failed request: 16 (X_InternAtom)
Serial number of failed request: 36
Current serial number in output stream: 38
and 'glxinfo':
Quote:
name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
is there some who faced that problem.. and how did you solved it? it looks like i won't be using fresh software no more. thanks for the support
respect,
do
 
Old 03-14-2007, 10:22 AM   #2
rje_NC
Member
 
Registered: Nov 2002
Location: Greensboro, NC
Posts: 182

Rep: Reputation: 30
I may be mistaken, but I thought that xorg supported openGL with the radeon driver for the 9200 cards. Have you tried using the default Xorg in slack11 and tried enabling dri and see what you get?

It sounds like you might be setting yourself up for problems straying so far from the norm for Slack and Dropline.

Just my opinion...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to use ATI's fglrx (8.29.6) on sid's X.org (7.1.1) andreag Debian 2 10-28-2006 06:47 AM
system freeze at kdm logout: kde 3.5, fglrx 8.21.7, x.org 6.8, kernel 2.6.14 schatoor Linux - Software 3 02-13-2006 05:07 PM
ATI's fglrx kernel 2.6.9 and X.org 6.8.1 electronique Slackware 20 02-01-2005 04:11 PM
Fglrx console=>X changing problem and fglrx resume zbychdm Linux - Hardware 2 09-21-2004 12:58 PM
ATI 9500, fglrx-glc22-4.1.0, fglrx-glc22-4.2.0, fglrx-glc22-4.3.0 ctrl_alt_delx Linux - Hardware 1 09-30-2003 05:48 AM


All times are GMT -5. The time now is 12:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration