LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   x.org 6.9 to 6.8, because of fglrx? (http://www.linuxquestions.org/questions/slackware-14/x-org-6-9-to-6-8-because-of-fglrx-537189/)

oneagainstall 03-13-2007 04:31 PM

x.org 6.9 to 6.8, because of fglrx?
 
hi there :) i've been using slackware since 10.1. i moved to dropline gnome when 10.2 came out. i recently upgraded my system to slack 11:)
i have a radeon 9200se/128mb graphic adapter. we all know that ati dropped support for the 9200 series since the 8.28.8 version of their drivers for linux. while using kernel 2.6.18 i was unable to compile my ati drivers. i downgraded to linux-2.6.17.13 and everything went well untill i ran aticonfig and restarted X. then i got the following err:
Quote:

[r200setup]X version mismatch - detected X.org 7.0.0, required 6.8.0
failed to load module "fglrx"(module requirement mismatch,0)
slackware 11 uses x.org 6.9 :scratch:
anyway i downgraded again to x.org 6.8.1. and x started normaly. 1024x768@85Hz fits perfectly on my 19" crt monitor :) then an error message about the system monitor poped up.. dropline gnome 2.16 was build on slackware's x11-6.9 packages :) i ran fgl_glxgears:
Quote:

Using GLX_SGIX_pbuffer
X Error of failed request: BadLength (poly request too large or internal Xlib length error)
Major opcode of failed request: 16 (X_InternAtom)
Serial number of failed request: 36
Current serial number in output stream: 38
and 'glxinfo':
Quote:

name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
is there some who faced that problem.. and how did you solved it? it looks like i won't be using fresh software no more. thanks for the support :)
respect,
do:)

rje_NC 03-14-2007 10:22 AM

I may be mistaken, but I thought that xorg supported openGL with the radeon driver for the 9200 cards. Have you tried using the default Xorg in slack11 and tried enabling dri and see what you get?

It sounds like you might be setting yourself up for problems straying so far from the norm for Slack and Dropline.

Just my opinion...


All times are GMT -5. The time now is 04:20 PM.