LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   X only works with root user (http://www.linuxquestions.org/questions/slackware-14/x-only-works-with-root-user-226931/)

joe83 09-05-2004 09:38 AM

X only works with root user
 
I can only run X as root. When I try to access it from my user account I get the following:

timeout in locking authority file /home/joe/.Xauthority.
This error displays four times, then the screen goes to the KDE screen which displays the following:

no write access to $HOME directory (home/joe) KDE is unable to start
I click ok on this and get a window stating could not start Kserver check your installation I click ok on this and it takes me to command line which gives the following error:
QSettings: error creating /home/joe/.qt

Any ideas out there?
Thanks in advance

.


:Pengy:

Cedrik 09-05-2004 09:42 AM

try : chown joe:users /home/joe/.Xauthority

or at least read man xauth to create another one

joe83 09-05-2004 09:54 AM

Thanks for replying. I read the man page for xauth several times
and as usual with man pages (for me anyway) ended up more confused than when I started. The weird part is it was working yesterday, I logged out, shut the machine off and then this morning when I logged in BOOM! Doesn't make any sense. I'll try the chown as you suggested and see what happens.
Thanks.


:cry:

elsheikhmh 09-05-2004 09:57 AM

try
$ ls -l /home/joe/.Xauthority
plz post the o/p

elsheikhmh 09-05-2004 10:12 AM

well,
try
1. chown, or
2. copy the root's .Xauthority to your home, or
3. delete it entirely, believe me, it may work without it !!

mustafa

joe83 09-05-2004 10:19 AM

Quote:

Originally posted by elsheikhmh
try
$ ls -l /home/joe/.Xauthority
plz post the o/p


output is:

no such file or directory
I don't get it. How can a file just diappear like that??



:mad:

joe83 09-05-2004 10:27 AM

Quote:

Originally posted by elsheikhmh
well,
try
1. chown, or
2. copy the root's .Xauthority to your home, or
3. delete it entirely, believe me, it may work without it !!

mustafa

I already tried #'s 2& 3 will try #1 but I have doubts. Changing ownership of something that doesn't exist?

I just thought of another option :
4. Throw the bloody thing out the window

:cry:

elsheikhmh 09-05-2004 10:37 AM

give a try

as a root,
# cp /root/.Xauthority /home/joe/.Xauthority

mustafa

nalg0rath 09-05-2004 10:41 AM

So, what happends when you try to copy the file from the the root user's home directory?

joe83 09-05-2004 10:55 AM

Quote:

Originally posted by nalg0rath
So, what happends when you try to copy the file from the the root user's home directory?
Same result, same errors

:study:

kodon 09-05-2004 11:24 AM

Quote:

Originally posted by joe83
no such file or directory
I don't get it. How can a file just diappear like that??
how about:
ls -l /home
and
ls -l /home/joe

joe83 09-05-2004 12:13 PM

Copied the file .Xauthority from root to /home /joe
did chown joe:users /home/joe/.Xauthority
ls -l /home/joe/.Xauthority outputs :
-rw----- 1 joe users 53 Sept5 10:05 /home/joe/.Xauthority
startx gives same results as before
xinit starts x, takes me to the basic x manager
Any ideas??

:(

elsheikhmh 09-06-2004 04:41 AM

xinit then, startkde

mustafa

elsheikhmh 09-06-2004 04:46 AM

well, i tried this:
(as a normal user)
Code:

~$ rm .Xauthority
~$ xauth -b
xauth> exit
~$ startx

xauth with -b flag will try to break locks (caused by another xauth) on the authority file
"exit" on the xauth shell will save & exit. u don't need any other operations at xauth shell.

plz, give a try and post ur feedback. this will benifit us too much.

mustafa

joe83 09-06-2004 08:17 AM

Tried it, same error as originally. I added a user and X works fine.So for now I'm going to transfer my files there so I can use the machine for work tomorrow and keep trying to find out what the problem is and (more importantly to me anyway) what caused it. Thanks to all who have helped. Will post if I find anything.


:Pengy:


All times are GMT -5. The time now is 04:23 PM.