LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 05-02-2010, 03:11 PM   #1
Jack128
Member
 
Registered: Feb 2009
Location: Germany
Distribution: Slackware64 Current
Posts: 90

Rep: Reputation: 22
X gets very slow (unusable) - Current 2.6.33.3 - nvidia 7600 GS


Hello,
I've updated today to current, so I
installed the 2.6.33.2 kernel source
build it with the "huge" configuration
and added bootsplash-support.

After everything was completed, I rebooted
into the new kernel. It was working for
a about a half-hour, then the X gets very
slow and the cpu-usage-led was full red.

Mouse movement weren't able anymore, but
I could restart X with Strg+Alt+Backspace.
After that every thing was working again,
for a while of course.

Xorg.log doesn't report anything, no errors
no warnings. I run the closed source nVidia
driver (latest 195.36.24) on my
Slackware64-current machine.

Can anyone help me, or got anyone a
idea of fixing this?

Thanks in advance,
Best regards.

Jack
 
Old 05-02-2010, 03:58 PM   #2
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
One thing to try is add:

Code:
Section "Device"

    Option "UseEvents" "1"

EndSection
to xorg.conf (in device section if there is one). I've never tried the nvidia drivers with the newest kernel, it could be just some bug or that it's not supported.
 
Old 05-02-2010, 04:05 PM   #3
Jack128
Member
 
Registered: Feb 2009
Location: Germany
Distribution: Slackware64 Current
Posts: 90

Original Poster
Rep: Reputation: 22
Thanks for your quick reply. =)

I've added this option now, but I need to
test it a longer time. After the freeze, X
come up again, and KDE is telling me, the
composing is disabled, because the system
react to slow. With disabled KDE composing
I run now for quit a while.

I installed a earlier nvidia driver (195.36.15),
the same behavior on 2.6.33.3. ATM I can't test
the 195.36.24 nvidia driver on 2.6.33.2, because
I deleted the source dir, so he couldn't build it.

Have to test it anyway, tomorrow.

Best regards,
Jack.
 
Old 05-02-2010, 04:52 PM   #4
sahko
Senior Member
 
Registered: Sep 2008
Distribution: Slackware
Posts: 1,041

Rep: Reputation: Disabled
Quote:
Originally Posted by Jack128 View Post
It was working for
a about a half-hour, then the X gets very
slow and the cpu-usage-led was full red.
Which process was doing that ? X ?
 
Old 05-02-2010, 05:12 PM   #5
rmjohnso
Member
 
Registered: Mar 2006
Location: Wisconsin
Distribution: Slackware64-Current
Posts: 294

Rep: Reputation: 43
Quote:
Originally Posted by sahko View Post
Which process was doing that ? X ?
Good question. I wonder if this has something to do with KDE rather than X. I'm running 2.6.33.3 with nvidia (8400M GS) drivers (195.36.15) under XFCE. I'm not seeing any problems, so far.
 
Old 05-03-2010, 12:24 AM   #6
Jack128
Member
 
Registered: Feb 2009
Location: Germany
Distribution: Slackware64 Current
Posts: 90

Original Poster
Rep: Reputation: 22
I didn't know, witch process it was, I
can't see it anymore, if it starts to
get slow.

I'm using the Alien-Build of KDE 4.4.2.

Best regards,
Jack.
 
Old 05-03-2010, 10:52 AM   #7
Jack128
Member
 
Registered: Feb 2009
Location: Germany
Distribution: Slackware64 Current
Posts: 90

Original Poster
Rep: Reputation: 22
Here are some new facts:

I checked my RAM, with MemTest4.00+, no errors on
the 2GB module (the only module ATM).

I catch a few outputs of KDE's System-Monitor:

process: | cpu usage: | RAM usage:
---------------+-----------------------+-----------------
firefox-bin | inactive on hard disk | 85MB
plasma-desktop | inactive on hard disk | 47MB
X | inactive on hard disk | 641,8MB

This happens on, 2.6.33.2 / 2.6.33.3 with nvidia binary
drivers 195.36.15 / 195.36.24 on a 1.7.6 X.
Without the (Option "UseEvents" "1").

With this option I haven't tested it yet.

I did not have any of these problems with
Xorg 1.7.5, kernel 2.6.33.2 and 195.36.15 nvidia package.


Best regards,
Jack.
 
Old 05-03-2010, 02:48 PM   #8
Jack128
Member
 
Registered: Feb 2009
Location: Germany
Distribution: Slackware64 Current
Posts: 90

Original Poster
Rep: Reputation: 22
Ok, (Option "UseEvents" "1") did nothing on
this behavior. I found out like rmjohnso says:

Quote:
I wonder if this has something to do with KDE rather than X. I'm running 2.6.33.3 with nvidia (8400M GS) drivers (195.36.15) under XFCE. I'm not seeing any problems, so far.
This behavior happens to KDE, with nvidia
binary package or with the nv opensource driver.

But the WM make a difference, I use now for testing
xfce4, with nvidia 195.36.24, and kernel 2.6.33.3,
without any problems, so far.

I have to took a look on the KDE 4.4.2 build or
rebuilt it on the current, or switch back to KDE 4.3.5.

Thanks for all your help.
Best regards,
Jack.

Last edited by Jack128; 05-04-2010 at 10:58 AM.
 
  


Reply

Tags
nvidia, x8664, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia 7600 GT Thatonedude87 Linux - Hardware 4 05-07-2008 10:36 AM
Xorg for Nvidia 7600 Mojojo Linux - Hardware 1 05-02-2008 12:43 PM
Nvidia Geforce 7600 GS drivers sigma_50 Linux - Hardware 2 12-30-2007 04:08 PM
Beryl and nvidia Geforce 7600 GS gbj Linux - Desktop 14 02-04-2007 06:04 PM
cant get Nvidia gf 7600 running nin82 Linux - Hardware 5 09-06-2006 09:17 PM


All times are GMT -5. The time now is 12:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration