LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   X gets very slow (unusable) - Current 2.6.33.3 - nvidia 7600 GS (http://www.linuxquestions.org/questions/slackware-14/x-gets-very-slow-unusable-current-2-6-33-3-nvidia-7600-gs-805517/)

Jack128 05-02-2010 02:11 PM

X gets very slow (unusable) - Current 2.6.33.3 - nvidia 7600 GS
 
Hello,
I've updated today to current, so I
installed the 2.6.33.2 kernel source
build it with the "huge" configuration
and added bootsplash-support.

After everything was completed, I rebooted
into the new kernel. It was working for
a about a half-hour, then the X gets very
slow and the cpu-usage-led was full red.

Mouse movement weren't able anymore, but
I could restart X with Strg+Alt+Backspace.
After that every thing was working again,
for a while of course.

Xorg.log doesn't report anything, no errors
no warnings. I run the closed source nVidia
driver (latest 195.36.24) on my
Slackware64-current machine.

Can anyone help me, or got anyone a
idea of fixing this?

Thanks in advance,
Best regards.

Jack

H_TeXMeX_H 05-02-2010 02:58 PM

One thing to try is add:

Code:

Section "Device"

    Option "UseEvents" "1"

EndSection

to xorg.conf (in device section if there is one). I've never tried the nvidia drivers with the newest kernel, it could be just some bug or that it's not supported.

Jack128 05-02-2010 03:05 PM

Thanks for your quick reply. =)

I've added this option now, but I need to
test it a longer time. After the freeze, X
come up again, and KDE is telling me, the
composing is disabled, because the system
react to slow. With disabled KDE composing
I run now for quit a while.

I installed a earlier nvidia driver (195.36.15),
the same behavior on 2.6.33.3. ATM I can't test
the 195.36.24 nvidia driver on 2.6.33.2, because
I deleted the source dir, so he couldn't build it.

Have to test it anyway, tomorrow.

Best regards,
Jack.

sahko 05-02-2010 03:52 PM

Quote:

Originally Posted by Jack128 (Post 3954904)
It was working for
a about a half-hour, then the X gets very
slow and the cpu-usage-led was full red.

Which process was doing that ? X ?

rmjohnso 05-02-2010 04:12 PM

Quote:

Originally Posted by sahko (Post 3954971)
Which process was doing that ? X ?

Good question. I wonder if this has something to do with KDE rather than X. I'm running 2.6.33.3 with nvidia (8400M GS) drivers (195.36.15) under XFCE. I'm not seeing any problems, so far.

Jack128 05-02-2010 11:24 PM

I didn't know, witch process it was, I
can't see it anymore, if it starts to
get slow.

I'm using the Alien-Build of KDE 4.4.2.

Best regards,
Jack.

Jack128 05-03-2010 09:52 AM

Here are some new facts:

I checked my RAM, with MemTest4.00+, no errors on
the 2GB module (the only module ATM).

I catch a few outputs of KDE's System-Monitor:

process: | cpu usage: | RAM usage:
---------------+-----------------------+-----------------
firefox-bin | inactive on hard disk | 85MB
plasma-desktop | inactive on hard disk | 47MB
X | inactive on hard disk | 641,8MB

This happens on, 2.6.33.2 / 2.6.33.3 with nvidia binary
drivers 195.36.15 / 195.36.24 on a 1.7.6 X.
Without the (Option "UseEvents" "1").

With this option I haven't tested it yet.

I did not have any of these problems with
Xorg 1.7.5, kernel 2.6.33.2 and 195.36.15 nvidia package.


Best regards,
Jack.

Jack128 05-03-2010 01:48 PM

Ok, (Option "UseEvents" "1") did nothing on
this behavior. I found out like rmjohnso says:

Quote:

I wonder if this has something to do with KDE rather than X. I'm running 2.6.33.3 with nvidia (8400M GS) drivers (195.36.15) under XFCE. I'm not seeing any problems, so far.
This behavior happens to KDE, with nvidia
binary package or with the nv opensource driver.

But the WM make a difference, I use now for testing
xfce4, with nvidia 195.36.24, and kernel 2.6.33.3,
without any problems, so far.

I have to took a look on the KDE 4.4.2 build or
rebuilt it on the current, or switch back to KDE 4.3.5.

Thanks for all your help.
Best regards,
Jack.


All times are GMT -5. The time now is 05:27 AM.