Go Job Hunting at the LQ Job Marketplace
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 05-19-2013, 05:17 AM   #1
LQ Newbie
Registered: Jun 2006
Distribution: Slackware 14.1 64bit
Posts: 24

Rep: Reputation: 0
X crash after last upgrade

Hi there,
yesterday I upgrade Slackware 14 64bit (with multilib) XFCE. Upgraded packages were:
  • ./mozilla-firefox-21.0-x86_64-1_slack14.0
  • ./google-chrome-26.0.1410.63-x86_64-1
  • ./xorg-server-xvfb-1.12.4-x86_64-1_slack14.0
  • ./seamonkey-2.17.1-x86_64-1_slack14.0
  • ./seamonkey-solibs-2.17.1-x86_64-1_slack14.0
  • ./mozilla-thunderbird-17.0.6-x86_64-1_slack14.0
  • ./xorg-server-xephyr-1.12.4-x86_64-1_slack14.0
  • ./ruby-1.9.3_p429-x86_64-1_slack14.0
  • ./xorg-server-1.12.4-x86_64-1_slack14.0
  • ./xorg-server-xnest-1.12.4-x86_64-1_slack14.0

Upgrade was made on init 3 and the PC was restarted after upgrade. After restart everything works fine but if I run google-chrome version 23 X crash. I upgrade google-chrome to 26.0.1410.63. After upgrade I can run google-chrome and open settings menu but if I try to open url (load page) X crash again.

Error in Xorg.0.log.old is:
[ 2974.080] Backtrace:
[ 2974.080] 0: /usr/bin/X (xorg_backtrace+0x36) [0x55d526]
[ 2974.080] 1: /usr/bin/X (0x400000+0x160ee9) [0x560ee9]
[ 2974.080] 2: /lib64/ (0x7fae82acc000+0xf4e0) [0x7fae82adb4e0]
[ 2974.080]
[ 2974.080] Segmentation fault at address (nil)
[ 2974.080]
Fatal server error:
[ 2974.080] Caught signal 11 (Segmentation fault). Server aborting
[ 2974.080]
[ 2974.080]
Archived: kdm.log, Xorg.0.log and Xorg.0.log.old Crash logs
Old 05-19-2013, 06:23 AM   #2
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 853

Rep: Reputation: 259Reputation: 259Reputation: 259
NVIDIA driver detected

Have you reinstalled the nvidia drivers?
Old 05-19-2013, 02:17 PM   #3
LQ Newbie
Registered: Jun 2006
Distribution: Slackware 14.1 64bit
Posts: 24

Original Poster
Rep: Reputation: 0
OK you were right - reinstall of nvidia driver solve the problem.

Thank you.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] KDE crash after upgrade. SeRi@lDiE Slackware 14 11-24-2010 07:47 PM
System crash after kernel upgrade krokodille Slackware 4 03-20-2005 02:34 PM
Fatal X Crash After Upgrade. rvijay Debian 9 02-28-2005 08:37 PM
kontact crash on kde 3.3 upgrade rkfb Linux - Software 2 12-13-2004 07:31 AM
KDE Upgrade + all GUI crash DirtyDan Slackware 3 10-03-2004 03:19 PM

All times are GMT -5. The time now is 12:52 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration