LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 07-07-2013, 05:10 AM   #1
inverse
LQ Newbie
 
Registered: Oct 2010
Location: India
Distribution: Slackware
Posts: 19

Rep: Reputation: 1
WWAN not getting enabled


Hello all

I am trying to configure my mobile broadband, airtel 3G dongle. I am using Network Manager 0.9.4 version which is default installation in slackware 14.0. I am following the steps provided in the website below:
http://www.unixwerk.eu/linux/slack/vodafone.html

Now the problem is, when I am doing

Quote:
nmcli nm wwan on
WWAN is not getting enabled. It still show disabled.

And another problem is that I have added the connection but when I do

Quote:
nm-tool
It does not shows the connection.

Anyone having idea how to resolve this thing???

Should I upgrade my slackware 14.0 to slackware-current????

Thanks in advance.

[EDIT]
PS: WWAN hardware is enabled. I have restarted my system many times also.

Last edited by inverse; 07-07-2013 at 05:14 AM.
 
Old 07-07-2013, 09:56 PM   #2
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 1,820

Rep: Reputation: Disabled
Does the dongle show up when you run lsusb?

Are the correct kernel modules loaded? Could you post the output of lsmod?
 
Old 07-08-2013, 12:50 PM   #3
inverse
LQ Newbie
 
Registered: Oct 2010
Location: India
Distribution: Slackware
Posts: 19

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by Ser Olmy View Post
Does the dongle show up when you run lsusb?

Are the correct kernel modules loaded? Could you post the output of lsmod?
The output of lsusb is:

Quote:
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 0c45:63ee Microdia
Bus 003 Device 002: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 003 Device 003: ID 413c:8161 Dell Computer Corp. Integrated Keyboard
Bus 003 Device 004: ID 413c:8162 Dell Computer Corp. Integrated Touchpad [Synaptics]
Bus 003 Device 005: ID 413c:8160 Dell Computer Corp. Wireless 365 Bluetooth
Bus 002 Device 003: ID 19d2:1254 ZTE WCDMA Technologies MSM
The output of lsmod is:
Quote:
Module Size Used by
onda 13426 0
option 19791 0
usb_wwan 9198 2 option,onda
usbserial 31492 3 usb_wwan,option,onda
snd_seq_dummy 1455 0
snd_seq_oss 29048 0
snd_seq_midi_event 5620 1 snd_seq_oss
snd_seq 51265 5 snd_seq_midi_event,snd_seq_oss,snd_seq_dummy
snd_seq_device 5228 3 snd_seq,snd_seq_oss,snd_seq_dummy
snd_pcm_oss 39183 0
snd_mixer_oss 15404 1 snd_pcm_oss
ipv6 279979 12
cpufreq_ondemand 6252 2
acpi_cpufreq 5773 1
mperf 1171 1 acpi_cpufreq
freq_table 2475 2 acpi_cpufreq,cpufreq_ondemand
lp 9787 0
ppdev 5958 0
parport_pc 19423 0
parport 31427 3 parport_pc,ppdev,lp
fuse 66626 7
btusb 11676 0
bluetooth 151679 1 btusb
b43 340351 0
mac80211 227731 1 b43
snd_hda_codec_idt 55294 1
uvcvideo 62784 0
joydev 9972 0
i915 419107 3
snd_hda_intel 23267 2
snd_hda_codec 81925 2 snd_hda_intel,snd_hda_codec_idt
videodev 76679 1 uvcvideo
v4l2_compat_ioctl32 8660 1 videodev
cfg80211 169025 2 mac80211,b43
usbhid 35615 0
ssb 47856 1 b43
processor 25592 3 acpi_cpufreq
mmc_core 77850 2 ssb,b43
video 11378 1 i915
pcmcia 35720 2 ssb,b43
drm_kms_helper 26133 1 i915
hid 82876 1 usbhid
snd_hwdep 6324 1 snd_hda_codec
drm 187389 4 drm_kms_helper,i915
thermal 7983 0
pcmcia_core 12061 1 pcmcia
sky2 48305 0
thermal_sys 14578 3 thermal,video,processor
hwmon 1329 1 thermal_sys
dell_wmi 1509 0
sparse_keymap 3016 1 dell_wmi
psmouse 61704 0
dell_laptop 10592 0
rfkill 15428 4 bluetooth,dell_laptop,cfg80211
ums_realtek 7376 0
uas 8144 0
i2c_algo_bit 5319 1 i915
evdev 9574 11
wmi 8403 1 dell_wmi
snd_pcm 72864 3 snd_hda_codec,snd_hda_intel,snd_pcm_oss
snd_page_alloc 7081 2 snd_pcm,snd_hda_intel
snd_timer 18798 2 snd_pcm,snd_seq
snd 57796 15 snd_timer,snd_pcm,snd_hwdep,snd_hda_codec,snd_hda_intel,snd_hda_codec_idt,snd_mixer_oss,snd_pcm_oss, snd_seq_device,snd_seq,snd_seq_oss
i2c_i801 8044 0
intel_agp 10864 1 i915
i2c_core 19978 6 i2c_i801,i2c_algo_bit,drm,drm_kms_helper,videodev,i915
serio_raw 4389 0
soundcore 5474 1 snd
dcdbas 5416 1 dell_laptop
intel_gtt 13833 3 intel_agp,i915
ac 3331 0
button 4529 1 i915
battery 11171 0
agpgart 27372 3 intel_gtt,intel_agp,drm
loop 18192 0
Now, how should i check whether appropriate kernel modules loaded???

I used wvdialconf and it did detected the datacard and showed in its wvdial.conf file at /dev/ttyUSB1. The only reason I am not able to run through wvdial because for PAP authentication it asks for username/password. And with this datacard, there is no username or password. So, everytime I try to connect it shows error for username/password.

What next???

And one more thing I would like to know. Soon I will be getting airtel 4G datacard. So in that case network manager and modem manager needs to be updated as network manager version 0.9.4 does not support 4G. So should i update my slack to current or just update the related packages???

Thanks

Last edited by inverse; 07-08-2013 at 01:02 PM.
 
Old 07-08-2013, 03:06 PM   #4
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 1,820

Rep: Reputation: Disabled
Quote:
Originally Posted by inverse View Post
The output of lsusb is:
Quote:
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 0c45:63ee Microdia
Bus 003 Device 002: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 003 Device 003: ID 413c:8161 Dell Computer Corp. Integrated Keyboard
Bus 003 Device 004: ID 413c:8162 Dell Computer Corp. Integrated Touchpad [Synaptics]
Bus 003 Device 005: ID 413c:8160 Dell Computer Corp. Wireless 365 Bluetooth
Bus 002 Device 003: ID 19d2:1254 ZTE WCDMA Technologies MSM
I guess the Microdia device must be your 3G USB modem? Does the entry disappear when you unplug it?
Quote:
Originally Posted by inverse View Post
Now, how should i check whether appropriate kernel modules loaded???
The usbserial, usb_wwan, option and onda modules are probably related to your modem.
Quote:
Originally Posted by inverse View Post
I used wvdialconf and it did detected the datacard and showed in its wvdial.conf file at /dev/ttyUSB1. The only reason I am not able to run through wvdial because for PAP authentication it asks for username/password. And with this datacard, there is no username or password. So, everytime I try to connect it shows error for username/password.
The fact that a /dev/ttyUSB1 device exists is a good sign. As for wvdial, perhaps there's a log file with more detailed information?
 
Old 07-09-2013, 01:05 PM   #5
inverse
LQ Newbie
 
Registered: Oct 2010
Location: India
Distribution: Slackware
Posts: 19

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by Ser Olmy View Post
I guess the Microdia device must be your 3G USB modem? Does the entry disappear when you unplug it?
no, actually, ZTE WCDMA Technologies MSM is my 3G USB modem

Quote:
Originally Posted by Ser Olmy View Post
The usbserial, usb_wwan, option and onda modules are probably related to your modem.
Yes.

I think if my WWAN gets enabled then I will be able to connect with the help of Network Manager. Any idea how I can achieve that?? I have already mention that I tried by doing
Quote:
nmcli nm wwan on
but it is not getting enabled. Any idea why???
 
Old 07-10-2013, 05:19 PM   #6
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 1,820

Rep: Reputation: Disabled
I'm afraid I'm not at all familiar with NetworkManager, and I don't know what's supposed to happen when you "enable" an interface from nmcli.
 
Old 07-10-2013, 06:28 PM   #7
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 836

Rep: Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620
Quote:
Originally Posted by inverse View Post
I think if my WWAN gets enabled then I will be able to connect with the help of Network Manager. Any idea how I can achieve that?? I have already mention that I tried by doing but it is not getting enabled. Any idea why???
Have you set up the interface with nm-applet or the KDE NetworkManager app? If not, I don't think that nmcli can do much. I could be wrong, though... I've only used it a few times to get status reports. On my machine, NetworkManager was set up using nm-applet on Xfce. I do not boot into X, but NetworkManager brings up the connection at boot time without needing X to run once it has been configured.
 
Old 07-10-2013, 07:10 PM   #8
jtsn
Member
 
Registered: Sep 2011
Location: Europe
Distribution: Slackware
Posts: 686

Rep: Reputation: 272Reputation: 272Reputation: 272
As Pat stated, you need to have a configured connection in /etc/NetworkManager/system-connections.

Example:

Code:
[connection]
id=MyWwanConnection
type=gsm

[ipv4]
method=auto

[gsm]
number=*99#
apn=insert.your.apn.here
You may also try nmcli dev to list your devices and nmcli con to get an actual connection...
 
Old 07-10-2013, 11:48 PM   #9
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,281

Rep: Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802
Quote:
Bus 002 Device 003: ID 19d2:1254 ZTE WCDMA Technologies MSM
Apparently you need a kernel version 3.4 or later to support this device. http://cateee.net/lkddb/web-lkddb/USB_NET_QMI_WWAN.html
Quote:
Should I upgrade my slackware 14.0 to slackware-current???
Slackware-current certainly has an appropriate kernel.

Last edited by allend; 07-10-2013 at 11:56 PM.
 
1 members found this post helpful.
Old 07-14-2013, 09:31 AM   #10
inverse
LQ Newbie
 
Registered: Oct 2010
Location: India
Distribution: Slackware
Posts: 19

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by volkerdi View Post
Have you set up the interface with nm-applet or the KDE NetworkManager app? If not, I don't think that nmcli can do much. I could be wrong, though... I've only used it a few times to get status reports. On my machine, NetworkManager was set up using nm-applet on Xfce. I do not boot into X, but NetworkManager brings up the connection at boot time without needing X to run once it has been configured.
Hi Pat

I did setup the interface with Network Manager and can be seen with
Quote:
nmcli con
.
I am simply following the steps provided in the website below:
http://www.unixwerk.eu/linux/slack/vodafone.html

Is there any way I can make it work???

Thanks
 
Old 07-14-2013, 09:40 AM   #11
inverse
LQ Newbie
 
Registered: Oct 2010
Location: India
Distribution: Slackware
Posts: 19

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by allend View Post
Apparently you need a kernel version 3.4 or later to support this device. http://cateee.net/lkddb/web-lkddb/USB_NET_QMI_WWAN.html

Slackware-current certainly has an appropriate kernel.
Now trying to upgrade to slackware-current.

Thanks
 
Old 07-28-2013, 05:40 AM   #12
inverse
LQ Newbie
 
Registered: Oct 2010
Location: India
Distribution: Slackware
Posts: 19

Original Poster
Rep: Reputation: 1
Hello All

I have upgraded my slackware 14.0 to slackware-current but still I am unable to enable my WWAN. I did

Quote:
nmcli nm wwan on
but wwan is not getting enabled.

I could have used KPPP but the problem is that there is no username password with my mobile broadband, airtel 3G dongle.

Am I skipping something??? Any changes in config files in order to make it working???

Please help.

Thanks
 
1 members found this post helpful.
Old 07-28-2013, 10:48 AM   #13
irgunII
Member
 
Registered: Jan 2012
Location: Directly above the center of the earth
Distribution: Slackware. What else is there?
Posts: 304

Rep: Reputation: 40
Did you install network-manager-applet? Also, networkmanager and applet is at 0.9.8

Once nm-applet is installed, you can click on it on the panel and it will give you better control over things.

I'm connected to an ATT aircard 770S, so I guess it's similar to what you have (remember, just guessing) and it's working within reason. The aircard is in the office (with an antenna to get a better signal way out here in the woods, which brought it up to three bars from two - it's a 4g device IIRR), and a TP-Link TL-WN821N Wireless N USB Adapter.

Is your setup similar?
 
Old 07-28-2013, 10:56 AM   #14
parcox
LQ Newbie
 
Registered: Jan 2007
Location: Pontianak, Indonesia
Distribution: Slackware64-14.0
Posts: 26

Rep: Reputation: 5
Try to activate the connection (nmcli con up uuid ...) regardless the wwan state. Because mine, it still can be connected while nm-tool reports wwan is disabled.

Here is the interesting part:
Code:
┌─(bowo@pcxthinkslack)(22:35:21)(•)──────────────────────────────────────────────────(~)─┐
└─(:))─> $ nmcli nm wwan
WWAN      
disabled  
┌─(bowo@pcxthinkslack)(22:35:28)(•)──────────────────────────────────────────────────(~)─┐
└─(:))─> $ nmcli con up uuid 5f7ab9bf-c4ae-4cd8-96eb-9cdacf103fbc
Active connection state: activating
Active connection path: /org/freedesktop/NetworkManager/ActiveConnection/10
state: activated
Connection activated
┌─(bowo@pcxthinkslack)(22:35:52)(•)──────────────────────────────────────────────────(~)─┐
└─(:))─> $ ping google.com
PING google.com (173.194.38.136) 56(84) bytes of data.
64 bytes from sin04s01-in-f8.1e100.net (173.194.38.136): icmp_req=1 ttl=54 time=117 ms
^C
--- google.com ping statistics ---
2 packets transmitted, 1 received, 50% packet loss, time 1000ms
rtt min/avg/max/mdev = 117.389/117.389/117.389/0.000 ms
┌─(bowo@pcxthinkslack)(22:36:10)(•)──────────────────────────────────────────────────(~)─┐
└─(:))─> $ nmcli nm wwan
WWAN      
disabled  
┌─(bowo@pcxthinkslack)(22:36:17)(•)──────────────────────────────────────────────────(~)─┐
└─(:))─> $ nmcli con | grep gsm
3                         5f7ab9bf-c4ae-4cd8-96eb-9cdacf103fbc   gsm               Sun 28 Jul 2013 10:59:43 PM WIT
I'm not sure if it's bug in NM. Running on Slackware64-14.0 here.

Last edited by parcox; 07-28-2013 at 11:05 AM. Reason: tipo
 
Old 09-15-2013, 03:51 AM   #15
inverse
LQ Newbie
 
Registered: Oct 2010
Location: India
Distribution: Slackware
Posts: 19

Original Poster
Rep: Reputation: 1
Hello All

Now the NetworkManager is able to detect my 3G mobile broadband. But still I am not able to connect. Every time I try to connect, it fails.
This is the message log:

Quote:
Sep 15 13:07:35 darkstar kernel: [ 278.561584] PPP generic driver version 2.4.2
Sep 15 13:07:35 darkstar pppd[2507]: pppd 2.4.5 started by root, uid 0
Sep 15 13:07:35 darkstar pppd[2507]: Using interface ppp0
Sep 15 13:07:35 darkstar pppd[2507]: Connect: ppp0 <--> /dev/ttyUSB1
Sep 15 13:07:55 darkstar NetworkManager[2043]: <info> Activation (ttyUSB1) Stage 4 of 5 (IPv4 Configure Timeout) scheduled...
Sep 15 13:07:55 darkstar NetworkManager[2043]: <info> Activation (ttyUSB1) Stage 4 of 5 (IPv4 Configure Timeout) started...
Sep 15 13:07:55 darkstar pppd[2507]: Terminating on signal 15
Sep 15 13:07:55 darkstar NetworkManager[2043]: <info> (ttyUSB1): device state change: ip-config -> failed (reason 'ip-config-unavailable') [70 120 5]
Sep 15 13:07:55 darkstar NetworkManager[2043]: <info> Activation (ttyUSB1) Stage 4 of 5 (IPv4 Configure Timeout) complete.
Sep 15 13:07:55 darkstar NetworkManager[2043]: <info> (ttyUSB1): device state change: failed -> disconnected (reason 'none') [120 30 0]
Sep 15 13:07:55 darkstar NetworkManager[2043]: <info> (ttyUSB1): deactivating device (reason 'none') [0]
Sep 15 13:07:55 darkstar modem-manager[2051]: <info> Modem /org/freedesktop/ModemManager/Modems/0: state changed (connected -> disconnecting)
Sep 15 13:07:56 darkstar modem-manager[2051]: <info> Modem /org/freedesktop/ModemManager/Modems/0: state changed (disconnecting -> registered)
I tried with about all the combinations of settings, but no luck.

Please Help.

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Connect my non wireless enabled pc to my wireless enabled pc via ethernet? Help me im dumb Linux - Networking 3 10-21-2012 04:58 PM
Trying to use Qualcomm 9201 WWAN card. Not sure where to start. melee Linux - Hardware 2 03-27-2009 01:15 PM
[sda] Write cache: enabled, read cache: enabled, doesn't support DPO seskissinger Linux - Software 3 05-16-2008 01:17 PM
xdmcp is not being enabled pradeep_chk Linux - Newbie 0 09-04-2006 11:07 AM
How do I tell if both processors are enabled? duerra Linux - Newbie 4 01-18-2004 02:05 PM


All times are GMT -5. The time now is 11:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration