LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 11-01-2011, 06:15 AM   #1
scam
Member
 
Registered: Jun 2011
Location: UK
Distribution: Slackware 13.1, Slackware 13.37
Posts: 92

Rep: Reputation: Disabled
wvdial problem


Hi, wonder if anyone can help me with a problem with wvdial, here my wvdial config file http://pastebin.com/U4yk3q8y

This config file works with slack 13.37, but when I try it with 13.0 it says there is no dev /dev/ttyUSB2 and was wondering how I could find which it uses on 13.0. I'm using a mobile broadband usb modem and I can mount the device with /dev/sr0 but that doesn't work when I replace ttyUSB2 with /dev/sr0 ....any help would be great
 
Old 11-01-2011, 09:39 AM   #2
scam
Member
 
Registered: Jun 2011
Location: UK
Distribution: Slackware 13.1, Slackware 13.37
Posts: 92

Original Poster
Rep: Reputation: Disabled
Here is the output from dmesg after plugging the modem .... http://pastebin.com/nymddY8R ..I've also tried wvdialconf and it doesn't detect the modem either.
 
Old 11-01-2011, 09:51 AM   #3
0men
Member
 
Registered: Mar 2011
Location: Gold Coast, Australia
Distribution: saline, centos, freeBSD, slackware
Posts: 180

Rep: Reputation: 22
Brother,

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
Phone = *99#
ISDN = 0
Username = user
Password = pass
Modem = /dev/ttyUSB0
Baud = 9600
Stupid Mode = 1
Dial Command = ATDT
New PPD = yesomen@darkstar

Never had a problem with this setup, no matter what modem.
*note that the last line can be

New PPD = yesscam@darkstar
 
Old 11-01-2011, 09:59 AM   #4
san
Member
 
Registered: Jan 2006
Location: vienna, .at
Distribution: Slackware64 13.37
Posts: 50

Rep: Reputation: 12
i'm not sure, but I think that on 13.0, usb-modeswitch has to be run/configured manually (back then, the programme was not yet as user-friendly as it is now). I remember having written an udev-rule that ran after plugging the stick in.
 
Old 11-01-2011, 10:06 AM   #5
scam
Member
 
Registered: Jun 2011
Location: UK
Distribution: Slackware 13.1, Slackware 13.37
Posts: 92

Original Poster
Rep: Reputation: Disabled
Omen my problem is even though slack-13.0 sees my device with lsusb and with dmesg, it doesn't create /dev/ttyUSB* or even /dev/ttyU*
 
Old 11-01-2011, 10:08 AM   #6
scam
Member
 
Registered: Jun 2011
Location: UK
Distribution: Slackware 13.1, Slackware 13.37
Posts: 92

Original Poster
Rep: Reputation: Disabled
Thanks san, I'll have a google on that
 
Old 11-01-2011, 10:14 AM   #7
san
Member
 
Registered: Jan 2006
Location: vienna, .at
Distribution: Slackware64 13.37
Posts: 50

Rep: Reputation: 12
from my 13.0 "/etc" backup:
Code:
#/etc/udev/rules.d/10-local.rules

# Option GlobeSurfer Icon 7.2, old firmware:
SUBSYSTEM=="usb", ACTION=="add", ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="1000", RUN+="/usr/sbin/usb_modeswitch"
not sure if usb_modeswitch was already shipped with slack 13.0.
 
Old 11-01-2011, 11:01 AM   #8
zasavage
Member
 
Registered: Sep 2010
Location: Bloemfontein , South Africa
Distribution: Slackware 13.37 and Slackware 14
Posts: 193

Rep: Reputation: 6
Hi there

In order to access the modem proper, you'll need to signal to the stick that it may switch now. Fortunately, on this particular stick this is implemented in a quite straigt-forward way -- simply eject the CD:

eject /dev/sr0

After ejecting, three new devices will show up at ls /dev/ttyUSB*:

/dev/ttyUSB0 /dev/ttyUSB1 /dev/ttyUSB2


The important one is /dev/ttyUSB2
Edit wvdial.conf use /dev/ttyUSB2 as the modem
Regards
Lawrence

Last edited by zasavage; 11-01-2011 at 11:02 AM.
 
Old 11-01-2011, 05:57 PM   #9
scam
Member
 
Registered: Jun 2011
Location: UK
Distribution: Slackware 13.1, Slackware 13.37
Posts: 92

Original Poster
Rep: Reputation: Disabled
Well i tried zasavage's way and that worked, I haven't had chance to install usb_modemswitch yet but soon as I eject the device the ttyUSB0-2 appeared. Edited wvdial back to ttyUSB2 and ran wvdial and now works fine cause i'm typing this on slack 13 ....anyway thanks for all the help and advice.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Having problem with wvdial crrail Linux - Newbie 2 05-04-2011 10:43 AM
Help with wvdial. Have wvdial not dial and wait till handshake. dragos240 Linux - Networking 2 01-14-2011 09:04 AM
[SOLVED] Adding wvdial to start menu/desktop, running wvdial without shell. Mogget Linux - Desktop 1 08-07-2009 03:08 AM
wvdial problem Nik0s Linux - Newbie 5 02-04-2004 03:55 PM
WvDial Problem Nauseous Linux - Networking 5 04-08-2003 02:13 AM


All times are GMT -5. The time now is 03:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration