LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   wvdial is connecting but i'm unable to do anything (http://www.linuxquestions.org/questions/slackware-14/wvdial-is-connecting-but-im-unable-to-do-anything-714861/)

basheer 03-27-2009 10:36 AM

wvdial is connecting but i'm unable to do anything
 
I have a USB modem and i connected to the net through wvdial. I could connect properly.
But i'm unable to do anything with this.
Please help me with this.
I'm using slackware 12.2.


root@darkstar:~# wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT#777
--> Waiting for carrier.
ATDT#777
CONNECT
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Fri Mar 27 19:14:19 2009
--> Pid of pppd: 3423
--> Using interface ppp0
--> pppd: @[06][08]�[06][08]
--> pppd: @[06][08]�[06][08]
--> pppd: @[06][08]�[06][08]
--> pppd: @[06][08]�[06][08]
--> pppd: @[06][08]�[06][08]
--> local IP address 121.245.35.144
--> pppd: @[06][08]�[06][08]
--> remote IP address 172.23.129.14
--> pppd: @[06][08]�[06][08]
--> primary DNS address 203.197.12.30
--> pppd: @[06][08]�[06][08]
--> secondary DNS address 202.54.1.18
--> pppd: @[06][08]�[06][08]






When i used wget to download gnucash from slackbuilds I got this error.


root@darkstar:~# wget -c http://slackbuilds.org/slackbuilds/1...gnucash.tar.gz
--2009-03-27 19:23:16-- http://slackbuilds.org/slackbuilds/1...gnucash.tar.gz
Resolving slackbuilds.org... failed: Temporary failure in name resolution.
wget: unable to resolve host address `slackbuilds.org'

when i tried connecting with firefox to access google, I got the following error.














Address Not Found













Firefox can't find the server at www.google.com.







The browser could not find the host server for the provided address.

* Did you make a mistake when typing the domain? (e.g. "ww.mozilla.org" instead of "www.mozilla.org")
* Are you certain this domain address exists? Its registration may have expired.
* Are you unable to browse other sites? Check your network connection and DNS server settings.
* Is your computer or network protected by a firewall or proxy? Incorrect settings can interfere with Web browsing.

CAN SOMEONE PLEASE HELP ME OUT.

w1k0 03-27-2009 01:38 PM

First try the command:

ping 208.77.188.166

It should display something like:

PING 208.77.188.166 (208.77.188.166) 56(84) bytes of data.
64 bytes from 208.77.188.166: icmp_seq=1 ttl=54 time=195 ms
64 bytes from 208.77.188.166: icmp_seq=2 ttl=54 time=187 ms
64 bytes from 208.77.188.166: icmp_seq=3 ttl=54 time=193 ms

Then try the command:

ping www.example.com

It should display something like:

PING www.example.com (208.77.188.166) 56(84) bytes of data.
64 bytes from www.example.com (208.77.188.166): icmp_seq=1 ttl=54 time=192 ms
64 bytes from www.example.com (208.77.188.166): icmp_seq=2 ttl=54 time=189 ms
64 bytes from www.example.com (208.77.188.166): icmp_seq=3 ttl=54 time=195 ms

If the first command works and the second command displays the error it means that you haven't valid DNS server registered in the file /etc/resolv.conf and you should add to that file something like:

nameserver 208.67.222.222
nameserver 208.67.220.220

w1k0 03-27-2009 02:17 PM

On the page http://wiki.linuxquestions.org/wiki/Wvdial I found such tip:

Quote:

In Slackware 10, I noticed wvdial wrote DNS configuration on /etc/ppp/resolv.conf while reading /etc/resolv.conf. This prevented DNS from working. Copying /etc/ppp/resolv.conf on /etc/resolv.conf solved the problem.

w1k0 03-27-2009 02:43 PM

You can also check your routing table:

route

Code:

Kernel IP routing table
Destination    Gateway        Genmask        Flags Metric Ref    Use Iface
isp            *              255.255.255.255 UH    0      0        0 ppp0
localnet        *              255.255.255.0  U    0      0        0 eth0
loopback        *              255.0.0.0      U    0      0        0 lo
default        *              0.0.0.0        U    0      0        0 ppp0

If default doesn't point ppp0 use two commands:

route del default
route add default ppp0

sarmis 04-02-2009 09:18 AM

@ w1k0

The post #2 you did helped me out a lot. Was true: I had to edit resolv.conf because there was no DNS address there.So, thanks.


All times are GMT -5. The time now is 01:39 AM.