LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-30-2007, 01:36 AM   #1
alkos333
Member
 
Registered: Dec 2006
Posts: 271

Rep: Reputation: 31
wpa_supplicant: ioctl[SIOCSIWAUTH]: Operation not supported


It used to run fine on Slackware 11.0 with ipw3945. I upgraded to 12.0 and use iwl3945 now, which uses wlan0 instead of eth1.

Although it seems to work, I'm getting the following message on the start up:

Code:
root@alkos333_TPT60:/var/run# !wpa_supplicant
wpa_supplicant -B -i wlan0 -D wext -c /etc/wpa_supplicant.conf 
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
Here is a little bit more info from the commands I ran:

Code:
root@alkos333_TPT60:/var/run# lsof /var/run/wpa_supplicant/wlan0 
COMMAND    PID USER   FD   TYPE     DEVICE SIZE  NODE NAME
wpa_suppl 8087 root    6u  unix 0xef787040      39613 /var/run/wpa_supplicant/wlan0
Code:
root@alkos333_TPT60:/var/run# grep IEEE80211 /usr/src/linux-$(uname -r)/.config
CONFIG_IEEE80211=m
# CONFIG_IEEE80211_DEBUG is not set
CONFIG_IEEE80211_CRYPT_WEP=m
CONFIG_IEEE80211_CRYPT_CCMP=m
CONFIG_IEEE80211_CRYPT_TKIP=m
# CONFIG_IEEE80211_SOFTMAC is not set
 
Old 08-30-2007, 02:25 AM   #2
merer
LQ Newbie
 
Registered: Jul 2007
Location: Vilnius,Lithuania
Distribution: Slackware 12.2
Posts: 20

Rep: Reputation: 1
if i remember correctly, your command should be
wpa_supplicant -B -iwlan0 -Dwext -c/etc/wpa_supplicant.conf
(no spaces after -i -D -c)
try it. Maybe the problem will disappear.
 
Old 08-30-2007, 02:48 AM   #3
alkos333
Member
 
Registered: Dec 2006
Posts: 271

Original Poster
Rep: Reputation: 31
No, that doesn't make any difference because wpa_supplicant seems to be running and I'm actually connected to a WPA AP right now. I'm just trying to figure out how to get rid of that error/warning.
 
Old 08-30-2007, 04:29 AM   #4
General Failure
Member
 
Registered: Jan 2007
Location: Germany
Distribution: Slackware 13.37
Posts: 384

Rep: Reputation: 34
IIRC you can get more verbose output from wpa_supplicant by adding -dd or -ddd to the command. Maybe this brings some more information up.
 
Old 09-01-2007, 07:29 AM   #5
alkos333
Member
 
Registered: Dec 2006
Posts: 271

Original Poster
Rep: Reputation: 31
Here is the output: http://alkos333.net/wpa_supplicant_output

Last edited by alkos333; 09-01-2007 at 05:42 PM.
 
Old 09-29-2007, 01:23 AM   #6
Kiran KN
LQ Newbie
 
Registered: Sep 2007
Posts: 2

Rep: Reputation: 0
Cool Update your madwifi driver

Use the ticket 462 of madwifi to update your madwifi driver so that it can adhere to WE-18 standard
 
Old 09-29-2007, 07:03 AM   #7
alkos333
Member
 
Registered: Dec 2006
Posts: 271

Original Poster
Rep: Reputation: 31
But I'm not using a madwifi driver though, I'm using iwl3945?
 
Old 09-30-2007, 12:56 PM   #8
Kiran KN
LQ Newbie
 
Registered: Sep 2007
Posts: 2

Rep: Reputation: 0
Smile

The error usually occurs when the driver does not support a particular IOCTL. Just downloaded ipw3945 version 1.2.2 and verified that the SIGCSIWAUTH is supported by this driver. Download this driver and compile it with WIRELESS_EXT flag set to 18 and it should work.
 
Old 09-30-2007, 02:40 PM   #9
alkos333
Member
 
Registered: Dec 2006
Posts: 271

Original Poster
Rep: Reputation: 31
I don't like ipw3945 because it requires a regulatory daemon and just isn't as stable as iwl3945. I have already reported this to iwl3945, so hopefully it will be fixed soon.

Last edited by alkos333; 09-30-2007 at 02:53 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
setfacl: test: Operation not supported raxxal Mandriva 6 10-25-2012 05:09 AM
OpenVPN: Cannot ioctl TUNSETIFF tun: Operation not permitted? licht Linux - Networking 3 07-29-2007 07:38 AM
wpa_supplicant - ioctl[SIOCSIWAP]: Input/output error Irayo Linux - Wireless Networking 2 05-13-2006 06:50 PM
SIOCETHTOOL: Operation not supported tallen Linux - Newbie 2 01-26-2006 09:28 PM
wpasupplicant: operation not supported error Markup Linux - Wireless Networking 1 09-14-2005 09:20 AM


All times are GMT -5. The time now is 03:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration