LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-25-2007, 09:51 PM   #1
kozimodo
LQ Newbie
 
Registered: Feb 2007
Posts: 9

Rep: Reputation: 0
wpa supplicant and no broadcast ssid


I've managed to get wpa supplicant to work when my ssid is being broadcast but am at a loss when it is not being broadcast. Can anyone tell me how to configure my rc.inet1.conf file so that it can connect to an ssid that is not being broadcast?

Thanks!
 
Old 02-26-2007, 12:16 AM   #2
brokenflea
Member
 
Registered: Nov 2003
Distribution: Slackware 11.0, FreeBSD
Posts: 284

Rep: Reputation: 30
I believe you need to edit your wpa_supplicant.conf file. That's the way its setup on my notebook.

My config file reads:

Code:
ap_scan=2 ## the value 2 for ap_scan defines a non-broadcast ssid
network {
ssid="your-ssid-here"
psk="your-psk"
pairwise=TKIP
group=TKIP
key_mgmt=WPA-PSK
proto=WPA
}
 
Old 02-26-2007, 10:34 AM   #3
kozimodo
LQ Newbie
 
Registered: Feb 2007
Posts: 9

Original Poster
Rep: Reputation: 0
I've tried that -- in fact, I used your howto and it only works if I broadcast the ssid and comment out the ap_scan=2.
 
Old 02-26-2007, 10:42 AM   #4
Emerson
Senior Member
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~
Posts: 3,177

Rep: Reputation: Disabled
You should broadcast your SSID. Hiding it is just silly.

http://blogs.zdnet.com/Ou/index.php?p=43
 
Old 02-26-2007, 02:57 PM   #5
kozimodo
LQ Newbie
 
Registered: Feb 2007
Posts: 9

Original Poster
Rep: Reputation: 0
Thanks. I had always suspected so.
 
Old 04-30-2009, 04:17 AM   #6
mikosz
LQ Newbie
 
Registered: Apr 2009
Posts: 1

Rep: Reputation: 0
I've just found a solution for this problem, so I wanna share it in case someone bumps into it And Emerson -> 'you should broadcast your SSID' isn't very helpful in case you're a user, not an admin of a wifi network, right?

So, the solution is quite simple, in your wpa_supplicant.conf:

network={
ssid="the non broadcasted ssid"
scan_ssid=1
...
}

Hope that helps.
 
  


Reply

Tags
broadcast, ssid, supplicant, wg511v2, wpa


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
A better way to WPA SUPPLICANT Ashrack Linux - Wireless Networking 5 01-25-2007 01:46 PM
is broadcast ssid necessary for iwconfig glorsplitz Linux - Wireless Networking 1 04-29-2006 09:31 PM
WPA Supplicant Question brokenflea Slackware 7 07-28-2005 09:18 PM
How do i set up WPA PSK with wpa supplicant and linuxant? Eleavings Linux - Wireless Networking 4 12-27-2004 11:24 AM
Turning off ssid broadcast laclac01 Linux - Wireless Networking 2 04-26-2004 09:48 AM


All times are GMT -5. The time now is 10:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration