LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-10-2011, 01:39 PM   #1
Jinx-Wolf
LQ Newbie
 
Registered: Feb 2011
Distribution: Slackware
Posts: 26

Rep: Reputation: 1
wmii + Slackware 13.37


I'm a n00b to the whole "Tiling Window Manager" realm, but recently I found myself trying to snap my windows together to be a bit more productive.

Enter wmii:
I've taken a look at a few other wm's (dwm, awesome, xmonad, etc), I even tried a few out, but wmii looks the most appealing to me.

It took me a while to get it working (mostly), but after fighting with the sources for a while, I downloaded the hg version and go it compiled and installed. Edited my .xinitrc file to execute wmii when I startx, and it does just that.

However, after it's up and running, I can't seem to do anything at all. I've tried MOD0 and MOD1 and nothing happens when I MOD+ENTER/MOD+P. I have to CTRL+ALT+Backspace to get out. After dropping back into the shell, I see a few errors left over from my key combinations:

Code:
xterm Xt error: Can't open display: :0
wimenu: fatal: Can't open display
wmiir: fatal: can't mount: Connection refuse
I've tried messing around with the DISPLAY settings, but that only causes wmii to crash with the same error on startup. Any ideas?

[One side problem that I'm having, and I didn't see on the forums, is that after updating to 13.37 if I press more than one key down at a time the first key stops responding when I lift up on the second.
Example:
When playing SuperTuxKart you press the up arrow to go, then left or right to turn; After I finish turning and let go of the left or right arrow, I stop accelerating because the up arrow isn't responding anymore. I've had this problem ever since I've updated, but haven't bothered to ask, but since I'm here...]
 
Old 06-10-2011, 03:29 PM   #2
Snark1994
Senior Member
 
Registered: Sep 2010
Location: Wales, UK
Distribution: Arch
Posts: 1,630
Blog Entries: 3

Rep: Reputation: 345Reputation: 345Reputation: 345Reputation: 345
It's fairly normal to have errors like that when you kill off the X server suddenly - the clients are upset that you swept the rug out from under their feet, as it were. Look at your wmiirc to find out what your mod key is (mine is MOD4, the Windows key, but it may well be "Alt" on your system). I feel that's the most likely place that things have gone wrong, unless you haven't compiled it correctly... Also, I guess you should check that you have xterm installed (or whatever you've set your default terminal to, again in the wmiirc). But I'm pretty sure MOD+P and MOD+A should work regardless (I assume you know what they're meant to do - look at the task-bar-esque thing at the bottom of the screen, it should fill with a list of options, which you can select by starting to type)

Hope this makes sense / is helpful
 
Old 06-11-2011, 12:43 AM   #3
Jinx-Wolf
LQ Newbie
 
Registered: Feb 2011
Distribution: Slackware
Posts: 26

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by Snark1994 View Post
It's fairly normal to have errors like that when you kill off the X server suddenly - the clients are upset that you swept the rug out from under their feet, as it were. Look at your wmiirc to find out what your mod key is (mine is MOD4, the Windows key, but it may well be "Alt" on your system). I feel that's the most likely place that things have gone wrong, unless you haven't compiled it correctly... Also, I guess you should check that you have xterm installed (or whatever you've set your default terminal to, again in the wmiirc). But I'm pretty sure MOD+P and MOD+A should work regardless (I assume you know what they're meant to do - look at the task-bar-esque thing at the bottom of the screen, it should fill with a list of options, which you can select by starting to type)

Hope this makes sense / is helpful
I realize that X complains a lot with the dreaded ctrl+alt+backspace, but when I press MOD+P 5 times I get the wimenu error 5 times, or when I press MOD+ENTER 6 times I get the xterm Xt error 6 times, etc. I've tried different MOD settings in wmiirc, and I've also tried the Super/Alt keys. MOD1/ALT works best in my situation so that's what I'm sticking with. Since it I'm getting errors corresponding to the correct key combinations, I'm pretty sure it's registering the input correctly, but not capable of outputting to my display for whatever reason.

Also xterm comes installed on Slackware 13.37, but I've also tried using the default terminal I've been using in XFCE as well. Neither works, nor does trying to change the shell. I've tried bash, zsh, and sh.

My set-up is a little odd. I use a monitor hooked up to my Laptop, but only clone the screen (not trying to do anything more, as I don't need dual monitors). I thought this might be the issue, so I undocked my laptop and tried again from scratch, but to no avail. Same issues. wmii compiles, installs, and launches flawlessly... until I try to actually DO something. The only thing I'm capable of doing is taking my cursor and dragging the little bar to the left around the screen...
 
Old 06-12-2011, 05:10 AM   #4
Snark1994
Senior Member
 
Registered: Sep 2010
Location: Wales, UK
Distribution: Arch
Posts: 1,630
Blog Entries: 3

Rep: Reputation: 345Reputation: 345Reputation: 345Reputation: 345
I'm sorry, the only thing I can think of is playing with the DISPLAY environment variable, but if it works with other WMs I don't see why it shouldn't work with wmii... However, I read in another LQ thread for a similar problem that someone recommended using the proprietary nVidia driver (if you use an nVidia card), so perhaps you can try that if it applies to you.

Finally, I'll just post my .xinitrc and xorg.conf, in case it gives you any hints... *shrugs*

Code:
#!/bin/sh
# ~/.xinitrc

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi

until wmii; do
	true
done
and

Code:
#All the files in my /etc/X11/xorg.conf.d/ directory except for the input settings
Section "ServerLayout"
    Identifier     "DualSreen"
    Screen       0 "LeftScreen"
    Screen       1 "RightScreen" RightOf "LeftScreen" #RightScreen at the right of LeftScreen
    Option         "Xinerama" "1" #To move windows between screens
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    Option         "Enable" "true"
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    Option         "Enable" "true"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    Screen         0
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    Screen         1
EndSection

Section "Screen"
    Identifier     "LeftScreen"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    SubSection "Display"
        Depth          24
        Modes          "1024x768_60.00"
    EndSubSection
EndSection

Section "Screen"
    Identifier     "RightScreen"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth   24
    Option         "TwinView" "0"
    SubSection "Display"
        Depth          24
        Modes          "1024x768_60.00"
    EndSubSection
EndSection
# Collection of quirks and blacklist/whitelists for specific devices.


# Accelerometer device, posts data through ABS_X/ABS_Y, making X unusable
# http://bugs.freedesktop.org/show_bug.cgi?id=22442 
Section "InputClass"
        Identifier "ThinkPad HDAPS accelerometer blacklist"
        MatchProduct "ThinkPad HDAPS accelerometer data"
        Option "Ignore" "on"
EndSection
Section "Device"
        Identifier "Default nvidia Device"
        Driver "nvidia"
        Option "NoLogo" "True"
EndSection
EDIT: reading through my xorg.conf files, I've duplicated stuff across files. Damn. Don't copy it that closely, it looks badly wrong. But hey, it works for now after exams I'll dig through and sort it out...

EDIT II: Erm, I had a monitor.conf.old file, and I had typed 'cat /etc/X11/xorg.conf.d/*' It's all good

I used to use Slackware until the number of these "should work but doesn't, not clever enough to work out what the hell's wrong" issues reached the end of my patience and I switched to Arch. But I sincerely hope you manage to get it fixed

Last edited by Snark1994; 06-12-2011 at 11:04 AM.
 
Old 06-12-2011, 12:10 PM   #5
Jinx-Wolf
LQ Newbie
 
Registered: Feb 2011
Distribution: Slackware
Posts: 26

Original Poster
Rep: Reputation: 1
Still no luck, but thanks for the help.
With a months worth of studying, and my test yesterday, I'm kind of burnt out... I'll probably just end up installing Arch/Debian and trying it again.

I don't have nVidia, and thinking about it that could be my problem. These intel/mesa drivers have been a horror story, but I thought I had almost all the kinks worked out...
I've tried using your .xinitrc, and my xorg.conf looks almost identical (other than I'm not using a dual monitor display). I've tried changing /usr/local/ to /usr for both wmii and libixp, then recompiling. I've tried running as root, and I've tried removing all the config files and starting again from scratch.

The furthest I get every time is: wmii starts up, It asks me if I want to use the Windows or Alt key for MOD, I choose one, and I see a blank desktop that won't display any applications (including it's own menu).

[I completely agree with you. I absolutely love Slackware. Every time I try to switch back to a Debian based distro, I always come back. I love getting my hands dirty (to a point), and I love how stable everything is once I get it running. But these "should work, but don't" problems are starting to get on my nerves. I don't NEED to switch to wmii, but I WANT to, and since it's broken, the geek in me wants to fix it at all costs. I spent weeks getting the whole intel/mesa fiasco worked out. Again, I'd like to thank you for your help.]

EDIT:
Here's to hoping that more information will shed some new light on a better trained eye.
I redirected the output from X into a log file while running wmii. After wmii started up, I tried to open the menu 3 times, and the terminal twice, then immediately killed X.

Code:
xauth:  file /home/jinx/.serverauth.23155 does not exist


X.Org X Server 1.9.5
Release Date: 2011-03-17
X Protocol Version 11, Revision 0
Build Operating System: Slackware 13.37 Slackware Linux Project
Current Operating System: Linux darkstar 2.6.38.4-smp #3 SMP Thu Apr 21 21:35:10 CDT 2011 i686
Kernel command line: BOOT_IMAGE=Linux ro root=801 vt.default_utf8=0
Build Date: 18 March 2011  12:08:03AM
 
Current version of pixman: 0.20.2
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jun 13 01:04:31 2011
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
      after 707 requests (707 known processed) with 0 events remaining.
xinit: connection to X server lost

waiting for X server to shut down XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
      after 82 requests (82 known processed) with 0 events remaining.
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0"
      after 9 requests (9 known processed) with 0 events remaining.
xterm Xt error: Can't open display: :0
xterm Xt error: Can't open display: :0
wimenu: fatal: Can't open display
wimenu: fatal: Can't open display
wimenu: fatal: Can't open display
wmiir: fatal: can't mount: Connection refused

Last edited by Jinx-Wolf; 06-13-2011 at 01:09 AM.
 
Old 06-13-2011, 01:30 PM   #6
Jinx-Wolf
LQ Newbie
 
Registered: Feb 2011
Distribution: Slackware
Posts: 26

Original Poster
Rep: Reputation: 1
Sorry for the double post, but I wanted to give this thread a "bump" with what I've found so far:

So I looked into that xauth error, and fiddled around with it until it was fixed.
My system wasn't creating a ~/.Xauthority file, so the first thing I did was use the command:

Code:
xauth merge /home/jinx/.Xauthority
I still got the error, so I kept looking around, and found a really old ubuntu How-To. In /usr/bin/startx it was setting the xserverauthfile env variable to =$HOME/.serverauth.$$, so I just edited that line to say xserverauthfile=$XAUTHORITY, and that did away with the xauth error in the previous post.

Still no luck...change

I did some more digging around, and I found a thread on the openSUSE forums with a problem similar to mine (but with KDE). The common factor here was starting up in run level 3 and using startx. His problem was solved by installing a login manager and then booting straight up into run level 4. Something I was trying to avoid, but I'm not totally again.

In this case, I tried installing SLiM, and changing inittab to default into 4. Here's the fun part;
SLiM refuses to login to my user account. I checked the /var/log files and this is what I came up with:
Code:
/usr/bin/xauth:  file /var/run/slim.auth does not exist


Fatal server error:
Server is already active for display 0
	If this server is no longer running, remove /tmp/.X0-lock
	and start again.


Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help.
It looks like xauth is still not doing it's job and/or both SLiM and wmii are having problems writing things to DISPLAY 0 because the think it's already in use... because they aren't getting permissions to use it??

I feel like I'm getting closer to the solution here, but I'm not sure where to go from here. Kind of confused how XFCE is skipping along without any worries...

EDIT:
So... SLiM just randomly started working after a couple restarts...
I tried to RTFM on wmii, but it keeps giving me an error that it can't read the man page... So, perhaps I'm installing wmii wrong??

My steps:
hg clone http://hg.suckless.org/wmii
cd wmii
vim config.mk [PREFIX = /usr]
make
sudo make install
vim .xinitrc [add exec wmii]
logout xfce
startx

pretty themed wmii starts up (I downloaded a custom wmiirc_local)
NOTHING else works.... not even MOD+P for the menu...

Last edited by Jinx-Wolf; 06-13-2011 at 03:19 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wmii not showing up 10100010 Linux - Desktop 1 08-31-2010 08:38 PM
Keymap change in locally installed wmii? greengirl Slackware 2 07-01-2010 07:52 AM
wmii slackbuild fails... What can I do...? Alexvader Slackware 3 11-02-2009 09:59 AM
Ubuntu - Problem with WMII RUBY Wind_Sp00n Ubuntu 0 10-10-2006 08:44 PM
how to bring wmii to my login screen bloodiestmarry Fedora 2 01-03-2006 07:21 AM


All times are GMT -5. The time now is 12:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration