LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   wmii slackbuild fails... What can I do...? (http://www.linuxquestions.org/questions/slackware-14/wmii-slackbuild-fails-what-can-i-do-766220/)

Alexvader 11-02-2009 08:39 AM

wmii slackbuild fails... What can I do...?
 
Hi Forum

I tried to build wmii from slackbuilds, but compilation yelds an error about not finding some files... (missed dependency maybe...? )

CC cmd/wmiir.o
cmd/wmiir.c:11:17: error: ixp.h: No such file or directory
cmd/wmiir.c:15: error: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token
cmd/wmiir.c:28: warning: implicit declaration of function 'ixp_errbuf'
cmd/wmiir.c:28: warning: passing argument 2 of 'fmtstrcpy' makes pointer from integer without a cast
cmd/wmiir.c:33: error: expected ')' before '*' token
cmd/wmiir.c:49: error: 'Stat' undeclared
cmd/wmiir.c:49: error: 'st1' undeclared
cmd/wmiir.c:49: error: 'st2' undeclared
cmd/wmiir.c:49: warning: left-hand operand of comma expression has no effect
cmd/wmiir.c:51: error: expected expression before ')' token
cmd/wmiir.c:52: error: expected expression before ')' token
cmd/wmiir.c:71: error: 'P9_DMDIR' undeclared
cmd/wmiir.c:85: warning: implicit declaration of function 'ctime_r'
cmd/wmiir.c:91: error: expected ')' before '*' token
cmd/wmiir.c:107: error: 'IxpCFid' undeclared
cmd/wmiir.c:107: error: 'fid' undeclared
cmd/wmiir.c:116: warning: implicit declaration of function 'ixp_open'
cmd/wmiir.c:116: error: 'client' undeclared
cmd/wmiir.c:116: error: 'P9_OWRITE' undeclared
cmd/wmiir.c:120: warning: implicit declaration of function 'write_data'
cmd/wmiir.c:121: warning: implicit declaration of function 'ixp_close'
cmd/wmiir.c:127: error: 'IxpCFid' undeclared
cmd/wmiir.c:127: error: 'fid' undeclared
cmd/wmiir.c:137: error: 'client' undeclared
cmd/wmiir.c:137: error: 'P9_OWRITE' undeclared
cmd/wmiir.c:157: warning: implicit declaration of function 'ixp_write'
cmd/wmiir.c:166: error: 'IxpCFid' undeclared
cmd/wmiir.c:166: error: 'fid' undeclared
cmd/wmiir.c:175: warning: implicit declaration of function 'ixp_create'
cmd/wmiir.c:175: error: 'client' undeclared
cmd/wmiir.c:175: error: 'P9_OWRITE' undeclared
cmd/wmiir.c:179: error: 'P9_DMDIR' undeclared
cmd/wmiir.c:195: warning: implicit declaration of function 'ixp_remove'
cmd/wmiir.c:195: error: 'client' undeclared
cmd/wmiir.c:202: error: 'IxpCFid' undeclared
cmd/wmiir.c:202: error: 'fid' undeclared
cmd/wmiir.c:212: error: 'client' undeclared
cmd/wmiir.c:212: error: 'P9_OREAD' undeclared
cmd/wmiir.c:217: warning: implicit declaration of function 'ixp_read'
cmd/wmiir.c:229: error: 'IxpMsg' undeclared
cmd/wmiir.c:229: error: expected ';' before 'm'
cmd/wmiir.c:230: error: 'Stat' undeclared
cmd/wmiir.c:230: error: 'stat' undeclared
cmd/wmiir.c:231: error: 'IxpCFid' undeclared
cmd/wmiir.c:231: error: 'fid' undeclared
cmd/wmiir.c:251: warning: implicit declaration of function 'ixp_stat'
cmd/wmiir.c:251: error: 'client' undeclared
cmd/wmiir.c:255: error: 'P9_DMDIR' undeclared
cmd/wmiir.c:256: warning: implicit declaration of function 'print_stat'
cmd/wmiir.c:257: warning: implicit declaration of function 'ixp_freestat'
cmd/wmiir.c:262: error: 'P9_OREAD' undeclared
cmd/wmiir.c:271: error: 'm' undeclared
cmd/wmiir.c:271: warning: implicit declaration of function 'ixp_message'
cmd/wmiir.c:271: error: 'MsgUnpack' undeclared
cmd/wmiir.c:277: warning: implicit declaration of function 'ixp_pstat'
cmd/wmiir.c:335: error: 'client' undeclared
cmd/wmiir.c:335: warning: implicit declaration of function 'ixp_mount'
cmd/wmiir.c:346: warning: implicit declaration of function 'ixp_unmount'
make[1]: *** [wmiir.o] Error 1
make: *** [dall] Error 2
bash-3.1# ls
README doinst.sh slack-desc wmii-3.6-config_mk.diff wmii-3.6.tar.gz wmii.SlackBuild wmii.info xinitrc.wmii
bash-3.1#


What do i miss to Install wmii slackbuild...?

BRGDS

Alex

slackd 11-02-2009 09:11 AM

from the README:

Quote:

Requirements
------------
In order to build wmii you need the Xlib header files and libixp. xmessage
and dmenu are used by the default scripts. libixp and dmenu can be obtained
from http://suckless.org/. Either plan9port[2] or 9base is recommended.

Alien Bob 11-02-2009 09:24 AM

From http://slackbuilds.org/repository/13.0/desktop/wmii/ : "This requires libixp, plan9port, and dmenu". Please read the requirements first, before trying to build software from the site.

All of those requirements have SlackBuild scripts at http://slackbuilds.org/ as well.

Eric

Alexvader 11-02-2009 09:59 AM

Hi @Slackd @Alien_Bob

Thanks for your hints...

BRGDS

Alex


All times are GMT -5. The time now is 11:42 PM.