LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-29-2010, 04:48 PM   #1
timetraveler
Member
 
Registered: Apr 2010
Posts: 243
Blog Entries: 2

Rep: Reputation: 31
With new kernel the device names are changed and lilo still looks for old device


With my stock install kernel for sw 13 my boot device = /dev/hdc1

Now I built a new kernel from 2.6.33.3 and that device is seen as /dev/sdb1

If I try to change the new lilo entry for the new kernel to root=/dev/sdb1 and run lilo it fails.

I tried making an initrd but that only boots so far until the system looks for hdc1

Does anyone know a way out of this rabbit hole?
 
Old 04-29-2010, 05:14 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,191

Rep: Reputation: Disabled
Read this: http://alien.slackbook.org/blog/robb...tchover-howto/

Eric
 
Old 04-29-2010, 05:26 PM   #3
timetraveler
Member
 
Registered: Apr 2010
Posts: 243
Blog Entries: 2

Original Poster
Rep: Reputation: 31
I had tried this but was still picking up hdc1.

I am now looking into rdev that is mentioned in lilo.conf man page.
I will probably rebuild the kernel and specify the ROOT_DEV

from lilo.conf man page:

"root=root-device
This specifies the device that should be mounted as root. If the special name current is used, the root device is set to the device on which the root file system is currently mounted. If the root has been changed with -r , the respective device is used. If the variable 'root' is omitted, the root device setting contained in the kernel image is used. (And that is set at compile time using the ROOT_DEV variable in the kernel Makefile, and can later be changed with the rdev(8) program.)"
 
Old 04-29-2010, 05:54 PM   #4
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Rep: Reputation: 201Reputation: 201Reputation: 201
I'm not sure at what point your boot is failing, but have you looked at /etc/fstab. It contains your mount point for the drives that get mounted at boot. It's possible that fstab is still calling the drive hdc1?
 
Old 04-29-2010, 06:11 PM   #5
aocab
Member
 
Registered: Nov 2009
Location: Heart of Texas
Distribution: Slackware-current
Posts: 138

Rep: Reputation: 30
@timetraveler,

you mention that when you tried to run lilo after making the change from hdx to sdx...that it failed...so I am assuming that when you ran lilo that you were still running under the older kernel?...and have not yet been able to boot into the new kernel?...

if the above is correct...and you are booting with a kernel that uses hdx (instead of sdx)...then change the entries in fstab to use hdx entries.

run lilo...reboot...and when you select the new kernel (the one that uses sdx)....press tab and add root=/dev/sdb1

that should get you in with the new kernel where you can then change the fstab entries to sdx...run lilo...reboot...

HTH
 
Old 04-29-2010, 08:08 PM   #6
timetraveler
Member
 
Registered: Apr 2010
Posts: 243
Blog Entries: 2

Original Poster
Rep: Reputation: 31
I edited /etc/fstab and changed the
/dev/hdc1 -> /dev/sdb1 and I can boot into the new kernel.

But now the same problem exists for the old kernel.

Which is ok for now since the new kernel is working.

I was not able to run lilo but it doesn't matter.

This is very funky.
 
Old 04-29-2010, 08:40 PM   #7
timetraveler
Member
 
Registered: Apr 2010
Posts: 243
Blog Entries: 2

Original Poster
Rep: Reputation: 31
Actually when I booted to the new kernel by pressing tab at lilo screen and adding root=/dev/sdb1
it boots me into a read-only system. Even though mount command shows "/" mounted read-write.

It has been really hard to get this all going. I don't have a solution but it seems to me that making the installation process easy should be important to the project.

Also I found that now that I'm in the new kernel that lilo -I does not work.

As a reminder I am installing to a 4GB CF card, I have no swap and I mount ext4 with noatime.
Perhaps this is an odd enough setup to be causing some of my issues.

Well at least I've got my custom kernel to support my hardware and I am now getting ready to
try X as I have just got the source for the display driver for VX800 - Chrome9 driver.

So lots of progress thanks to you all.
 
Old 04-29-2010, 08:44 PM   #8
timetraveler
Member
 
Registered: Apr 2010
Posts: 243
Blog Entries: 2

Original Poster
Rep: Reputation: 31
Just to close this out for anyone else that might encounter this.
rdev and recompiling with an altered ROOT_DEV in the kernel source (arch/x86/Makefile) did not
work as rdev and the kernel compile looked for the device but didn't find it. (i.e. /dev/sdb1)
 
Old 04-30-2010, 05:02 AM   #9
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,191

Rep: Reputation: Disabled
Quote:
Originally Posted by timetraveler View Post
I edited /etc/fstab and changed the
/dev/hdc1 -> /dev/sdb1 and I can boot into the new kernel.

But now the same problem exists for the old kernel.

Which is ok for now since the new kernel is working.

I was not able to run lilo but it doesn't matter.

This is very funky.
You can change /etc/fstab so that it works with both your old kernel (root on /dev/hdc1) and the new kernel (root on /dev/sdb1).

Use
Code:
blkid /dev/sdb1
to find out the UUID for this partition, and then use that to change the line in /etc/fstab that mounts the root partition.

Suppose that command returns this text:
Code:
/dev/sdb1: UUID="050a82e7-9346-4de9-953b-1d4e93973b9c" TYPE="ext3"
Something like
Code:
/dev/sdb1  /  ext3  defaults  1  1
would then become
Code:
UUID=050a82e7-9346-4de9-953b-1d4e93973b9c  /  ext3  defaults  1  1
This method is independant of device naming or filesystems and will help you make your computer boot with all kernels.

Eric
 
1 members found this post helpful.
Old 04-30-2010, 12:52 PM   #10
aocab
Member
 
Registered: Nov 2009
Location: Heart of Texas
Distribution: Slackware-current
Posts: 138

Rep: Reputation: 30
Quote:
Originally Posted by Alien Bob View Post
You can change /etc/fstab so that it works with both your old kernel (root on /dev/hdc1) and the new kernel (root on /dev/sdb1).

Eric
I was wondering about that.
Good to know.
Thanks
 
Old 04-30-2010, 02:15 PM   #11
timetraveler
Member
 
Registered: Apr 2010
Posts: 243
Blog Entries: 2

Original Poster
Rep: Reputation: 31
Thanks alien bob, er, uh, Eric, I will try that. That should solve the "rabbit holiness" of this issue.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] restore LVM VG after PV device names changed lurko Linux - Software 1 11-13-2009 08:11 AM
Did IDE block device label changed with Kernel > 2.6.27 ? maus Linux - Kernel 2 06-07-2009 03:28 PM
etc/fstab Device label changed cant restore the default device name shady_Dev Linux - Software 4 11-11-2007 11:00 AM
Device changed names after Kernel Update itz2000 Linux - Newbie 1 12-29-2006 02:12 PM
new kernel causes lilo crash; /sbin/lilo = Warning: device 0x0305 exceeds 1024 cylind dandysf Linux - Software 0 08-26-2003 04:50 PM


All times are GMT -5. The time now is 12:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration