LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Wireless USB init, Slackware style (http://www.linuxquestions.org/questions/slackware-14/wireless-usb-init-slackware-style-392945/)

Tylerious 12-14-2005 09:05 PM

Wireless USB init, Slackware style
 
I'm trying to setup a USB wireless card (Linksys WUSB11 v2.5) on my Slackware 10.2 box. I've finally gotten the linux-wlan-ng package to compile for my kernel, but I'm stumped when it comes to getting the darned thing to work. I've found various stuff online, all of which is for a different init system. For example, being told to edit the /etc/sysconfig/network-scripts/ifcfg-eth0 when I should really be editing /etc/rc.d/rc.inet1.conf, right?

So far, the card is plugged in and the prism2_usb module is loaded. wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable responds
Quote:

message=lnxreq_ifstate
ifstate=enable
resultcode=implementation failure
My kernel messages when I modprobe prism2_usb are:
Quote:

prism2usb_init: prism2_usb.o 0.2.3 Loaded
prism2usb_init: dev_info is: prism2_usb
usbcore: registered new driver prism2_usb
hfa384x_usbctlx_complete_sync: CTLX[1] error: state(Request failed)
hfa384x_drvr_start: cmd_initialize() failed, result=5
prism2sta_ifstate: hfa384x_drvr_start() failed,result=5
I also have a PCI ethernet card setup (eth0), so my /etc/rc.d/rc.inet1.conf looks like this:
Code:

IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""

IFNAME[4]="wlan0"
USE_DHCP[4]="yes"
WLAN_ESSID[4]=mynetwork
WLAN_MODE[4]=Managed

Sorry, such a long post. If there's anything else needed, please ask. I'll really appreciate any help.

Finlay 12-14-2005 11:22 PM

i use ndiswrapper for my usb wireless, works perfect, might want to try that.
i haven't googled that card so i don't know if it is a kernel supported device.

Hangdog42 12-15-2005 07:30 AM

The main problem with linux-wlan-ng is that it really doesn't use the normal wireless tools for configuring the card. However, Slackware (and pretty much every other distro) does use wireless tools for configuring wireless cards. My understanding is that part of the linux-wlan-ng package is its own set of configuration tools. Since I've never used it, I'm afraid that all I can say is you're going to have to read the documentation on how to configure.

Tylerious 12-15-2005 07:46 AM

Yes, wlanctl-ng is linux-wlan-ng's configuration tool. Unfortunately, it's not working.

My card has a Prism2/2.5/3 chipset, so it should be supported by both linux-wlan-ng and wireless tools/extensions. So how can I get my card to work with wireless tools? It's like it's not actually reaching the USB, like it doesn't know where the card actually is or something.

Can somebody using wireless tools post their working rc.inet1.conf?

Hangdog42 12-15-2005 11:54 AM

Quote:

My card has a Prism2/2.5/3 chipset, so it should be supported by both linux-wlan-ng and wireless tools/extensions
.

One of us is missing something here. The wireless tools interact with a driver (kernel module) and in this case it is linux-wlan-ng. Since that driver doesn't use wireless tools, you would have to use a different driver in order for this to work. As long as you are using linux-wlan-ng, you probably can't use wireless tools. From reading your thread, I'm assuming that you don't have a different driver. Is that right or is there another driver?

Tylerious 12-15-2005 02:45 PM

No, I wasn't aware there was another driver unless I use a Window driver with ndiswrapper. That option is looking better and better, but I heard ndiswrapper doesn't always support all of the wireless tools functions.

teckboy1243 12-15-2005 03:00 PM

;) Ndiswrapper = Good

I use ndiswrapper for my linksys WMP11 card is it works perfectly. I haven't expericened any loss of wifi tools

Tylerious 12-15-2005 08:21 PM

Okay, I must say ndiswrapper was very nice and easy. I can load the driver (I think) and view it's settings with ifconfig and iwconfig. Unfortunately, my setup seems a little screwy. I can't change the frequency from 24.37 MHz. It doesn't seem to be getting an IP from the router's DHCP (the ethernet still does).

Dmesg after modprobing ndiswrapper:
Quote:

ndiswrapper version 1.7 loaded (preemt=no,smp=no)
ndiswrapper: driver lswlusb (Linksys,) loaded
wlan: vendor: 'Instant Wireless USB Network Adapter ver.2.5'
wlan0: ndiswrapper ethernet device 00:06:25:xx:xx:xx using driver lswlusb, 066B:2212.F.conf
ndiswrapper (set_auth_mode:686): setting auth mode to 3 failed (C0010015)
wlan0: encryption modes supported: none
usbcore: registered new driver ndiswrapper
This could mean the driver doesn't really work, right? It's the one from the Linksys website. My card isn't listed on the ndiswrapper wiki, so I'll try to find another driver and see how that goes.

Finlay 12-15-2005 08:29 PM

the ndiswrapper website lists chipsets and where you should get the drivers from.
the driver from link sys may not work because it may be hacked by link sys. it is best to get the basic driver from the chipset vendor

Tylerious 12-15-2005 09:38 PM

Intersil, who made the chipset doesn't appear to offer drivers. I found a different driver from Linksys that appears to work at least slightly better. For one thing, my frequency is right.

How can I get the DHCP to recognize my wlan0 and issue an IP?

--
Edit:
Okay, dhcpcd was only running for eth0, but not wlan0 as well. A simple `dhcpcd wlan0` fixes that. Slackware should change their init scripts to it runs dhcpcd for every interface.

Thank you guys for all this help; I've been through several headaches, but it's working! *happy dance*


All times are GMT -5. The time now is 10:36 PM.